OpenElec & LiberElec WishList

Yes, this is possible. The order of installation into the internal memory (eMMC) stock firmware of Android (NOT for dualOS). 1. All of the steps in the startup LE from the external media. 2. Be sure to check all the necessary functions for working with LE external media. 3. If you are satisfied with the job LE, then you can run the installation procedure to the internal memory. To do this, power down the system, connect the media LE to a PC. Find the media file “” and name it “install.aml”. Plug the device into an off TV box and include it. The system LE is automatically installed in the internal memory. After installation, the system will turn off VIM. Removable media and turn VIM. Next, a custom LE as usual. Pay attention that when you install this will erase all information from the sections “sysytem” and “data” in the internal memory (Android will be deleted from internal memory). If at the first start of system in eMMC memory you will get an error that is not found partition /dev/system , run the installation again from the external media. To do this, don’t forget to rename the file “”. After installation, the script “install.aml” automatically returns to its original name “” and the LE will run as usual with the media.

Thank you balbes150, it is working fine from eMMC now. :+1:t2:

Balbes150: Are u planning to update LE for Khadas Vim, when new releases are coming?

Updated the images LE 20170219. For those who have LE already installed in internal memory (eMMC), re-installation is NOT required. The difference of the new images from the former only in the installation procedure in the internal memory. No longer requires manual renaming script “”. It is sufficient to choose the desired menu item in the group “Off”. The system, on reboot, perform installation and copy all the settings from the external media in the inside memory. Pay attention that the new system install on the internal memory automatically copies all existing at the time of installation settings in the internal memory. This means that when you select the menu item “Install to internal memory eMMC”, all created on an external drive settings will automatically be copied to the internal memory. In the new system is not necessary after the installation to configure everything again.

Added option LE Jarvis for VIM.


I don’t know is here place for my question. If not please replace. Is there
possibility to install Acestream engine?

Try this method.

  1. Download
  2. Unzip
  3. Use a program like WinSCP to transfer the files to /storage/.config
  4. chmod 777 (right-click properties): and the folder acestream (please select recursive)
  5. reboot, wait 1-2 minutes
1 Like

Try it but not work.

Hi,I’m having problems trying to get LE onto emmc, got Vim_Marshmallow_Root_170121 on emmc, got LE 20170219 sd card. When I do
Android/Settings/About Device/System/updates.
From the Update and Backup App, under the UpdateLocale section, click Select, select, click update.
and it reboots, all I get is it stuck on the vim screen and no lights on vim need a noobs guide on getting it on emmc.
Thanks David

I haven’t tested the activation of the multi-boot on Vim_Marshmallow_Root_170121. Maybe it uses u-boot, which is different from what comes from the factory. Try to write an image LE on the USB flash drive and run from it. There is a possibility that the problem may be the compatibility of the SD card and card reader. This often happens on many TV boxes.

wrote the LE image to usb and does not work stays on the vim screen even tried burning image Vim_Marshmallow_161211.7z to the Kkadas vim but that comes up with error 99% 0x30405004 uboot partition system/verify patition error

Will there ever be a LE image that you can burn emmc

Finaly got LE on emmc, the way I did it burned Vim_Marshmallow_160928 to Khadas Vim burned LibreELEC-Khadas_VIM.aarch64-8.0.1_20170216 to sd card
renamed to install.aml then pressed power button on power
pressed reset then took finger off power after 3 seconds, Works great, It never worked with Vim_Marshmallow_Root_170121

Checked version Vim_Marshmallow_Root_170121. Write in VIM via a USB cable. Firmware went without problems. Recorded on the USB flash drive the last option LE for VIM (20170223 KODI 17.1). Launched Android and executed the launch of the upgrade (activation multi-boot). After two automatic reboots will automatically start LE. Checked its functions. Picked the menu off the last item “Reboot from the Install LE to eMMC”. After a restart LE will automatically set to the internal memory (eMMC). Pay attention that if you install to the internal memory when connected to configured on a USB flash, SAMBA network resources will be error, disable the SAMBA service, and restart the system and turn it back on. Configure the network connection. Perhaps in some cases, network resources are not properly authenticate when porting the system to another location. By the way, now, to install to the internal memory, neither of which hands to rename is not required. It is sufficient to choose in menu off mode, reboot with the install LE in the internal memory and the system will automatically restart and install LE in the internal memory. Note that automatic setting to the internal memory works so far only with Android firmware.

Ok I had the same problem as Radeon18. I couldnt reboot to Libreelec from android update. After using
a standalone USB charger, everything went without problem, Prior my Khadas Vim was plug in a USB port of my PC

I’m not saying that this behavior is not possible. I have described only what he carried out himself. Possible if you install additional applications (using the root) or change in the settings, the reaction to change.

Just same metod radeon18 used.
With this image LibreELEC-S905.VIM.aarch64-8.0.1_20170219.img
it works fine.

Do you know about an addon server url for s905(x) LE ?
Or is it better to just build addons oneself?

Hi balbes150,
How do I “stop loading u-boot”?

Hi. In the images already connected to the server with addons. Or do you need your supplements ?

These steps are written to activate the multi-boot, the console is connected via UART. When start VIM, have to press the spacebar to stop the run and control the u-boot manual.

which server URL for the LibreELEC aarch64 repository