Only Android images work on eMMC (Edge-V)

Yes. I did ‘Erase Flash’ in the AndroidTool before ‘Upgrade Firmware’.
I’m inclined to agree that the problem is hardware.
What’s the next step?

@TheHermit we can arrange a product exchange. At the same time, @kenny wants to verify one thing before that.

  • Take a photograph of your Edge-V with the HDMI, USB-C, and other cables plugged in when you encountered the green squares.

There is a known issue whereby if the HDMI and other cables are pressed against each other tightly, because the cable-heads are too large, users would then encounter HDMI graphical issues, artefacts such as loss of colour, green haze, etc. As you know, the Edge-V boards are very small, and the ports closely spaced together - so we’ve had some people experience this issue in the past.

I’m using the power USB-C beneath the USB2 connector, so they are not near each other.

Okay no other fat cables pushing against the HDMI? Did you attempt to use a different HDMI cable?

If all of the above is true / tried out, then its quite certain to be an issue with the onboard GPU, or some other sub-system related to the HDMI output.

1 Like

Yes I tried a 4k HDMI, too

This is what I’m seeing after it returns from power saver.
This is what happens during shutdown from either eMMC or SDcard. Notice the bottom half is okay, once lightdm has unloaded.

That’s odd. So the HDMI issue is intermittent?

Actually, it is very predictable. But, ~50% of the time, it will only be green instead of the multiple colored squares during startup, probably depending upon whether it is warmed up.
After ~15 minutes, the power saver blanks the screen, so I can move the mouse and everything looks and behaves normally.

That’s very odd. Just out of curiosity, do you have another screen lying around?

Only a 7" Raspberry Pi Touchscreen. I’m on it, but I need to untie cables and restart the EDGE-V. Could be a while, if I have to wait for the power saver. We’ll see.

Well no harm giving that a try too. Because if it is a hardware issue, the issue would (most of the time) be persistent.

Powered on fine. I’m at login. But, that won’t work for me. The touchscreen is for a Raspberry Pi project.

And the RPi screen is connected via MIPI-DSI and TP, and not over HDMI?

No. It’s connected to the same HDMI. BTW, the other monitor is a 50" Toshiba FireTV. I’ve use several other SBCs on it, including ROCK Pi 4, RPi 3B+, and RPi 4B+

Ok, the issue is unlikely with the Edge-V’s GPU. Could you play around with it in the “Rpi screen mode” for a while longer, and see if the fuzzy green squares appear again?

It’s not that we wouldn’t want to exchange your board, its just that you know the 2-way shipping will take a very long time, and be inconvenient for you.

Yeah, but I’ve already waited 3 weeks, just to get to this point. I’ve spent several hundred $ on the ROCK Pi POS. I really need to have the EDGE-V fully functional. Don’t mean to be difficult. But, I’m in no hurry.

Okay I understand. What is the resolution of the Rpi screen? The 50" Toshiba is 4K right?

Ithink it is 1080 x 720, if I remember corectly. Yes, the Toshiba is 4K. I purchased it specifically for the EDGE-V.

Okay play around with both the 4K and 720P displays for a bit, going from one to the other, and see if the issue recurs. I’ll ask @kenny for his feedback when he is available.

I’ve got a USB-C to HDMI adapter cable. Should I be able to use both outputs at the same time? Been wanting to try that.:thinking:
Ha! But, there is no panel and the debian swirl is off center on the touchscreen. Gotta mess with the resolution. But, let me try rebooting. Perhaps the DP works OK.
Looks like the DP is working normally. The HDMI isn’t connected and I moved the Toshiba FireTV to the DP.
The maximum resolution available on the DP is 1920 x 1080
But HDMI allows 3840 x 2160 @ 30 fps
HDMI behaves okay, as long as the DP is connected, too. With both outputs connected to different HDMI inputs on the Toshiba, The HDMI output is still 3840 x 2160, but the DP output is still only 1920 x 1080 (with no panel, so it’s pretty unusable)
YouTube videos on HDMI are very choppy, even @ 720p

Yes, see Edge-V, top, component 4. That USB-C port has Display Port v1.2 output.