Only Android images work on eMMC (Edge-V)

Yes I’m using the official firmware you provide for eMMC (the Ubuntu desktop one). Tried Edge_Ubuntu-lxde-bionic_Linux-4.4_arm64_EMMC_V20190116

Both, after upgrading firmware through USB C in Windows stay on red light steady, then white light blinks and reboots (this loop will repeat indefinitely).
I tried erasing flash and uploading firmwares but didn’t work. Android firmware works good.

When my USB - TTL cable arribes I will try to upload a U-boot Fenix compiled and see if it fixes it.

Yes, but the thing is “edgev” was working well for other people with an Edge-V but not working for me, I had to set up “edge” in the DTB that’s why I’m suscpicious there’s something odd in my bootloader.

@jgalt91 Did you use external power supply? This seems to be due to a lack of power supply, which has been restarting all the time.

Sorry for the late answer, I’m still waiting for the USB-TTL cable to try upgrading a new u-boot so didn’t check forum. Yes I’m using a 27W USB C power supply. I haven’t had any problems with it in Raspberry 3 and 4, or Edge-V with the right images (eMMC Android or SD-USB Ubuntu Desktop).

Edit: the power output modes are 5V 3A, 9V 3A, 12V 2.25A, 15V 1.8A, 20V 1.35A. How the PSU selects the appropiate mode, I really don’t know and can’t be chosen.

Hi @numbqq & @Frank, @tsangyoujun suggested that I bring this issue to your attention. Perhaps you don’t already have enough problems. :smirk: Also, it looks like @Frank has been addressing these eMMC image issues. Perhaps he would like to chime in. In fact, I invite anyone/everyone from Khadas to join in. lol

My problems are to do with upgrading the eMMC to Ubuntu on my EDGE-V. I’ve tried the 2 most recent Khadas dtb’s of Ubuntu desktop and the most recent dtb of server. ~90% of the boots only produce a blank green screen. ~10% (after reset button) produce a multicolored patchwork of squares (like a linear kaleidoscope). It looks like the HDMI is out of sync.
When I use the Power key to power down, there is terminal text scattered across the screen, until the Light Display Manager is stopped. Then, the sync problem also stops and the terminal text is displayed correctly until shutdown. (This also happens during normal shutdown from the Desktop GUI on both the SD card and the eMMC Ubuntu dtb’s.)
I’ve tried replacing the Light Display Manager, boot files, and .config files with files from a working SD card (from the same build date). Afterwards, I could see through three overlayed offset images that the eMMC boot had reached the desktop logon. So, I entered the khadas password and the sync issue magically disappeared when the login form refreshed. From that point, I was able to update and upgrade, create additional users, etc. Everything looked fine, until I rebooted. Then, the green screen returned… permanently. Unfortunately, I am unable to reproduce correcting the out of sync issue by logging on while it is happening.

Update: The out of sync display problem appears as soon as the HDMI drivers load, because the KHADAS logo and terminal text are fragmented, prior to LDM being loaded.
The Desktop may appear as solid green, a kaleidoscope of squarish colors, or 3 offset overlaid images of an otherwise functional desktop.
If I wait until the power saver blanks the screen, a normal desktop is immediately restored whenever it returns from sleep mode. (rather inconvenient😴)
I also noticed that the cooling fan was repeatedly revving up during sleep mode, until I logged on. Then, it immediately slowed to its normal speed. Temp is < 60 deg.:thinking:

Unfortunately, I’m a Linux novice and don’t even know what to grep. So, I apologize in advance.

Thank you for your assistance.:sunglasses:



@goenjoy sorry my bad. @TheHermit@numbqq and @Frank are more knowledgeable about this.

Okay, folks. I’ve been waiting over 3 weeks to determine whether I have a defective eMMC or a bad image. Surely, during the that time, someone else has downloaded a Khadas ubuntu image for EDGE-V, which would indicate whether any image problems are causing this behavior. A little feedback would go a long way.
Is there any way to check the eMMC memory, perhaps isolate defective locations?
I really don’t want to put the EDGE-V on the shelf next to my ROCK Pi 4B, just to collect dust.

I was able to load Ubuntu into the eMMC for both Server version and Desktop version. I’m not knowledgeable enough in Linux to build my own kernel so I used the most current version on the download section.
The issue I had was I had to user the USB upload method as I could not get an image loaded to an SD card to work, and I had to use a Windows 7 system to run the utility. Tried on multiple Windows 10 systems and could never get the driver to load correctly.

1 Like

I’ll go test it out. Which image was it that’s giving you issues?

From here, yes?

Thank you @tsangyoujun

…V20190830 I’ve tried both server and lxde images.

1 Like

Thank you for the feedback. Was that on the EDGE-V?
It’s been a while, but I think I had to format my SD card, before it would work. It is also very important to use a fast/quality SDcard.
I used Balena Etcher to flash the SDcard. Contrary to some documentation, I don’t need to use TST mode or anything to boot from SDcard. Simply insert the SDcard then power on.
Also, the SD image is a different download from the eMMC image
Hope this is helpful.

@TheHermit, I did the cookie-cutter installation method on an Edge-V Max and all worked well. Please see this video for reference:

Chosen Image:

Image Downloaded From:

Installation Instructions:

Yes, that’s the same image firmware and procedure using AndroidTool.exe.
Thank you for verifying that the image is fine.
As I previously mentioned, the image installation went okay. But, I’m having display issues. Please review my post above from 3 weeks ago for details.
I’m inclined to think the issue is a defective eMMC memory location. But, that doesn’t explain the out of sync terminal text, while shutting down from SDcard. But, that’s not really any concern, because it only happens during shutdown. Plus, once the eMMC is working, I won’t be using the SDcard.
Does HTOP indicate if there is defective eMMC locations?

Unfortunately, I am not a Linux expert too. Though I did find this method of hard disk analysis (unsure if this applies to EMMCs). Maybe @hyphop has an idea of which tool available in Linux can do a check of your EMMC.

I think you are being very modest and know more than you realize. So far, you have been the most helpful CSR for me.:call_me_hand:
This looks very promising. I’ll try it as soon as I can log in (after the power saver kicks in).
Will let you know the results.
Making progress, but not there yet. (not holding my mouth right?)
Tired . Will try again tomorrow.

1 Like

Yes, Edge-V. My guess is that I had the SD card with the wrong format. I’ll retry this weekend, but right now the Edge-V is booting from eMMC into the Server eMMC version of ubuntu just fine. Thanks…

1 Like

While trying to use smartctl and fsck, on eMMC, SDcard, & nvme, I only received errors stating that the device is in use, but I’ll try again after unmounting the devices.
I also noticed that my eMMC file system is Type 88 Linux. While trying to verify if this is correct, I have only found 2 posts which only mention SD formats, ext4 & Type 83 Linux.
What is the correct file format for the eMMC?
UPDATE: Gparted indicated that mmcblk1p1-p6 had errors due to no file format. So, I formatted them to ext4. That bricked the EDGE-V. So, I uploaded the image again. But, that only returned me to exactly the same problem.
Gparted indicates again that mmcblk1p1-6 have unknown file systems. p7 (rootfs) is ext4, as before.

Why not just do a clean wipe and install everything again? The official image does not appear to have any issues with the emmc file system. If you’re having an issue with the HDMI, maybe the SoC is borked? (we don’t encounter fuzzy green squares on a regular basis) :smile:

Yes. I did ‘Erase Flash’ in the AndroidTool before ‘Upgrade Firmware’.
I’m inclined to agree that the problem is hardware.
What’s the next step?

@TheHermit we can arrange a product exchange. At the same time, @kenny wants to verify one thing before that.

  • Take a photograph of your Edge-V with the HDMI, USB-C, and other cables plugged in when you encountered the green squares.

There is a known issue whereby if the HDMI and other cables are pressed against each other tightly, because the cable-heads are too large, users would then encounter HDMI graphical issues, artefacts such as loss of colour, green haze, etc. As you know, the Edge-V boards are very small, and the ports closely spaced together - so we’ve had some people experience this issue in the past.