On but no picture appears

After a few days of use, the unit has stopped working, the red light turns on but no image appears, the hdmi cable and power supply have been replaced but the problem has not been solved.
Font used 5v 2a.

Sorry, I’m using google translator.

Hi, Divino:
Can you describe more details on the problem you met?

Basically, would be better to feedback issues like this:

  • Tell us the ROM version you installed or try to install
  • Tell us the hardware date code, i.e. Vim V1.2 1610 4916
  • Describe all the procedures(step-by-step) you did with details
  • Provde neccesarry photos to help us better understand the issue you are facing
  • If you are a developer, post the full printing log
  • Others information you thought would be helpful for us
  • If you are facing many different problems, please create different topics one by one, we will also reply one by one.
  • If your problem has been fixed, please follow the Problem Solved Button to mark it as solved


version ROM try to install: VimPro_DualOS_Marshmallow_Ubuntu-16.04_170124;
hardware date code: Vim v1.2 1610 4916;
rocedures(step-by-step): http://docs.khadas.com/bootcamp/CreateBurnCardViaCLI/.


Keys Mode(U-Boot is running)
Power on Vim.
Long press Power key without release
Short press ‘Reset’ key and release
Count 2-3 seconds and release the ‘Power’ key to enter into upgrade mode

Does not work, the android recovery screen always appears.

The system did not try to make an update, I could not enter update mode, I just put the card and I livied the Vim, after this nothing appears on the screen, nor the Vim logo.

Sorry, I’m not quite understand that put the card and livied the VIM? Can you kindly explain on this?

BTW, does your VIM model is Pro one? note that the DualOS ROM is only for VIM Pro.


Bom vou tentar detalhar o que fiz, passo a passo.
1ª - Utilizei o aparelho originalmente por alguns dias.
2ª - Baixei essa ROM (VimPro_DualOS_Marshmallow_Ubuntu-16.04_170124)
3ª - Baixei o U-Boot na mesma pagina que a ROM.
4ª - Queimei a ROM para um MicroSd utilizando este processo (http://docs.khadas.com/bootcamp/CreateBurnCardViaCLI/)
5ª - Coloquei o MicroSd no aparelho.
6ª - Tentei por varias vezes entrar em modo de atualização, apertando o botão power seguido do reset, sem sucesso, o aparelho sempre cai na tela de recuperação do android.
7ª - após algumas tentativa de fazer o aparelho entrar em modo de atualização o aparelho parou de mostrar a imagem.
8ª - Fiz testes trocando os cabos hdmi e o monitor.

Obs: Tem algum processo que eu possa fazer pra voltar as configurações de fabrica do aparelho?

Well I’ll try to detail what I did, step by step.
1 - I originally used the device for a few days.
2 - Download this ROM (VimPro_DualOS_Marshmallow_Ubuntu-16.04_170124)
3 - I downloaded the U-Boot on the same page as the ROM.
4 - I burned the ROM to a MicroSd using this process (http://docs.khadas.com/bootcamp/CreateBurnCardViaCLI/)
5 - I placed the MicroSd in the device.
6 - I tried several times to enter update mode, pressing the power button followed by reset, without success, the device always falls on the android recovery screen.
7 - after some attempts to make the device enter into update mode the device stopped showing the image.
8 - I did tests replacing the hdmi cables and the monitor.

Note: Is there a process I can do to return factory settings to the device?

I was reading the documentation and I think I deleted the EMMC ROM by accident by pressing the power and function button at the same time.
How to proceed to save a new android version in EMMC?

Take it easy, I think you just upgrade ROM in a wrong way, you device still works.

Can you kindly tell me which model do you have?

  • VIM: 8GB EMMC + AP6212 WIFI
  • VIM Pro: 16GB EMMC + AP6255 WIFI

Keep mind that if your device is VIM model, the DualOS ROM which is only for Pro model will not work on your device.

Well, you can follow the instructions below to let your device work again:

1) Follow the Upgrade Via a USB-C Cable instructions
2) Instead the red-circled-steps below, follow the MRegister Mode method to one to let your device boot into upgrade mode:

If any problem, just let us know.

Good luck!

My version is:VIM Pro: 16GB EMMC + AP6255 WIFI,
Thank you for the answer, l’ll try procedure.

Okay, I got the update. I updated with dualboot, but Linux is freezing So I decided to update only with android, everything worked fine.
Very much obliged by the aid.

1 Like