NVMe SSD Support for Edge-V


I want to add the support of my SSD in Edge-V (ANDROID PI).
SSD details are mentioned below.

NVMe SSD 960 EVO M.2 (250GB) from SAMSUNG.

We have verified this model. It’s OK.

Does it get auto mounted after connecting to the board ??
Because initially we tried but we had to mount it manually.


I tried your ROM and it seems to be working.
So, could you please provide a SDK patch related to SSD(PCIe) only.

There is no corresponding patch. But you can make this patch.

cd .repo/manifests
git log
git show cca563bea5614ef124acc61139c828613e2c0943

You can see the modification record.

Okay, Thanx
Will let you know after building the source

Do these modifications also need to be applied to the EDGE-V, running Khadas’ most recent dtb of Ubuntu Desktop?
I have a 1TB Samsung EVO 970 Plus NVMe SSD, but lsblk doesn’t show it.


Please check whether /dev/nvme0n1 exist or not. If it exist, you can use fdisk to add partitions and format it.

Thank you for the reply.
lsblk does not list /dev/nvme0n1. The SSD does not appear in gparted, either. It was last used on a Rock Pi 4B and has already been partitioned and formatted, with data.
lsblk shows 4 ZRAM’s with 256 MB each. Is that normal?

Check ll /dev/nvme0n1

Thanks for your reply.
I should have mentioned that I’m using the M2x extender board. Does PCIe or the M.2 need to be enabled?

‘ll /dev/nvme0n1’ #returns:
‘ls: cannot access ‘/dev/nvme0n1’ No such file or directory’

I have managed to create an Armbian SD boot card (was trying to upgrade eMMC). Armbian returns the same msg.

BTW, regarding the HDMI out of sync issue with eMMC dtb’s, the Armbian boot SD card has the same HDMI behavior as the Ubuntu dtb’s boot SDcard. The display is fine until shutting down. Then, there is terminal text scattered across the screen, until light display manager is stopped. Then, the terminal text is normal until shutdown. Of course, the true test would be what happens with it running on eMMC.

Hello @TheHermit

Can you update the kernel and try again?

khadas@Khadas:~$ sudo apt-get update
khadas@Khadas:~$ sudo apt-get upgrade
khadas@Khadas:~$ sync
khadas@Khadas:~$ sudo reboot
khadas@Khadas:~$ lspci
khadas@Khadas:~$ dmesg | grep nvme
khadas@Khadas:~$ ll /dev/nvme0n1 


1 Like

hermit@Khadas:~$ sudo apt-get update
Err:1 https://dl.khadas.com/repos/edge bionic InRelease
Could not resolve ‘dl.khadas.com
Err:2 http://ports.ubuntu.com bionic InRelease
Could not resolve ‘ports.ubuntu.com
Err:3 http://ports.ubuntu.com bionic-security InRelease
Could not resolve ‘ports.ubuntu.com
Err:4 http://ports.ubuntu.com bionic-updates InRelease
Could not resolve ‘ports.ubuntu.com
Err:5 http://ports.ubuntu.com bionic-backports InRelease
Could not resolve ‘ports.ubuntu.com
Reading package lists… Done
W: Failed to fetch http://ports.ubuntu.com/dists/bionic/InRelease Could not resolve ‘ports.ubuntu.com
W: Failed to fetch http://ports.ubuntu.com/dists/bionic-security/InRelease Could not resolve ‘ports.ubuntu.com
W: Failed to fetch http://ports.ubuntu.com/dists/bionic-updates/InRelease Could not resolve ‘ports.ubuntu.com
W: Failed to fetch http://ports.ubuntu.com/dists/bionic-backports/InRelease Could not resolve ‘ports.ubuntu.com
W: Failed to fetch https://dl.khadas.com/repos/edge/dists/bionic/InRelease Could not resolve ‘dl.khadas.com
W: Some index files failed to download. They have been ignored, or old ones used instead.

hermit@Khadas:~$ cat /proc/cmdline
storagemedia=emmc androidboot.storagemedia=emmc androidboot.mode=normal wol_enable=0 earlyprintk console=ttyFIQ0,1500000n8 console=tty0 rw root=UUID=bae3ae94-61a8-4ba8-86f1-ce1d5bd08b71 rootfstype=ext4 init=/sbin/init rootwait board_type=2 board_type_name=Edge-V fan=auto mac=00:00:00:00:00:00 androidboot.mac=00:00:00:00:00:00 coherent_pool=2M image_type=EMMC
hermit@Khadas:~$ uname -a
Linux Khadas 4.4.179 #1 SMP Fri Aug 30 14:28:24 CST 2019 aarch64 aarch64 aarch64 GNU/Linux

@TheHermit Internet issue? Please check your network.

I’m on line now. Update is happening.:sunglasses:

It seems a network issue. Can you access the internet?

Just completed upgrade. Okay, I’ve run the other cmds. But, rebooting will take ~10 minutes until power saver kicks in and I’m able to get to the desktop.
I’ll see if I can shorten the power time interval.
nvme isn’t there yet.
back in a few .
Thanks for your patience.

OK, I’m finally back. Looks like I have no control over when power saver kicks in. Sorry.
OMG! I’ve got an NVMe!
Thanks, @numbqq! Well done!:clap::clap::clap: