No Wifi support after install ubuntu-5.3-rc4

Install Ubuntu bionic with 5.3-rc4 from SD card

Only eth0 NIC:
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP group default qlen 1000

Only eth0, no Wifi devices.

This might solve your problem

Hi @Electr1,

But actually there is no wifi devices showing on my ubuntu. I suppose it lacks of Wifi driver or so.

Regular ubuntu does not have these drivers,
but server version does have wifi working
you can install ubuntu server and download a desktop environment like KDE or XFCE
if you like KDE there is a prebuilt image of kubuntu (ubuntu with KDE) available for download

1 Like

@Electr1 Hey, thanks for the info. I’ve install the ubuntu server and it has the wifi drivers.

But one more issue I find, all the USB devices are not working in this release with ubuntu 5.5-rc2.
Either the USB HDD drive or the USB mouse/keyboard

root@Khadas:~# lsusb
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

Hmm, will see that and have it tested and bring you a solution.

by the way may I know the current firmware you are using and whether you are using a Desktop Environment on top of the server,

are you using USB or SD card to boot

and finally did you get that lsusb readout with the devices connected ?

I tested it on my system with a desktop environment and it seems it works on that with no problem
I do note that it asks you to mount the disk to read data from it,
So there might be a problem on your side.
maybe don’t cold plug the devices and see if that works? :man_shrugging:

Can you check 5.5 kernel which add Wi-Fi support for VIM3.

That is not the current problem he is running that firmware only,
it seems to be the problem with connecting USB devices…

@numbqq @Electr1 Yes now I use the 5.5 kernel it has WIFI support, but both code plug and hot plug both do not have any info or notify and when I lsusb, there are none devices.

But I tested on 5.3 kernel, this one can support USB, but does not support WIFI

@kevinz do me a favor, if you do not have a problem please try my Kubuntu image,
it is based on the Ubuntu 5.5 kernel use it and see if you still have USB recognition problem,
yesterday i tried it on that only and it worked fine with no problem.

Hi, I’ve installed your Kubuntu 5,5 kernel.
khadas@Khadas:~$ lsusb
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

Hot plug and code plug USD devices, no any info for connecting USB devices.

are you using windows if so,
open The app called Remote desktop (it is already on a windows computer)
and enter the IP address of the VIM3 you use to SSH into it
you will get a blueish screen. go ahead enter the regular credentials for login (user khadas, Passwd khadas)
you will get desktop display of Kubuntu
it is like screen mirroring.

you can further procced to see if any USB devices are connected such as hardrives and will be prompted to access the drives data

tell me if it works
this for the kubuntu firmware

Hi @Electr1 sorry for late response. I’m doing some internal works recently and do not have time play with it. Today I tried another time with Kubuntu 5.3, and I find that the Wifi still do not work.


Did you SSH into it ?

@Electr1 of course, I use the cable network to ssh into it.

@kevinz Here’s what I want you to do,

first: make you have successfully burned the Image to a SD card or USB pendrive (Kubuntu)

Second: make sure you have connected the required peripherals, SD card, pendrive, ethernet cable etc.


Three: assuming you have windows 10 as OS, use the app called Remote desktop to login to the device (first enter the IP address , you will be greeted in to the lobby and you can enter the credentials, then you will get a virtual display simply connect to your WiFi, with the GUI app present in the bottom right corner

that’s it

maybe it will be superfluous for WiFi? :slightly_smiling_face:

Yeah but it is one of the ways I could suggest to easily, connect to WiFi with a GUI :stuck_out_tongue:

Or just do this