No output from serial port with VIM3L

I’m using VIM3L. I followed the instructions

But there is no output on the terminal. What the cause could be?


Hmm, will check and see I will tell you by tomorrow, what was your debugging tool (cable) and host PC software like putty ?

did you use the correct (linux_TX &linux_RX pins)? ,
did you set the correct Baud rate on your computer ( 115200 b/s )

I think so.

TXD -> pin 18
RXD -> pin 19
GND -> pin 17

I think I set it baud rate correctly. I use the .kermrc file with the commands from the instructions.

Forgot to mention my USB to serial adapter is based on ARK3116T.

what is your host machine for this operation, what is the terminal software like putty etc.

I use Debian buster AMD64 as my host machine. I installed ckermit from stretch release since buster does not have it. I also tried minicom. Neither works.

guess its another job for the big guys, @Frank @hyphop @RDFTKV can we get some help here as well, sorry @jzhang918 in my experience has never experienced something like this I have tried my best, but please keep updating !

1 Like

It works after I switched TxD and RxD, i.e. connect TxD of the adapter to pin 19 and RxD to pin 18. Maybe the labels on my USB to UART cable are different to other cables. So now I can see the boot messages through serial terminal. Thanks.

1 Like

Hello, Those pins look correct, however, try swapping 18 & 19 just in case the serial adapter has a variation in pin assignments. So far, I have only used serial to usb tools with the following chips, PL-2303 and CH340G, as a result I cannot offer any other tips on the ARK3116T.

Timing :grin:. Sorry, glad you got it going.


I hope you got it @jzhang918,
it is very frustrating when you swap the orientation of UART pins and you get nothing, the same goes for setting the Baud rate as well, if you get it wrong then the terminal starts spewing gibberish and you might as well bang your head in the door figuring why it happened,
p.s. I have gone through this many times and I am just venting out my views, #Arduinolife

glad it worked for you :smile:

1 Like