No HDMI signal after reboot

there is no signal to the monitor via HDMI
the white indicator lights up all the time
the reset button can restart system, but still there is no HDMI signal.
The radiator is warm
booting from the SD card does not work
What to do?

Hello, Have you tried a different HDMI cable?

@smatsak what firmware do you have on the eMMC perhaps you have a corrupted image? and also check the HDMI connector, if it wiggles too much it could spell out any hardware damage…

The HDMI cables have nothing to do with this
I tried different cables. The result is the same.
Rather, the problem is in eMMC.
I was trying to install an alternative Linux.
I formatted eMCC as a single MBR ext4 partition
After the reboot, the HDMI signal disappeared.
There were two unmarked partitions on eMCC - perhaps this is important for VIM3
I have not found a description on this subject.

That is a lot of information that would have been helpful to include in your OP. As it was, all we knew is HDMI would not display after a reboot. Always a good idea to include all relevant information to the issue , specially if you have made changes to hardware or software. I believe Electr1 will be able to help you now.
Good luck.

Installing an alternative Linux was not my whim.
This is a business assignment from my employer.
After fixing VIM3, I will have to install Alt-Linux.
Otherwise, I wasted my money.
I understand that the only person who can help me is Electr1.
I will wait and hope for his help.

I do not think he is the only one who maybe able to help you, others may be able to as well. For instance, @numbqq, @hyphop and @Frank.
You may want to search the forum using term “AltLinux” and see if it produces any useful information.
I hope you find a solution.

The developers of Alt-Linux have already told me how to install Alt-Linux.
This can most likely be done even through your Krescue tool by specifying the desired image to it.
I have already downloaded an Alt-Linux image for VIM3.

It remains to fix the VIM3 itself.
I am waiting for instructions from your engineers.

The developers of Alt-Linux said that it is important for VIM3 that the file system on eMCC has the ROOT label.
I did everything myself without instructions and did not know about it.

@Electr1 , @numbqq, @hyphop and @Frank.
Dear engineers, you were recommended to me as professionals in solving complex problems with VIM3 hardware and software.
Could you help me solve the problem with my device, or is it impossible and now it’s just a monument?

Hello @smatsak

Please follow this documentation to flash the latest Android image to check the HDMI issue.


1 Like

Thank you very much, it was not easy, but I returned, with your help, control over the device.
I managed to do this only through M register.

1 Like

TST will be more easier. :wink:

It is possible, but in my case, of all the combinations from the instructions, only the reset from the buttons worked.

The problem is solved.
Now I can restore the VIM3 boot even in the most severe cases, when the boot from the SD card does not work and there is no HDMI signal on the monitor.
Special thanks to @numbqq, :slight_smile:
But that’s not all, I couldn’t put an alternative Linux, to discuss the problem with installing an alternative Linux, I will open a separate task.

1 Like

OK. Please open a new topic.