No audio from Toneboard connected to Vim2

I have connected a toneboard to a vim2 (v1.2) and cannot get it to produce any audio. The toneboard is selected as the proper output device, and have tried both the digital spdif output as well as the analog RCA connectors without any luck.

I’ve flashed numerous images, form android to ubuntu without being able to get any sound from the toneboard. If I connect it with USb to windows 10, it works without any trouble. Amy I missing something?

Hello, I have not had an issue when TB and VIM2 are connected.
Is the power supply you are using 5 volts at 2 amps or better?

I am powering the vim2 with the supplied usbc cable along with the 24w khadas branded wall adapter. Power should be ok I would assume to power both the Vim2 and the tone board


If you mean this 24 watt PD power supply, I do not believe that Power Supply should be used with the VIM2, it is only for the VIM3 and Edge SBCs.
The Khadas Power Supply for the VIM2 is this one.

I do not think I would continue to use that 24W supply on the VIM2.

Sorry, yes I quickly searched the wattage without confirming it was the actual one I had, I am using the one you linked here: for the vim2. sorry about that.

No worries. That should rule out the power supply, but if you have another suitable supply give it a try.
As I have not had your issue, not sure what else to try.
Does the TB’s LED come on when connected to the VIM2?
May also check Android audio settings and set to Auto. Check volume levels.
Are you are using the same patch cords when testing TB with Windows and when TB is mounted to VIM2.
I know some of these sound basic and obvious, but sometimes that’s the stuff that gets us.:grin:

Haven’t tried another wall adapter, but it seems to power the tone board as far as I can tell. LED on the tone board lights up, ubuntu detects it as expected. have tried different usb cables, but the same one worked with a laptop as I am using with the vim.

Appreciate the help, will see if I can trouble shoot some more, otherwise it’s working well enough connected to a raspberry pi for the time being to stream audio from Roon.