New vim4 wifi antenna cannot connect

I just received my VIM4 module today and began setting it up. I have discovered that I cannot seem to plug the bluetooth and wifi antennas onto the board. After trying several times from various angles, I took a magnifying glass and looked at the board connectors and the wired connectors and to my shock they all appear to be male connectors.

By this time the connectors on the board seemed to be bent up, so I have set that aside and will speak to customer support about where I go from here.

In the meantime I have been trying to use a USB wifi adaptor to at least see what the board can do, but the VIM4 will not recognize any other wifi besides its internal (that I cannot get an antenna hooked to). I have tried several different adaptors with no luck.

I saw several threads where other people were trying to connect wifi dongles to USB without luck.

What can I do from here?


These look like typical micro coax MHF4 connectors. They may look like both sides are male, but the antenna end is actually recessed in the centre to allow the pin on the board to fit into it. Found this on YouTube, hope it helps: How I connect MHF4 RF connections the easy way yes it’s cheating - YouTube

I have not tried but wonder if the gigabyte LAN works instead of wireless? Don’t know if you have a spare port or cable lying around but probably worth a try.

I could never get them to seat properly. With other connectors there is a point where the seat, but these never seated. The connector body is also very thin metal so after a few tries it had bent in which caused me to start inspecting more closely. I’ve worked with the mini connectors before so I presumed khadas sent the right stuff but no. I just gave up at this point. I’ve emailed customer support.

I only have the usual wifi dongles. The problem is that the Khadas board seems to have Wifi locked down specifically to their broadcom interface and won’t even look to see if there is a different one via usb (or perhaps, they have a special driver that does that). In any case, everytime I try to select a wifi source it is only the broadcom that responds and of course, sees nothing.


I need to a use a magnifier, have some one hold your phone camera and zoom it up. They are small and tricky. Just use 2 hands, one to center the connector and your other hand to apply downward pressure with a small tool.

What OS are you running.

for ubuntu here are some tools

$ nmcli device show wlan0
$ nmcli connection show
$ nmcli dev wifi list

Good light, a jeweler’s loupe, and this video worked for me.


1 Like