Need help keep trying this for many days now

Had followed your above advice. Now only has dark

screen.But no reboot. Repower many times by unplug and plug the adaptor, still dark screen.
What else I can do ?

About how to boot ubuntu from the SD card,you can look this link:

You need to check step by step.
I think it may be caused by the sdcard format.
You can try to format the sdcard as fat32

Dear Terry,
I have tried following firmwares :

  1. ubuntu desktop
  2. android root
  3. arch linux
  4. LibreELEC
    All fail to reboot except LibreELEC which booted flawlessly. Unfortunately wifi not working for LibreELEC. I have no choice now but wait 'till someone more clever than me pointing out how to boot into other OS. I now enjoy Kodi via wired connection.

Hi, Bengt:
Did you notice the new LibreELEC ROM released? The WIFI is supported now.

About booting issue:

  • Tell us the Ubuntu desktop ROM version you installed
  • Tell us the arch linux ROM you installed

And about the u-boot, which version did you used?

ArchLinux : archlinux_4Gb_20161201.img

Ubuntu : armbian_5.24_amlogic-s905x_ubuntu_xenial_3.14.29_desktop_20161223.img

bootrom :

Thank you in advance.

Where you download the or you compile by yourself?

No,I downloaded it from your site.
If any alternative bootloader available ?

Try the new u-boot for Android & Armbian-ubuntu, and kindly feedback to us.


Works like a charm. I wrote ubuntu-desk top image with your new bootloader above. It works perfectly. Please tell me how to write into eMCC. So it will be started up quicker.


Additional information : your above new bootloader can not boot

  1. Arch Linux
  2. Android root
    More over ( from my short experiment today) , Ubuntu booting on Khadas VIM, IS EASILY HANGED ( in 20-25 minutes from booting). It is just simply freeze and cannot do anything except reboot.
    Thank you.

Android ROM, take a notice that:

  • u-boot.bin: is for eMMC Installation
  • is for SD card installation

Arch Linux, I’m not quite sure, as:

  • Different OS might requite different cmdline for it
  • You can built the u-boot from source code for Arch Linux image
  • Just take a notice that there are similar docs on Khadas Docs

Ubuntu freeze issue: did you already erase the eMMC storage first?

This morning I tried install u-boot.bin as you suggested for install Ubuntu into eMCC. But only get black screen. It does not boot. It is for Android only? What’s about Ubuntu u-boot.bin? Do you have one ?
FYI: I already delete eMCC as per your prior suggestion. So it is not related to the freezing of Ubuntu OS.

Has also tried install Android both rooted and unroot images. No luck.
Both with u-boot.bin did not boot. Only have black screen after 2-3 of screen flipping. Any comments or suggestions?

Will release Ubuntu-server ROM in a few hours, kindly test again there.

BTW, would be better to feedback issues like this:

  • Tell us the ROM version you installed
  • Tell us the hardware date code, i.e. Vim V1.2 1610 4916
  • Describe all the procedures(step-by-step) you did with details
  • Provde neccesarry photos to help us better understand the issue you are facing
  • If you are a developer, post the full printing log
  • Others information you thought would be helpful for us
  • If you are facing many different problems, please create different topics one by one, we will also reply one by one.
  • If your problem has been fixed, please follow the Problem Solved Button to mark it as solved


1 Like

Happy new Year! Rooster year, wish you luck and success.

I’ve got the 16Go/Wifi AC board.

Any chance you could explain how to boot and use directly Linux from the SD Card?

as I only see ROMs that upgrades the EmmC memory. I don’t want that, I only want to boot and run Linux from the SD Card.

Thank you

Hi, PeFar:
Check the topic for details.

PetFar, Let me know if you need help with this.

1 Like

Hi Thank you for your assistance,
I used Armbian_5.24_Amlogic-s905x_Debian_jessie_3.14.29_desktop_20170201.img from
burn the mage through unetbootin-windows-625.exe to Micro SD card and pressed long “Function” button during boot. But the box only boots on Android (installed on EmmC)
If I read a bit on this forum apparently I need to install uboot or something but I’ve got only a PC or a Mac no Linux machine :frowning: (it’s why I used unetbootin, naively thinking it would work … by a miracle)

1.) Format an SD card to FAT32. 4GB minimum( I generally use 16 and 32 cards), Class 10 or better recommended. The faster the better.
2.) Download and extract the file, the extracted file will be an image. I use 7Zip for extraction.
3.) Burn the image to the SD card. I use HDD RAW(portable ver.). Programs like Rufus or Win32DiskImager, etc should also work. Caution with HDD RAW, make certain you select the SD card as the target, HDD RAW will write over anything. It does have a couple of confirm notices, but be careful anyway.

To Run with prepared card: A few things take place, it does not just boot to Linux first go round.

1.) With the TV box running Android, insert the prepared card in to the box’s SD slot or use a USB card reader.
Note: I like to use a card reader with activity LED, so I can see something is happening. The first boot can take a few minutes and the flashing LED is reassuring.

2.) At Android/Settings/About Device/System/updates.
-From the Update and Backup App, under the UpdateLocale section, click Select, select, click update.
Note: Leave “Wipe Data” and “Wipe Media” unchecked/unticked. To be clear, do not use those options

-The TV box will reboot, it will do so a couple of times.
-Eventually you will see the initial login prompt.
Initial login credentials, See here for login info on the different images. Latest images will also be at that link.

-You will be asked to select a new password, do so. You will be asked to create a new User and P/W, do so.

-The box will reboot, this boot will be a bit slow, but ultimately should bring you to the desktop.
If the card’s available space does not get expanded, use gparted(may need to install) to expand the Ext partition to fill the card. A video to show how to use gparted for this, has been kindly provided by balbes150. See video here.

More info can be found in this Khadas thread.

Let me know if you have questions.


27 posts were split to a new topic: Voices from user confused