MultiOS_3in1 (Android+Libreelec+Linux) install to eMMC


Balbes150 thanks for your help.

Meantime and after figth with the software I figured out how to get out of the Android and switch to LibeELEC or Linux.
This are all working very well.:grin:

Thank you for your work and development of ROMs for Khadas.


Please to those who have installed version MultiOS_3_in_1 (VIM1 or VIM2) is connected to the console UART or SSH test this test image.

The procedure of verification.

  1. Download archive.

  2. Unpack it.

  3. Write the archive to any media from 4 GB (SD or USB).
    Pay attention to record the file need a special program, the same as recorded image Armbian Libreelec etc.

  4. Add the dtb file. For VIM1 S905X it is recommended to use the file “kvim_multios”. For VIM2 S912 - file “kvim2_multios”.

  5. Connect the device and turn the power on.

  6. Within 3-5 minutes the system should start. Pay attention to the monitor\TV will NOT have any image, screen is black.

  7. To verify that the system is fully running, in the UART console, press the “Enter” key, in response, a new prompt should appear on the grille ( # ), this prompt is from the UART console that you can run the command.

  8. Execute the command

gst-play-1.0 /root/test1.mp4

After a few seconds, the image and sound should appear on the screen. After playback is complete, run the following command

gst-play-1.0 /root/test2.mp4

The image should appear (doesn’T make any sound, this is normal).
9. Run the "poweroff"command to shut down.

Very is welcomed - check on hardware 4K.

It is also advisable to check the commands

kplayer /root/test1.mp4


kplayer /root/test2.mp4


The second test version with kernel 3.14.

If you are using this version on VIM1 and VIM2 models with MultiOS_3_in_1 systems installed, you may choose not to copy to manual dtb. On startup, the system will automatically use the dtb from the eMMC. Command to verify similar to that described earlier for the version 4.9.76. To run your test files from the video, you can burn them file to media and specify their name file when you run the player command.

Both test images can be run on the latest versions of Android\Ubuntu firmware for VIM and VIM2.


Updated GSTPlay image 20180220 with kernel 4.9.76.

Added the ability to control via SSH. Changes in this image. After starting the system, you need to wait for the screen saver. You can then connect using SSH. Before playing the video, you need to disable the splash screen by command.

/etc/init.d/S90dfb stop

As part of the added MC. To connect via SSH you need to use login “root” and password “root”.


Can you explain more about this image GSTPlay, i’ve never heard about it, as i understand this is testing image, am i right?


These are images that are collected using buildroot Amlogic. It includes HW when playing a full-screen video. In the future, it is possible to include these components in Linux-based system images.


Instructions for using MultiOS_3_in_1.


How can one “call the shutdown menu” in Android having a mouse and a keyboard(usb) only? (kvim2)
I have installed/updated 3 in one all steps and I am back in Android (the newly installed from the 3 in 1).
I installed a lot of power down apps/buttons to no avail.



Just use the remote’s top button. Android will then show a menu with the required options.

I installed the 3-1 this morning (France, here). Mostly working like a charm.
Under ubuntu, external storage cannor be accessed with current “khadas” user.
sudo chown khadas:khadas /media/khadas wil correct permissions.

Else, ubuntu correctly updated.
Haven’t yet tried 4k with libreelec. 1080p seems flawless.

Just one question : how to update the emmc? Througn the ddbr process again?

Keep up with the fine job and thanks to you all!


Thanks for the advice but as stated above “a mouse and a keyboard(usb) only”, ie I don’t have a khadas remote.
From the info above seems that no other upgrades/installations are required.

The Q stays open:
How to call the system shutdown menu from the Android UI or terminal?


Button “Power” on the Board itself. I don’t use Android, maybe there’s another option, I don’t know.
Press and hold for about 2-4 seconds, the shutdown menu will appear.


Can be turned off via the program


Great! Thanks! It works!
The simplest things are most difficult.


4k monitor is working fine in LE( 4k video from YT but the streaming says 720 and it doesn’t look like 4k) but in Ubuntu/Firefox/yt and with the Ubuntu video player from LAN is laggy even at 1080.


Hello. I instaled th image, and works well. Only problem is that I would like to see, from linux, the other partitions, but it seems like when I run either fdisk or gparted all emmc space appears as unallocated.

I have been able to locate the Libreelec ystem partiion (it is actually an image file called SYSTEM), but again, when I run fdisk on it, no partition appears, so I cannot mount it.

Any suggestions on how to get what I want? Thanks.


There is no standard disk partition table. The existing u-boot does not support this feature standard disk partition table. Access can only be obtained by mounting partitions as “/dev/system” “/dev/data”. But some of these devices are copies of images and can not be mounted as usual.


Update Xenial_KODI18_20180604

This is the version with the new KODI-18 and the package update in Ubuntu Xenial to the latest version at the moment.
Do you want to install KODI-18 in previous releases of MultiOS_3_in_1 ?
Please note, KODI-18 is a test version, which may not work some functions.


Added to the site version of the System Multios_3_in_1 Xenial_KODI-18_20180606.
It uses Ubuntu from the latest official version of Khadas_VIM with all its changes.

180209 dualboot

How to change in Multios_3_in_1 Xenial_KODI-18_20180606 The system when in kodi, I can not go from Kodi to another system because I do not have a boot change button in Ubuntu or Android.
Thank you.


Sometimes I change/set from command line with (in linux or libreelec)
fw_setenv bls android
fw_setenv bls libreelec
fw_setenv bls linux
Or (in android) with
setbootenv bls android (noop)
setbootenv bls linux
setbootenv bls libreelec