MultiOS_3in1 (Android+Libreelec+Linux) install to eMMC

Found a couple of errors. Replaced the archive version 20180116.

A new version of the image MultiOS 3_in_1 20180117 .

Changes. Added synaptic. Changed the first start procedure of formation of /home for Ubuntu. Now this directory is located in /dev/data and mounted in the directory /extpart/LINUX/home. For those who want to increase the available volume for Linux on eMMC for the installation of new programs, etc.), can use a simple procedure. Copy to the directory /extpart/LINUX the existing directory and system and edit fstab to prescribe its mounting on the analogy of /home (using key “bind”). For example, to migrate , the largest directory is /usr on /dev/data. Copy as root the directory /usr /extpart/LINUX/usr. Add in fstab the string “/extpart/LINUX/usr /usr bind bind 0 0”. And reboot the system. Note that partition /dev/affordable Android data cleaning and performing a “wipe” all data in it are erased.

Pay attention. Now when you first start the Linux system will reboot automatically, something came into force the new settings (this is normal).


You are a genius, sir. Thank you!

I tried to understand “bind” when you first mentioned it but could not work it out - your example now is perfect.

In fact I am now running your 3in1 - I worked out how to copy the Khadas Ubuntu server to replace Mate in /dev/linux and setup my simple openbox desktop the way that keeps me happy.

I am still on 20171116. And I changed partition content (linux libreelec system) incrementally.
I wonder: should I install new u-boot to stay compatible with recent 3_in_1 features like 20180117?
If so, can you provide updated u-boot (if any)?

If everything is working, changing it is not required. :wink:

1 Like

Can’t boot the image. I’ve tried to enable multiboot manually (I don’t want to erase emmc to android) but it doesn’t work in any way I’ve tried. LibreELEC for the VIM2
all resulted in
** Unrecognized filesystem type **

I’m using VTV_20180117 KVIM2-emmc.img

Please tell me what are correct commands to boot from SD and from Emmc for VIM2?

Write in detail what steps you did. What do you mean “I’ve tried to enable multiboot manually” ?

Pay attention while installing this firmware (MultiOS_3_in_1) the whole eMMC will be wiped clean. This system is NOT designed to work with external media.

  1. Downloaded KVIM2-emmc.img
  2. dd if=./KVIM2-emmc.img of=/dev/disk2
  3. Installed Android VIM2_Nougat_V171028 on VIM2
    There’s no Update&backup to enable multiboot
    So I’ve opened “About->System updates” as was said
    But there’s no option to choose from. I gave up and rebooted. Then I’ve tried
    kvim2#run update
    And got the android menu
    Chose there “update from EXT” and there “update from sdcard"
    And got this where all ends:
    The console meanwhile I see:
    ”[ 326.373599@4] FAT-fs (mmcblk1): bogus number of reserved sectors
    [ 326.373974@4] FAT-fs (mmcblk1): Can’t find a valid FAT filesystem
    [ 326.380728@6] FAT-fs (mmcblk1): bogus number of reserved sectors
    [ 326.385982@6] FAT-fs (mmcblk1): Can’t find a valid FAT filesystem

btw I haven’t found android “Setup Wizard” package ( in your Android package. Some things require running setup wizard/factory reset to run the wizard.

You’re doing it wrong. See the instructions carefully. Perhaps other users who speaks English well will be able to write clear instructions.


3_in_1 will alter original internal eMMC and erase original Android installation.

  • If you do not want this:
    Consider booting and using LibreELEC or Armbian from separate external SD cards.
    But first activate multiboot as documented using UPDATE&BACKUP from Android.
    UPDATE&BACKUP should be present in stock VIM2 Nougat
    (try system update from Android Settings).

  • But if you still do want 3_in_1:
    As said that system alters eMMC, so you can first make an eMMC backup with ddbr
    (when running Armbian from external SD card).
    Basically 3_in_1 allows to have 3 OS on internal eMMC and boot into any 3 of them from any 3 of them. The 3 OS are: Android, LibreELEC and Armbian (or any other Linux you make), and they are located on separate dedicated partitions
    (/dev/system /dev/libreelec and /dev/linux).



Looks like I got it.
In order to install KVIM2-emmc.img you need a bootable linux system installed on SD card prior to it. Then you need to login to it, download kvim2-update script and download KVIM2-emmc.img.gz without decompressing it. Then you put KVIM2-emmc.img.gz to /ddbr directory and run kvim2-update
So the main point here is - you need a bootable linux sd card

You hit the point.
The detail about /ddbr is perhaps configurable, I don’t exactly recall.
But I would recommend : take a ddbr backup of internal storage, so you can, with same bootable linux system installed on SD card, always restore should anything go wrong while overwriting internal storage.
Good luck!

1 Like

Bootable SD card is only needed if you have damaged a standard bootloader in eMMC. If you have normally functioning normally the bootloader from eMMC, you can use any USB flash drive > 8 GB.

You know I like the idea you did with Armbian as far as I remember. When you install the system on SD, boot from it, check if it fits your needs and works fine, and only then you copy the system to emmc.

I can assemble a version of the image 3_in_1 for SD\USB, but the main problem is that I have no version of Android that can work with external media. If someone can give me a version of Android that works with external drives, I can collect 3_in_1 option for external media.

I missed something again.
I ran kvim2-update
It showed everything went fine.
I rebooted.
And got into VIM2_Nougat_20171123 the same I had prior installation
And I can’t find any menu to reboot to other OSes
What did I miss?

btw your kvim2_update_SRC_20170926.img.xz looks broken.
It has chmod 1023:1023 on all /usr/bin files including sudo and suid bit not set
I had to mount it and fix owners
find /mnt -group 1023 -exec chgrp -h root {} ;
find /mnt -user 1023 -exec chown -h root {} ;

Also I wasn’t able to use wifi to download image on SD. It couldn’t find wifi driver.

Long press (2-3 seconds) of the button on\off on the remote control or on the Board.

For Wifi see description of settings Armbian.

Pushing middle button on the board only leads to:
[ 109.243827@2] input input1: key 102 up
[ 111.025232@5] fb: osd[1] enable: 1 (surfaceflinger)
[ 115.000489@4] fb: osd[1] enable: 0 (surfaceflinger)
and nothing…

Can you please tell me the command from android console to run the menu?

not press the middle(funkction) button
the button power\shutdown.

At the end we have:

  1. Android lacks Android SetupWizard so you can’t install enterprise policy rules there
  2. LibreELEC lacks Chrome as a fact. You just can’t run/install any web browser there because it doesn’t run on Xorg.
  3. Armbian Chromium shows 7.4fps on 1080p videos.
    it’s upsetting.