Manjaro Linux - KDE-Plasma & XFCE for VIM1

@Spikerguy,
I’ve been running Ubuntu focal with lima on kvim1 for few days, i did use android on it for the last few months, there are some bugs Ubuntu related, there are some with lima like Chromium not working, but overall it looks like amlogic s905/x has the best Linux support within amlogic soc’s.

Count me in for test when you release it.

1 Like

Hi @Spikerguy,

thank you for providing Manjaro ARM Images for the VIM1. I’ve tried to boot this image here (https://osdn.net/projects/manjaro-arm/storage/vim1/kde-plasma/20.04/), but it doesn’t seem to contain a boot loader (the buildtin EMMC is empty at this time), the console output shows:

LOOP:4;EMMC:0;READ:0;CHK:AA;SD:0;READ:0;CHK:AA;USB:8;

I’ve tried to apply the Khadas provided u-boot firmware (https://dl.khadas.com/Firmware/VIM1/U-boot/), but then the kernel gets stuck during boot.

1 Like

Hello @umiddelb
Thank you for trying Manjaro.
Manjaro images for vim’s need Android in enmc to boot.
We do not provide any bootloader as of now but once i get time to built mainline uboot for vims and they turn out to be fine then will release new images with mainline uboot.

Until you you will need to use Android on emmc and then not from sd card, after booting you can update the boot-vim1 package and get /boot/install-aml-emmc.sh which you can run from root. This will install manjaro on emmc by using Android uboot and the boot scripts we have…

Or you may wait for few days until I release another vim1 image with lima support having hw acceleration.

Thanks

I’m using Manjaro on my PineBookPro for quite a while now and I’m very happy with it.

Khadas provides several firmware versions for the SD card (https://dl.khadas.com/Firmware/VIM1/U-boot/), but they don’t boot the Manjaro rootfs without further tweaking (e.g. the addresses for the kernel image and dtb differ).

This sounds very promising, I’ll give it a try for sure.

1 Like

Currently building and testing manjaro kde and xfce if everything works fine on the builds then will upload ur

Manjaro ARM for Khadas Vim1 with Lima for HW Acc!

The Manjaro ARM project is proud to announce the first release for the Khadas Vim1 - Basic SBC !

These images are running the 5.6.2-2 kernel. Can be upgraded to 5.7.0-rc3

How to install:

Download the image/xz file from the download location. Verify that the download completed successfully.

After that, install Etcher (sudo pacman -S etcher if on Manjaro) and burn the to an SD card (8 GB or larger).

Enable Multi-boot on the Vim1 by following steps mentioned here. With this it should recognize the SD card as a bootable device and boot from it.

Features:

  • New packages from upstream and Manjaro ARM.
  • Manjaro now uses a branch based repo structure. Meaning you can now switch between arm-stable , arm-testing and arm-unstable branches by editing /etc/pacman-mirrors.conf .
  • XFCE 4.14
  • KDE Plasma 5.18
  • Lima for GPU - HW Acceralation
  • BT/Audio - Works and tested in Vim1 - V14 - Basic.

Known Issues

  • Fan does not work on v14
  • HW Acceleration is a bit slow.
  • Wifi driver not added yet on Vim1 . (Will upload a new wifi firmware package for vim1 later)

eMMC flash script for Vim1

It’s a script for supported Amlogic SBC designed to flash Manjaro ARM to the built-in eMMC module, so you don’t have to fiddle with DD and/or take out the eMMc module yourself.
Right now script for the Vim1 is available in the boot partition of the image. Filename is install-aml-emmc.sh , to flash Manjaro on eMMC.

Users will need official latest Android image on the eMMC while booting Manjaro from Sd-Card and running this script using root access.
Thanks to @balbes150 for this emmc install script.

To flash Manjaro on eMMC:

  1. Download the image of your choice.
  2. Flash it to an SD card.
  3. Boot the SD card on the device.
  4. Follow the instructions on the screen.
  5. Login to the desktop.
  6. Open Terminal with root access and run ./boot/install-aml-emmc.sh

First Time setup

This release sports the First Time setup for all images, also via SSH. This means that at first boot, you will be asked about the following:

  • keyboard layout
  • username
  • additional user groups (optional)
  • full name
  • password for that username
  • password for root
  • timezone
  • locale
  • hostname

Then the setup script will set these settings and reboot to the login screen.

Downloads:

Device XFCE KDE Plasma
Khadas Vim1 Pro 20.05 20.05

Donate!

Please consider supporting Manjaro ARM directly via Patreon , Ko-Fi or Open Collective .
You can also donate to our upstream, which is Arch Linux ARM .

Manjaro ARM team

1 Like

@umiddelb and @Tommy21
Please flash latest android on emmc using burning tool and then flash the above listed manjaro img to sd card.

Boot from sd card and run /boot/install-aml-emmc.sh with root access.

This will flash manjaro on emmc.
Reboot once again into sd card to enable multiboot.

Shutdown from sd card boot and the boot without sd card it will boot from emmc until Manjaro :smiley:

Try and let me know you experience.
Later you can install Chromium docker package to get Netflix and amazon to work. :wink:

2 Likes

Nevermind this post, i thought the wifi is missing only on Vim1 basic.

Need to add Firmware file to the correct location. I have a package somewhere. Let me search for it.
Problem is the package I made was for Vim1 V12 and after replacement I now have Vim1V14 which have a different upgraded wifi chip.

Can you share which Vim1 Version do you use? and also which edition ?

@Spikerguy i have vim1 pro, bought the first version that came out, i think it’s 1.2 revision.

Finally I was able restore the Android bootloader on the internal emmc storage.
The sd card image boots Manjaro happily, but the two USB2-A receptacles don’t seem to work. So I cannot connect something like a keyboard or a mouse to test the desktop environment. They don’t show up even if I left them connected during reboot (which helped to overcome this issue on other AML based devices).

I am not sure about this, as usb seem to work fine on the images provided.
Maybe it is something to do with kbi? Idk just a guess. @Frank @numbqq any advice on this?

@Spikerguy @umiddelb
I do a test with Edge-V Pro yesterday , the keyboard works fine . I will try with Max later.

This is for vim1 please try it

@Spikerguy i did try it yesterday on sd card, keyboard and mouse worked for me, but i need wifi working on it.

1 Like

@Spikerguy OK, I will try it together

I will try to get the wifi firnware for you tonight.

This is the only hint, I get from the dmesg log:

dwc3 c9000000.dwc3: Failed to get clk 'ref': -2

U-Boot does not detect USB storage devices via usb start either. FW version is:

BL2 Built : 15:21:18, Aug 28 2019. gxl g1bf2b53 - luan.yuan@droid15-sz
BL3-1: v1.0(release):53f813e
BL3-1: Built : 15:51:23, May 22 2019
gxl_v1.1.3390-6ac5299 2019-09-26 14:09:24 luan.yuan@droid15-sz
U-Boot 2015.01-gcf11480 (Mar 17 2020 - 16:15:42)

Can you try this?


If it works then i will clean it and add ap6212a file also. As this one doesn’t work on v14 but worked on v12

1 Like

this medieval :japanese_ogre: :sob: need for android in emmc to be able to boot a linux on sdcard is such a terrible experience imposed to the users, according to me.

2 Likes