Manjaro ARM on VIM3 - Lost mouse control in KDE after latest update

Using VIM3 and after latest online updating of Manjaro distribution (Linux manjaro 5.14.10-1-MANJARO-ARM), with no apparent reason I lost the control of the KDE desktop, with the mouse appearing for a very short while and then disappearing right after booting. In the desktop, the invisible mouse appears basically doing something, like when I blindly click in the desktop area, but any useful action is totally impaired. Thank you for any advice
PS: I upgraded my Manjaro for several times in the past months with no such problem.
Cheers, Marco

Try switching to Linux RC kernel if it’s possible via command line. See if the problem is resolved.

Please share the output this command.

inxi -Fzxi

I’ve not had this problem, I just updated mine last night.
I am using linux pkgname for kernel.

Here below the output:

[root@manjaro ~]# inxi -Fzxi
Kernel: 5.14.10-1-MANJARO-ARM aarch64 bits: 64 compiler: gcc v: 10.2.0
Console: pty pts/0 Distro: Manjaro ARM base: Arch Linux
Type: ARM Device System: Khadas VIM3 details: N/A
Info: 6-Core (2-Die) model: N/A variant-1: cortex-a73
variant-2: cortex-a53 bits: 64 type: MCP MCM arch: ARMv8 rev: 4
features: Use -f option to see features bogomips: 0
Speed: 2208 MHz min/max: 100/1800:2208 MHz Core speeds (MHz): 1: 1800
2: 1800 3: 2208 4: 2208 5: 2208 6: 2208
Device-1: meson-g12a-vpu driver: meson_drm v: N/A bus-ID: N/A
Device-2: meson-g12a-mali driver: panfrost v: kernel bus-ID: N/A
Device-3: meson-g12a-dw-hdmi driver: meson_dw_hdmi v: N/A bus-ID: N/A
Display: server: 1.20.13 driver: loaded: modesetting tty: 80x24
Message: Unable to show advanced data. Required tool glxinfo missing.
Device-1: meson-g12a-dw-hdmi driver: meson_dw_hdmi bus-ID: N/A
Device-2: axg-sound-card driver: axg_sound_card bus-ID: N/A
Device-3: Texas Instruments PCM2902 Audio Codec type: USB
driver: hid-generic,snd-usb-audio,usbhid bus-ID: 1-1.1.2:5
Sound Server-1: ALSA v: k5.14.10-1-MANJARO-ARM running: yes
Sound Server-2: JACK v: 1.9.19 running: no
Sound Server-3: PulseAudio v: 15.0 running: no
Sound Server-4: PipeWire v: 0.3.38 running: no
Device-1: meson-g12a-dwmac driver: meson8b_dwmac v: N/A port: N/A
bus-ID: N/A
IF: eth0 state: up speed: 1000 Mbps duplex: full mac:
IP v4: type: dynamic noprefixroute scope: global
IP v6: type: noprefixroute scope: link
Device-2: pwm-clock driver: pwm_clock v: N/A port: N/A bus-ID: N/A
IF-ID-1: ip6tnl0 state: down mac:
IF-ID-2: wlan0 state: down mac:
Device-1: meson-gx-uart driver: meson_uart bus-ID: N/A
Report: rfkill ID: hci1 rfk-id: 1 state: up address: see --recommends
Report-ID: ID: hci0 rfk-id: 0 state: up address: N/A
Local Storage: total: 29.12 GiB used: 15.25 GiB (52.4%)
ID-1: /dev/mmcblk1 vendor: Samsung model: BJTD4R size: 29.12 GiB
ID-1: / size: 28.4 GiB used: 15.19 GiB (53.5%) fs: ext4
dev: /dev/mmcblk1p2
ID-2: /boot size: 199.8 MiB used: 63.9 MiB (32.0%) fs: vfat
dev: /dev/mmcblk1p1
ID-1: swap-1 type: zram size: 5.59 GiB used: 0 KiB (0.0%) dev: /dev/zram0
System Temperatures: cpu: 61.9 C mobo: N/A
Fan Speeds (RPM): N/A
Processes: 216 Uptime: 1m Memory: 3.72 GiB used: 913.2 MiB (23.9%)
Init: systemd Compilers: gcc: 10.2.0 Packages: 1055 Shell: Bash v: 5.1.8
inxi: 3.3.07

You’re still on linux-vim

please do this.

sudo pacman -Syyu linux linux-headers

Try to reboot and see if it fixes your problem.

ICYM :slight_smile: You happened to be my lifeline. Thanks!
As a result it downloaded roughly a 2,5GB load of updates.
For the sake of my understanding, what steps did I do wrong following what I believed to be the correct automated upgrade path?

Just worth noting that now numerous graphical glitches are displayed, I tried 4K and other screen resolutions. Thanks, Marco

1 Like

I also told you to change to Linux - RC which could have solved the problem as well.

Yes, sorry did not get the immediate sense of your advice. Thank you

Edit: I am aware not fair to ask this way but can you give a short hint about what is Linux-vim opposed to Linux-RC. Thanks

Different forks of Linux kernel for our sbc and each has slightly different versions.

Linux vim is default kernel used by manjaro
Linux rc is the one i use as per my experience. It’s the most updated one and usually have latest fixes (and latest bugs)
Linux aml is for overall Amlogic chips
Linux rpi is for raspberry pi

You get the idea……


Thank you, this topic has helped the hell out of me ! :slight_smile:

1 Like