Manjaro ARM for the VIM3

Added after posting here yesterday. Thank you. But there is a problem like this. I’m uploading to emmc. Then the update comes and it updates 615 mb. There is no problem so far. Then when I reboot the system won’t boot up. I tried it 3 times.

I solved the problem with sd card with img downloaded from manjaro site. Then I updated it and transferred it to emmc. No problem right now. Already your img file size is 100 mb smaller than the file size I mentioned. This also caught my attention.

yes need more testing !!! i just make boot-able image like example

Already your img file size is 100 mb smaller than the file size I mentioned. This also caught my attention.

different compression level and removed some trash :wink:

PS: TNX for testing - we can remake it soon

a very thin green line appears on! the left side of the manjaro. Do you have the same situation?

Yes this have been common on all my S922x device.

  • Khadas Vim3
  • GT KIng PRO
  • GS King X
  • Ugoos AM6 Plus

I have not done any test on this, If you can try some display config testings then it will be helpful.

It’s a DRM driver problem and this is a band-aid workaround, not a proper solution.

1 Like

FIXED ! + Krescue - take full control of your VIM device! easy way to install ANY OS! + back/restore your system


As of yesterday, the manjaroma update has arrived. I installed about 600 mb of update and rebooted several times. Linux XFCE Khadas vim3 pro

As i see

  1. the green line on the left side has been corrected.
  2. Youtube videos play smoothly in 1080p on Mozilla and other browsers. There is no breakage or fluctuation.
  3. The sound issue was fixed in the previous version, now I did not see any problems, it works fine.

but there was a problem that was not pre-update. And it looks like a serious problem. It reduces the experience of using the system very much.

  1. The mouse keeps coming and going in the start menu and often doesn’t show up. the mouse gets stuck frequently.
  2. We are right on the desktop and pixelated on other clicks. Occasionally the screen turns black and goes back 3 to 4 seconds later.

None of these issues were pre-update

This is because panfrost is still unstable for bifrost gpu.

You can use software acceleration tilll then.

sudo echo "QT_BACKEND_RENDERER=software" >> /etc/environment



Thank you.

but it didn’t fix the problem. The most nervous thing is that the screen suddenly goes black and stays on the pitch black screen until you click the mouse.

I presume that is just the system being suspended…


I’m just starting with VIM and ARM in general, my past experience has been only with the Rasbperry Pi.

I went with the minimal installation of Manjaro just to learn how all works and build up from there. I usually don’t use xfce, mate nor kde, so minimal sounded like a good option. My main goal here is to learn as much as possible about the booting, kernel, hardware support and such in order to eventually try to get my favorite distribution (Slackware) running with the VIM3. Manjaro minimal sounded like the perfect starting point.

I installed fluxbox and xorg, but the X is pretty unusable, I get lots of drawing issues, sometimes the windows just disappeared until I move the mouse over them or try to drag and drop them then they appear again, I’m getting lots of kernel messages similar to:

[  502.173680] panfrost ffe40000.gpu: Unhandled Page fault in AS0 at VA 0x0000000000000030
           Reason: TODO
           raw fault status: 0x30002C2
           decoded fault status: SLAVE FAULT
           exception type 0xC2: TRANSLATION_FAULT_LEVEL2
           access type 0x2: READ
           source id 0x300
[  502.190550] panfrost ffe40000.gpu: gpu sched timeout, js=1, config=0x7300, status=0x8, head=0x4326e80, tail=0x4326f80, sched_job=000000003148b0e8
[  502.277504] panfrost ffe40000.gpu: js fault, js=0, status=DATA_INVALID_FAULT, head=0x44d4080, tail=0x44d4080
[  502.281695] panfrost ffe40000.gpu: gpu sched timeout, js=0, config=0x7300, status=0x58, head=0x44d4080, tail=0x44d4080, sched_job=00000000f94cfd86
[  509.789260] panfrost ffe40000.gpu: js fault, js=1, status=DATA_INVALID_FAULT, head=0x4335080, tail=0x4335080
[  509.793442] panfrost ffe40000.gpu: gpu sched timeout, js=1, config=0x7300, status=0x58, head=0x4335080, tail=0x4335080, sched_job=00000000192602bd
[  509.842702] panfrost ffe40000.gpu: js fault, js=1, status=INSTR_INVALID_ENC, head=0x46a4f40, tail=0x46a4f40
[  509.846784] panfrost ffe40000.gpu: gpu sched timeout, js=1, config=0x7300, status=0x51, head=0x46a4f40, tail=0x46a4f40, sched_job=00000000483f49b5

I also tried adding QT_BACKEND_RENDERER=software in /etc/environment but didn’t do anything :frowning:

I have:

kernel 5.10.5-1-MANJARO-ARM
xorg: 1.20.10
mesa 20.3.3-1
vulkan-mesa-layers 20.3.3-1

I kind of fix the issue by disabling glamoregl all together with the following file in /usr/share/X11/xorg.conf.d/00-noglamoregl.conf:

Section "Device"
    Identifier "nogpu"
    Driver "modesetting"
    Option "Accelmethod" "none"

Section "Module"
    Disable "glamoregl"

But that leaves me without acceleration as far as I know, is there perhaps a way to get some of it without the glitches? or something else that may work better?

Another issue is the temperature, sensors doesn’t detect any and the fan doesn’t seem to start, not sure if I’m missing something here, I tried lowering the tripping point with echo 60000 > /sys/class/thermal/thermal_zone0/trip_point_3_temp but I’m getting permission denied even as root.

What the difference of thermal_zone0 and thermal_zone1? i have a temp file in both (which I assume is the current temperature), but they differ, thermal_zone0 says 45100 and thermal_zone1 47200.

1 Like

sudo pacman -S mesa-git

This will only minimize it.

We’re waiting for some drm patches might have to backport it but its a long list.

This is one of the way to make i ur use cpu acceleration for now.

I kind of fix the issue by disabling glamoregl all together with the following file in /usr/share/X11/xorg.conf.d/00-noglamoregl.conf:

So will this fix the problem? even temporarily …

Yes it will make use of the cpu for acceleration.

I do not have such a file.

[root@fkaraokur fkaraokur]# cd /usr/share/X11/xorg.conf.d/
[root@fkaraokur xorg.conf.d]# ls
10-quirks.conf	40-libinput.conf

Make a new file and enter that enter in it

yes the problem is solved. At least the screen is not blinking anymore. I hope the update will come soon and I can enjoy the manjaro.


Hello, I’ve tried to install from Krescue and everything went well. Then, I tried to do a Software Upgrade (about 870 MB) with success. However after logging back into the desktop it resulted into a fundamental blank screen with just the pointer visible - I can do searches of software to run individually though. So, the system is available but definitely something in the graphical environment was screwed up after the upgrade. Hint: in the logon X Window the writings appear mangled with changed or missing characters. Thank you.

This is a known issue coz of panfrost update.

Please do the following to get is fixed temporarily until panfrost drivers are stable for G52 gpu.


hi @Spikerguy may be u can make workable NVME ?

whats a problem ?