"make" error with FENIX tool


I am working with VIM3, and 2 days ago I had no problem with “make” to build an image with FENIX, but today when I try to make, I have this error:

That error appear when I try make, make debs, make kernel, etc.

My setup build environment is:

and the host PC has Ubuntu 18.

Thanks in advance.

@vaayroon Is the Kodi package there on Fenix by default?

@Electr1, I suppose, I try to make after clone the fenix repository again, and the same error.
Actually I did not change anything.

My steps:

$ sudo apt-get install git make lsb-release qemu-user-static
$ git clone --depth 1 https://github.com/khadas/fenix
$ cd fenix
$ source env/setenv.sh
$ make

and the error appear.

try to do git pull and see if the repository gets updated…

I tried git pull several times, but the error persist. I tried unistall make and install again, new ubuntu version (ubuntu 20) and the same error.

Hmm, I don’t have such an error, 3 days ago I even built a brand new image…

The error appear today, 3 days ago I built and image too.

@vaayroon run git diff to check have you modified anything. And you should run make again . The picture don’t show error message .

@Frank there is something wrong with Kodi packages,
look at this new post…



seems like something is wrong with the Kodi package, this seems to have popped up just recently, few days ago there was no such problem…

I have the same problem, I noticed there is auto update before building

I can build with U-boot mainline/linux mainline/ubuntu bonic well, but it only support SD-USB mode.

@numbqq could you please take a look at this here,
thank you!

OK. I will fix this later, thank you for your feedback.


Another problem: DISTRIB_TYPE=gnome, with this option, building failed. with LXDE, build well.

Please check it, Thanks

Processing triggers for mime-support (3.60ubuntu1) …
Processing triggers for libc-bin (2.27-3ubuntu1.2) …
Processing triggers for systemd (237-3ubuntu10.41) …
Processing triggers for hicolor-icon-theme (0.17-2) …
Processing triggers for ca-certificates (20190110~18.04.1) …
Updating certificates in /etc/ssl/certs…
0 added, 0 removed; done.
Running hooks in /etc/ca-certificates/update.d…
Processing triggers for initramfs-tools (0.130ubuntu3.9) …
Info: Installing packages
Reading package lists… Done
Building dependency tree
Reading state information… Done
Note, selecting ‘libglu1-mesa’ instead of ‘libglu1’
E: Unable to locate package yaru-theme-gtk
E: Unable to locate package yaru-theme-icon
E: Unable to locate package yaru-theme-sound
Makefile:7: recipe for target ‘all’ failed
make: *** [all] Error 100
a311d@vultr:~/fenix$ make info

Version: 0.9.2
Current environment:



Hello @vaayroon @peng794

I have fixed this issue, please update the code and try again.

1 Like

@numbqq @Electr1
This morning I have try to make and voila, it works, make completed successfully.

Thanks to everyone.


Please mark a solution and end the topic, thank you
Good day!

good news, also tell about the steps took

It was just a repo update…

i get it, thanks buddy