Linux WiFi AP6255 firmware

Hi @Gouwa
Can you please take a look on this topic [1]. There is as you know mainline kernel support for Khadas VIM in version 4.12. Today I tested (instruction from Martin Blumenstingl) WiFi and as soon as i try to connect to box there is call trace.

The Heiner Kallweit wrote that actually this could be a problem with “android” firmware which i use. Do there exist any other firmware then one i linked in first post in that Amlogic Mailing list?


What do you mean of “call trace”?

When we build the Ubuntu server ROM with Linux-4.9 kernel, we port the WIFI driver from the buildroot_openlinux_kernel_4.9_fbdev_20170515.tar.gz, WIFI works fine here.

We’ve push the source code on Khadas Github, check the commit for further details.

Easy definition of call trace is the kernel panic/ kernel crash which prints stack/call trace message which could be seen with dmesg or if connected over serial console directly in that session. So actually forum post should be kernel panic and the panic/oops message says something like [stack: ; Call trace; etc…]
And here on Mainline Kernel there is kernel panic when enabling WiFi on Khadas VIM Pro. This was also reported by Martin Blumenstingl replay in Amlogic Mailinglist [1].


@Gouwa that commit which you point does it enable WiFI on Pro version with AP6255, because only reference I found is for non Pro version with AP6212 [0]. Can you confirm that WiFi is relay working with the Pro version?

probably correct nvram for Pro version would be: /usr/lib/firmware/brcm/brcmfmac43455-sdio.txt and firmware /lib/firmware/brcm/fw_bcm43455c0_ag.bin from [1].
Or is the AP6255 firmware/nvram somewhere else defined?


1 Like

Yes, both WiFi and Bluetooth works fine on both VIM and VIM Pro model.

But we still haven’t got a try on Linux-4.12 yet, what we build is Linux-4.9 based on Amlogic Buildroot.

Can you post the printing log so more folks can help to check it.

They are for ArchLinuxArm and I will post them in that topic (actually I’ll update page on github, but post replay that page is updated)

How ever i also tried it on Ubuntu Server image you provide but i cannot login to device over SSH, ping out works through.
Do you have instruction how to setup WiFi on your Ubuntu Server image released yesterday?
This link [0] have some Notes with instruction I used:

[0] url: Defuse Security's Encrypted Pastebin password: khadas


It’s default WIFI model for AP6212, but the WIFI driver will check the chipID and load the firmware automate for both AP6212 and AP6255, check dhd_conf_set_fw_name_by_chip() for further details:

1 Like

Did you also tried WiFI without having Ethernet cable connected. As you can see in that Note from me, even after I add new default route I can’t ssh into device. Nor even ping gateway. Ping work however apt-get update not, but resolve works. Quite weird stuff.

PS: To download over 380MB for network-manager on Server and then use it’s cli is not an option here, sure for tests but otherwise an no go.

Hello khadas team,
I want to understand why I have this problem :
my wifi access point is using channel 13, which is fully legal where I live (FR).
my khadas vim pro (using ubuntu xenial + kernel 412rc6 patched by numbqq) is not able to see my network but can see others using channel <=11

and “sudo iw list” shows this…

Wiphy phy0
max # scan SSIDs: 10
max scan IEs length: 2048 bytes
Retry short limit: 7
Retry long limit: 4
Coverage class: 0 (up to 0m)
Device supports roaming.
Supported Ciphers:
* WEP40 (00-0f-ac:1)
* WEP104 (00-0f-ac:5)
* TKIP (00-0f-ac:2)
* CCMP (00-0f-ac:4)
Available Antennas: TX 0 RX 0
Supported interface modes:
* managed
* AP
* P2P-client
* P2P-GO
* P2P-device
Band 1:
Capabilities: 0x1022
Static SM Power Save
Max AMSDU length: 3839 bytes
Maximum RX AMPDU length 65535 bytes (exponent: 0x003)
Minimum RX AMPDU time spacing: 16 usec (0x07)
HT TX/RX MCS rate indexes supported: 0-7
Bitrates (non-HT):
* 1.0 Mbps
* 2.0 Mbps (short preamble supported)
* 5.5 Mbps (short preamble supported)
* 11.0 Mbps (short preamble supported)
* 6.0 Mbps
* 9.0 Mbps
* 12.0 Mbps
* 18.0 Mbps
* 24.0 Mbps
* 36.0 Mbps
* 48.0 Mbps
* 54.0 Mbps
* 2412 MHz [1] (20.0 dBm)
* 2417 MHz [2] (20.0 dBm)
* 2422 MHz [3] (20.0 dBm)
* 2427 MHz [4] (20.0 dBm)
* 2432 MHz [5] (20.0 dBm)
* 2437 MHz [6] (20.0 dBm)
* 2442 MHz [7] (20.0 dBm)
* 2447 MHz [8] (20.0 dBm)
* 2452 MHz [9] (20.0 dBm)
* 2457 MHz [10] (20.0 dBm)
* 2462 MHz [11] (20.0 dBm)
* 2467 MHz [12] (disabled)
* 2472 MHz [13] (disabled)
* 2484 MHz [14] (disabled)

Can you please check if your vim pro ubuntu using kernel 4.9 and 4.12 can see and connect to wifi network on these 2.4GHz channel : 12, 13 and 14?

thanks in advance