LibreELEC for Khadas VIM1 VIM2 VIM3 (SD & USB & eMMC)

  1. I made these quotes to keep your messages in their original form. I don’t see any point in wasting time on answers.
  2. This topic is about my build LE.
  3. If you want to discuss CE-create your own theme and there you can write whatever you want. On this, the debate about CE in this topic are closed.

Update LE 20190304 images.


Update LE 20190318 images.
Fix BT for VIM1 Pro.


Update LE 20190322 images.


The new version 20190324.

Please VIM2 S912 to check the operation of playback in the next version. After the start of the video playback, be sure to move the mouse, that would appear the bottom menu with a ruler of the playback time and the “stop” buttons . After that, after a few seconds, the menu is removed and at the end of the video playback, KODI should normally return to the file playlist. It also removes the “circle” from the center of the screen when playing.


The new version 20190404.

Pay attention, changed the image name for version S905 -> AMLGX.


The new version 20190414 (dir S905_S912). Pay attention, now, to S905\S905X\S912 use a single image AMLGX. DTB for VIM1 (S905X) is enabled by default. To run on VIM2 you need to edit “uEnv.ini” (to specify the correct DTB). The good news is that the version of “arm” (32 bits) on VIM2 (S912) started to work and you can test Netflix on VIM2.


Thanks Balbes150, please add reboot to android (nand) in next version

Can it be done in a simple way?

Write more precisely, for what option to run LE you write (SD\USB or eMMC) ?

Good afternoon, thanks for your work. I’m running from LE on SD and android in the NAND
The version I’m using is the one you compiled “LibreELEC-AMLGX.aarch64-9.1-devel-20190414080121-68723cf.img”

One more question, to run from SD should choose aarch64 or arm version.


I’m going to stop building and publishing ‘aarch64’ Kodi binary add-ons in the near future as we will not be officially releasing an aarch64 image (only arm) … so arm install would be preferred. Performance is marginally lower with arm but the user/support simplicity of shipping a single image trumps that.

Hello. inputStream Adaptive which is required for Netflix can not be installed:
error: “the dependency on version 1.0.14 could not be satisfied”.
image used: LibreELEC-AMLGX.arm-9.1-devel-20190424173952-68723cf.img.gz

can you please fix this ?

Now changing the structure of the placement of Addons and possible temporary failures.

So will it be fixed on the next version: 20190425?

Upgrades AMLGX 20190425 (this is universal version for all S905 and S912). To run on VIM2 S912, you need to configure the DTB in the file “uEnv.ini”

Update Addons performs @chewitt

Netflix works but the video is green. looks like RGB problem when only G(green) is working.
this issue only happens on resolution 720 and above. tried to change Netflix and inputstream settings but did not help. from what I have read this problem can be driver related. On YouTube and other video apps all is good.

Model is not listed.

Can you please elaborate? with kernel 3 works great on vim1 . worked slow with vim2 . but the green video is a new issue.

I have no versions with kernel 3 for a long time and they are no longer supported. Write in detail the model and version of the image , where green color.

Model: Vim2
Image: LibreELEC-AMLGX.arm-9.1-devel-20190425110311-68723cf.img