LibreELEC for Khadas VIM1 VIM2 VIM3 (SD & USB & eMMC)

My comments here are out of the context for this topic, but i don’t know where to add them. If admins decide, please move or delete them.
Anyway:

Thanks @balbes150.

This is what I have discovered after more than a month of trying to get DSD native playback on Kodi and reading all the internet for Hi-Res playback and just to save some time in case someone else have plans to try it:
Kodi can’t passtrough DSD music by itself. Kodi only can play them by transcoding to PCM and the quality depends from the user configurations. Actually VIM can handle transcoding for all known DSD standards at “Low” (Low means fast real time transcoding in this case) from the Kodi settings. And can’t do smooth playback at High transcoding quality only for numerous top-end 256bit, 11289k bitrate tracks.

The workaround for playing DSD native or DoP (DSD over PCM) without transcoding in Kodi is possible only on Linux based installations of Kodi where actually Linux take control of playback for DSD files (MPD or LMS for example).

I installed your image, but I have some stability problems with the wifi, so I wanted to know if you took the amlogic wifi driver with your images or if it is vanilla.
If you don’t know, that’s fine, I will investigate more.

I use the kernel sources from GIT Lebreelec. As far as I know, it uses data from Amlogic Buildroot + additional patches.

version 17.3_20170705

Hi Balbes150,

I’m trying to get LibreELEC running for several days, but no success.

My steps:

  1. Flashed “VimPro_DualOS_Marshmallow_Ubuntu-16.04_170124”
  2. Write “17.3_20170705” into SD card using Win32 Disk Imager.
  3. Delete “dtb.img” (skipped this step as there is none in the above image).
  4. Rename “remote.conf.vim” to “remote.conf”.
  5. Try to reboot to LibreELEC. Settings -> About Device -> System updates -> Select -> aml_autoscript.zip -> Update

Then nothing happened, the system reboot and Android started.

For firmware versions with DualOS is necessary to update u-boot. Files to update here. This must be done manually (for console UART).

https://yadi.sk/d/gRJa9jXd3FgUBi

I suggested to add support for multi-boot in the firmware (source code level) that would multiboot was download initially users didn’t have to do it, but don’t have it.

HI, how to adjust gpu ram size on your libreELEC ROM ?

On Pi3 in config.txt

Default GPU memory split (do not change if you do not know what you are doing)

gpu_mem=128

Configure GPU memory based on SDRAM size - overrides above setting

gpu_mem_256=112
gpu_mem_512=160
gpu_mem_1024=256

Hi,VIM GPIO

http://docs.khadas.com/images/vim_pinout.png
Please tell me,where are I2S?

All parameters gpu pledged in the dtb file. For example, here’s the data for fb.

The question You better ask in these topics.

im not sure if i did understand this correctly? i cat put that image (via dd) to an sd card and then select from the menu “install to emmc”?

edit: after reading 3rd-Party Ubuntu ROM for Khadas VIM
ah ok i got it. u need to do it as an android update.

but why this way? isnt it possible to burn this with uboot ?

update 2: running marshmallow 20170303
this doesnt work for me. only the VIM logo shows up on screen
i use external reader (wit status led) nothin happens!
uart debug stops at:

InUsbBurn
[MSG]sof
Set Addr 15
Get DT cfg
Get DT cfg
set CFG

update3:
i’ve tried different android images same result

i’ve put all from the tar to sd card and set all the env var from the amt_autoscript but this causes a stop too:

“rsvmem check failed
ee_gate_on …
InUsbBurn
[MSG]sof
Set Addr 33
Get DT cfg
Get DT cfg
set CFG

update: i dont know why, but i did now set the envs from the aml_autoscript again and today it worked fine. i must have made a mistake yesterday
thank you!

Version update 20170801.

https://yadi.sk/d/ysAgoIWT32M9Hn

Pay attention to use this version of the LE into VIM firmware Android 6 need, download and replace the file “dtb.img” on this option. Without a file “dtb.img”, this version of LE will not run on VIM.

https://yadi.sk/d/PTMTLQPs3Lhhr9

1 Like

Thanks for your work. Is the video playing smoothly? I’ll check only in the evening.

The video I tested, working fine. But I have not tested all the options. By the way, maybe it’s a coincidence, but I noticed that the version of the image I see is much more available Wi-Fi networks than on the way from Kszaq. It would be nice if someone had checked this information.

Just to clarify: if i DON’T have Android 6 (aka Marshmellow) on my VIM, i need to download the kvim.dtb from your Yadi.sk folder (20170801) and replace the one included in the image with the one i just downloaded?
– Edit: rename it to dtb.img obv as well :wink:

Yes, you need to download, rename and replace “dtb.img” on the media. I wrote about Android-6 in order to understand how u-boot I test my build. Maybe the firmware with Android 7 (with the data used in u-boot from the firmware) the behavior of the LE will be different, I have not tested it.

hi @balbes150,
why is there no simple img file we can use to flash LE directly to emmc using the same windows and usb-c tool like for ubuntu ?

Using the flash file with USB cable - is dangerous procedure. Running the system from external media in multi-boot mode saves the contents of the internal eMMC and allows the user to preview the system. To check all its functions and to make sure this system suits him. I know a lot of cases when users , after some time of use, refuse from this system, in this case, they really just return to their previous state (without having to perform a potentially dangerous procedure of flashing). Many users use multi-upload that would to have multiple systems (Android + Le + Linux).

Hi balbes,
i had the latest official nugat build (170612) installed on mmc, flashed via manually creating a burncard with u_boot_nugat_170512. Was working ok, but all my PCs run linux, so i wanted linux on my VIM aswell.
I dd’ed your previous LibreElec 20170705.img to my sdcard, renamed dtb.img to _dtb.img_ and renamed remote.vim to remote.conf. Then i ran the Update&restore utility, pointed to the aml_…zip-file and after short the system rebooted.
But it never got out of the boot-animation. So i updated my SDcard with your new image (dd…; ren dtb.img __dtb.img; cp …/…/kvim.dtb dtb.img). I can’t get the image to boot, the system will only boot to the android boot animation and never finish. I have access to uboot, here’s the boot log: https://pastebin.com/q1KmV6iF
As i’m completely new to uboot, what should i do now?
(Oh, and if this is the wrong thread, please move it to another.)
THX :slight_smile:

Show the output of “printenv” from u-boot.