LibreELEC for Khadas VIM (SD & USB & eMMC)


I have no equipment with 3D.


You can try view a sample 3d hsbs then switch to 2d mode on the fly (view only half of video resolution) to see if it works. I repeat, changing the view in the middle of playing not at the beginning. I get no signal error only when changing mode on the fly not at the beginning when kodi ask to display in stereoscopic or monoscopic.

I have another problem:

  1. I’m using your May build in emmc
  2. Update to August build via .tar file -> stuck at vim logo after updating successfully.
  3. Install August .img to USB -> boot USB OK -> reboot installing into eMMC -> all processes success, reboot -> stuck at vim logo again.

What could be the problem?


I have a similar update problem as @peerobo. Libreelec is installed on a SD card (with Android Vim_Marshmallow_Root_170603 image on internal storage). After updating to 20170801 using .tar method boot is stuck at Khadas logo.

Serial output shows the boot stopping here:

[ 0.000000@0] NR_IRQS:64 nr_irqs:64 0
[ 0.000000@0] Architected cp15 timer(s) running at 24.00MHz (phys).
[ 0.000004@0] sched_clock: 56 bits at 24MHz, resolution 41ns, wraps every 2863311519744ns
[ 0.008242@0] meson_bc_timer: mclk->mux_reg =ffffff800000c990,mclk->reg =ffffff800000e994
[ 0.016749@0] Console: colour dummy device 80x25
[ 0.021088@0] console [tty0] enabled
[ 0.024672@0] bootconsole [earlycon0] disabled
domain-0 init dvfs: 4


You need to update the dtb data in eMMC.

If you forgot to use a new device tree or used wrong one and your device doesn’t boot:

don't panic!
if booting from SD/USB, simply connect SD/USB to your computer, download a proper device tree, rename it to dtb.img and place on SD/USB
if booting from internal:
    Boot this build from SD card or USB with correct device tree.
    Login over SSH and execute dd if=/dev/zero of=/dev/dtb bs=256k count=1 then dd if=/flash/dtb.img of=/dev/dtb bs=256k
    Power off, remove SD/USB, boot from internal.


Thanks @balbes150 for the instruction. I think you should include it to the first post or update the command “install to eMMC” to copy dtb.img into eMMC, so no extra manual step for the user.
If I replace the new dtb.img in the eMMC, will your previous Armbian build function? (the one that use stocked dtb.img in eMMC)

  1. The clean install (using the menu item “Reboot to install eMMC”), if the medium has the file “dtb.img” it is automatically copied to eMMC. When using the updates by using the “tar” in the eMMC memory is written to the image “kernel.img” which contains a (default) option dtb (which not corresponds to the model VIM). Therefore, the transition to the new kernel (and new dtb data), in update file “tar” needs a manual copying process. Either need to change the update script, something he was looking for the dtb file and if present he updated it (to the extent possible, I will think about how to do it better).
  2. If you update dtb data in the images on external media where they used the automatic download dtb from the internal memory, you will need to manually add the old variant dtb (to add to the media file “dtb.img” from the image).


Assemble new version 20170807 of the LE for KVIM. The site is indicated by the suffix VIM. Note that in this version do not need to perform any manipulation of the DTB file. The required data are part of the image for recording to external media and in the TAR file. Please check how to work this version of VIM when you upgrade using the tar file and using a clean installation.


Version KVIM-20170816.

In this embodiment, a modified procedure activation TV. The system will attempt to obtain the possible settings from the TV, if this is not possible, it will use the previous version of the installation the screen resolution. Please check this option and write, if at system startup, there will be problems with the initial splash screen (the inscription LibreELEC at startup).


A few days ago I tried an update from 20170705 to 20170807 with the .tar method (using LibreELEC-S905.aarch64-17.3_20170807-KVIM.tar) installed on a SD card, but it didn’t work, the boot process stopped at the same place as before.

Putting the correct DTB file on the SD card fixed it. I haven’t yet tried the latest version 20170816 or a clean install.


Pay attention to the version of the images without the suffix “KVIM” use a different set of files, so I have other terms of use.


v 17.4-20170822-KVIM


Hi Everyone!
I have just get my new VIM board and I want to install LE on eMMC (no Android, just clean LE). To be honest, I am a little confused by which version should I use to prepare the SD card - the one with KVIM suffix (*KVIM.img.gz) or without it (*img.gz)? What is the difference between them? Thank you in advance for your help.


For VIM you need to use a version suffix KVIM (this version is tailor-made for this model). To install to the internal memory, you can use the menu item “Reboot install to eMMC”. If something is not clear - I hope other users will be able to tell You in detail what to do. By the way, I would be very grateful if there are users who will do detailed instructions and video. I have no time (all the time spent on the development and Assembly of new versions of the LE and Linux).


The new version of the image 17.4_20170830_KVIM.


Want to try LE with the kernel 4.12 + KODI-18. Download the link image. Unzip. To record on a USB flash drive. Work with the SD card I have not yet tested, probably will work. Rename the file “meson-gxl-s905x-khadas-vim.dtb” to “dtb.img”. To connect to VIM and run it. Need to control a connected USB mouse. :slight_smile:

Mandatory condition - the presence of an activated universal multi-boot. If it is not already active or you are using an older version, you must update the multi-boot to the latest version. All the necessary files are in the way, use the toothpick or via the installed app “Update&Backup”.

If you add “remote.conf” (you can take from the root of the captured image file remote.conf.vim) and put it in the default directory /storage/.config, partially working remote control (the OK button doesn’t work yet, not managed to do).

P.S. This is an alpha version so there are imperfections and bugs.

The main source Neil Armstrong. I added multiboot, all arranged and assembled in the desired form.


A test image with kernel 3.14 + KODI-18.

To start, after writing the image to media, download the dtb file for kvim from here and replace existing file “dtb.img” on the media.


I wrote the image to the media (SD) and rebooted successfully into LibreELEC via UPDATE&BACKUP but I can not find any Wifi Settings.
Do I have to connect through the wire connection?



Thanks for these images.

I’ve installed LibreELEC-Generic.aarch64-18.0_20170831 on an SD card and it boots.
I renamed “meson-gxl-s905x-khadas-vim.dtb” to “dtb.img" and “remote.conf.vim” to “remote.conf”.

As you said, the remote is partially working.

There is an issue where the display flickers when you move the mouse (with USB keyboard/mouse).

A bigger problem is Wifi and Bluetooth don’t work.

I may not have followed your instructions properly regarding multiboot. I currently have the latest Android 7.1.1 (not multiboot) installed on the eMMC. I don’t know if this would cause problems.


If it’s image-4.x, then there is no support for WiFi.

This is a test image, there are still many things not working.


Hi where can i download this specific version (17.4_20170830_KVIM) ? I can not find it … I also just want the LibreElec on the eMMC, by use of the Burn_Card_Maker.exe. I want the correct (latest but stable and complete SW for this. Can someone please tell me where to find it ?

By following: i do not see this file, which was recommended.

I have this now: Vim_LibreELEC_V170116 … should be correct(?) but since balbes150 said that for VIM i need to use a version suffix KVIM (this version is tailor-made for this model), i am confused.

Can someone enlighten me a little bit … dont know what to do and dont want to brick this new unit in the first week :slight_smile: