LibreELEC for Khadas VIM (SD & USB & eMMC)


#262

Updated version of Libreelec KODI-18 20180726.

In this version added a “parallel” installation Libreelec with Android in eMMC (menu off “Reboot from copy to EMMC”). In this mode of installation, Libreelec is copied to eMMC without removing Android and can be run in turn from eMMC either Android or Libreelec. Due to the fact that Android does not have a reboot mode in LE, LE always starts first, to start Android you need to select “Reboot from Android” in the menu to turn off Libreelec and the system restarts in Android. Pay attention, in the copying LE in the eMMC completely remains the whole Android system (all modes Recowery, etc.). Please note that this is only a “copy to eMMC” test, it may be errors. It is currently only tested on the regular firmware Khadas VIM1\VIM2.


#263

My VIM has the 20180608 version running, there are currently two problems:

  1. The default SAMBA share doesn’t work, while it worked in previous versions. I’m using macOS to access it, the share can be found on the network but cannot be opened.

  2. The new versions from July won’t upgrade. I copied the file to /storage/.update/ using scp, but it won’t upgrade and says “missing target (kernel) image”.

@balbes150 would you please take a look?


#264
  1. Turn on in the settings of the minimum level of SAMBA is the SMB2 -> SMB1
  2. Most likely you are using the version of aarch64, and you are trying to upgrade to the version of arm. To switch to another version, you need to use an additional file in the directory update “.nocompare”. The details are in the WIKI LE.

#265

Hi @balbes150, thanks for you reply.

The SAMBA issue resolved with your solution, great!

However, the second issue still persist no matter I put .nocompare or .nocompat.


#266

I also tried CoreELEC, no matter which version I try, the same issue.

Finally, I got the archive decompressed and manually replaced/renamed the files in the SD. Now it’s working and the problem is gone, I tried to use SAMBA update and it worked.


#267

In honor of my anniversary with his beloved wife (25 years together … ). Surprise for all Khadas VIM1 (S905X) users. Test version LE-9 with kernel 4.18 for VIM1 users … :slight_smile:
Please note, this is only a test version , a lot of it does not work (does not work 4K and more)…


#268

Wow, nice day for you and your family! :couple_with_heart_woman_man:

And, thanks for all your efforts on all the great ROMs :blush:


#269

Happy anniversary.:tada:
25th is silver if I recall. Wish you many more years of happiness together.

Also want to add a big thanks for all you do to make our tech lives much more enjoyable.


#270

:confetti_ball:Well Done, all the best to you and yours :confetti_ball:


#271

С Юбилеем! Здоровья и процветания Вашей семье! Спасибо за все, что делаете для сообщества!


#272

Спасибо за поздравление.

Попутный вопрос, у тебя есть (кроме VIM1) модели ТВ боксов на S905X ? Я залил на сайт версию с набором нескольких dtb , было бы интересно попробовать запустить на других моделях с ручным копированием dtb, как это есть в прежних версиях LE.


#273

На S905X только Khadas VIM.

Потестировал последнюю Вашу сборку. Обнаружил только одну проблему, при перемотке зависает видео.
Странно, что никто еще не сообщил…


#274

А можно ли эту версию перенести не EMMC LibreELEC-S912.arm-9.0-devel-20180726
А то на SD записал проверил все отлисьно
4К и CEC работает.
При попытке перенести на ЕММС ругается на отсутствие партиций насколько я понял.


#275

Может проблема в том что на EMMC стоит не Android а Libreelec 8 ?
Обновить его пытался закинув tar файл с 9 версией в папку update, но он ругнулся на версию.


#276

Какая модель ТВ бокса и версия LE ?

Как пробовали устанавливать в eMMC ?


#277

Vim1 Pro, версия 9.0 от 08.08.18.


#278

У тебя есть машина времени ? :slight_smile:
Твое сообщение об ошибке датировано двумя днями ранее (от сегодняшней даты 08-08-2018) …
Версию с ядром 4.18 (если речь про нее) с датой 20180808 я только загрузил на сайт, других версий с датой 08082018 у меня нет …
"… что-то здесь не то … " (с) :slight_smile:


#279

Я просто перешел на яндекс диск и посмотрел на дату (в суете даже не понял, что это сегодня) :smile:
Прошу прощения за предоставление недостоверной информации.
Разумеется я имел ввиду версию 9.0 с ядром 4.18 от 04.08(?) (“юбилейная”).
Спасибо за новую сборку. Потестируем… :sunglasses:


#280

Версию 9.0 с ядром 4.18 от 08.08.
Khadas Vim1 Pro
Проблема с перемоткой видео сохранилась, все так же зависает. Проигрыватель видео выглядит так, как будто сдвигаются слои интерфейса. Настройками декодера проблема не решается.
Порадовала скорость интерфейса и работа HDMI CEC - ни одного зависания/отвала за все время тестирования.