LibreELEC for Khadas VIM (SD & USB & eMMC)


I can confirm that LibreELEC-S905.arm-18.0_20180522.img.gz doesnt have problem with turn off and turn on tv. Although it does have other problem.

I think i can live with that for now.



I have tried to update Libreelec ftom LibreELEC-S912.arm-18.0_20180522 to LibreELEC-S912.arm-18.0_20180601 (tar file saved under update folder). Everything seemed to be ok, but during booting it´s showing me error like “Error in mount_flash: mount_part: Unknown filesystem”. LE is in EMMC. Any idea how to make it working again? Thank you


Why not try Coreelec


What kind of profile are you creating ?

What logo do you write about ? What do you have installed in eMMC ?

Need a new installation. Please note that KODI-18 is a test build. They have many functions that can change significantly (debugging program), so any nuances are possible.


By profile i mean kodi profile.

Freaktab logo is the first logo you see when booting. After freaktab logo, i see libreelec logo.

As for emmc, i install superceleron android.


I checked the version of 20180601 on my VIM with USB stick. Created a new profile. I checked the shutdown and reboot. I didn’t find any problems. Check your media (try another USB flash drive), or the reason in the firmware. I have the latest version of Android firmware in eMMC.


First of all, I would like to thank balbes150 for creating LE build for this board! Works flawlessly and playback is smooth.
My first board for LE (after x86 machine) was Odroid C2 with eMMC, but there is one little problem with this board - it is a bit expensive (about 110$ with shipping and taxes). This time for my boss I chose VIM 2GB.
Installation was fast and easy and I got LE on eMMC working.
There are couple small differences between these two boards:

  1. Khadas comes a all-in device with wifi and eMMC on the board already and a nice housing - that is much better than Odroid C2.
  2. Odroid shuts down when I turn off TV (I use CEC) and boots, when I turn the tv on and switch to the box in Simplink (LG version for CEC) menu. VIM does not do that, sadly. Tv does not detect any CEC device when VIM is shut down. Does anyone know if this can be fixed by patching software or is it purely a hardware problem? I tried setting “stand by” in VIM CEC options, but the board stays on when ?I switch off tv.
  3. As far as I see, there are no “official” builds and there will be no auto-update?


Actually, bot VIMs feature with CEC, but not sure whether the LE ROM support this yet or not.

To confirm the hardware, you can install our official Android ROM for a test.

Have fun!


Which version of LE do you USE ?

Automatic updating is an evil that does more harm than good. Any system update should be controlled by the user and performed in several stages.

  1. Create a backup of all settings.
  2. Start the new system from external media and check all functions used.
  3. If the operation of the new system from the external media is completely satisfied, only after that, the update procedure is started in the eMMC (using the “tar” file).


Thanks for quick reply!

Both VIM and C2 are using latest available - 8.2.5 official on C2 and 20180601 on Khadas.
I have strong suspicion that Khadas is using different chip for CEC. At the Kodi startup of C2 i see message “PulseEight CEC adapter”
Also, there is no device in TV’s Simplink menu, when VIM is shutdown.

About updater, you are right, especially when it is Microsoft. :wink:
I only update, when Google breaks Youtube plugin. My main usage of tv is Youtube with Kore plugin on my phone and live tv from tvheadend.


Actually, the CEC is built-in the SoC/CPU not a independent chip. :wink:


Ups, my bad. I will investigate standby and shutdown then. Maybe the difference is there.


This is a test version with KODI-18. When I start I see a message about the presence of the CEC adapter, but I did not check its operation. You can use the version with KODI-17 (on Odroid C2 you use this version).


I install LibreELEC-S905.arm-18.0_20180608. On first boot, during libreelec first boot wizard, i turn off tv and then turn on again. Libreelec crash, autoreboot and stuck at boot screen(where it shows freaktab/superceleron boot image)

I give up.


Downgraded to Kodi-17 and tested that image. Everything works, except for Stand-by. When I power off tv, Vim stays on. Funny thing is that there is no “Stand-by” option in VIM or C2 Kodi power menu. C2 goes to standby/shutdown at tv power-off and takes some time to start up, when I choose “Simplink - Unknown device Odroid C2”
Maybe I should just leave it on and not mess around. Everything else works perfect.
Alltogether, this is perfect device to recommend as Kodi box.


Why do you turn off the TV\monitor ?
I test run all test images on their models VIM and VIM2. If I upload an image to the site, it means I have a normal run from external media. I already wrote to you that one of the possible reasons for the strange behavior you have, another version of the firmware. You can make a full backup of internal eMMC memory to external storage (using ddbr utility from Armbian). After that, install (USB Buirn Tool) the latest stock Android firmware for your model and check the operation of LE.

Stand-by mode is not supported in these KODI versions.


Then it must be that my C2 shuts down, instead of stand-by and boots up on CEC connection.
After some more testing, VIM seems very fast and fluent. No problems and no glitches.


I understand that you are unable to reproduce the errors. WHat can I say?

Regarding turn off turn on tv, I did that to reproduce the error when I turn off and turn on tv. Should we turn on tv 24hrs to use Libreelec? Is it to be expected to turn on the tv all the time because we are using Libreelec? I believe not. I did that to trigger the error when turn off the tv and the error still exist.

I tried Coreelec but its much worse. I was unable to boot to Coreelec at all.

Luckily, I found LibreELEC-S905.arm-18.0_20180425.img in my drive and when I tried that, I experience no problem at all. So Ill stick to this version for now.

Thanks for trying to figure out the problem I had.


If you connect your UART console to C2 and see what happens when you put it on stand-by, you can know exactly what’s going on, off, or standby. By the way, when I tried to build the system GSTPlay (it is completely collected from the source BUILDROOT Amlogic), I noticed that there when you press the buttons keyboard , to fall asleep system and have to press the power button to get the system back to work. I’m will need to study the sources more closely , perhaps this behavior can be implemented in LE.

You cannot turn off the TV during the initial startup of the setting. At this point, the system is polled for the presence of different modes and their recording in the settings.


I turn off tv when everything has settle down. When im at the home menu of libreelec.
Let me know if I can assist by providing log files(point to me log files that you need).