LibreELEC for Khadas VIM (SD & USB & eMMC)


With the latest Leia, Libreelec addon doesnt work. Any idea how to make it work.


The Libreelec settings addon works for me and is preinstalled. Sometimes it can crash the system if it is called when there is media playing. It is a good idea to only run the Libreelec addon with no media playing at the same time. The latest Coreelec 8.90.1 no longer suffers from this problem on my system.



For those who need additions - use the option “arm”. Add-ons are not yet ready for the “aarch64” version.


Thanks. Ill try that.
Edit. Used arm and Libreelec addon works.


Update image 20180506.


On all firmware above “Libreelec_KVIM_KODI-18_20180417” can not install “pvr iptv simple client”.
I had to return to “Libreelec_KVIM_KODI-18_20180417”.
Channels open and switch instantly and on top of the playlist.
On the firmware below “Libreelec_KVIM_KODI-18_20180417” channels open behind the playlist.


Can I update without have to reformat sd card? like windows update. no need to reinstall.


If these are close versions (arm->arm), you can use the standard upgrade procedure, through the file.“tar.” It is described in the WIKI on the LE website.


Successfully updated. Thanks for the tip.


Try the new version s905_20180511.


New image 20180511 s905 (for VIM1) and s912 (for VIM2)


Failed to install “pvr iptv simple client”.



In the new version, sometimes the audio have problem making it loading media forever. When I try reboot, it shuts down, instead of reboot. I tried reboot through telnet when that happens, same result, shutdown instead of reboot.

Any advise?


Updated libreelec using LibreELEC-S905.arm-18.0_20180601.tar
Now everytime i change profile, the screen just showing colourful dots. The same thing happens when I turn off my tv and turn on tv again.

Any advise?


I would like to downgrade my libreelec 2 release before. current release have colourful dots problem. the release before have problem when restarting(instead of restart, it shutdown).

Where can I find old release? How can I downgrade without reformatting my sd card?


When running the image from external media, I do not see such problems.

I do not keep archives, all available versions on the site. With such symptoms, I recommend a clean installation. Perhaps the reason in your changes and experiments.


I tried deleting guisettings.xml and reboot but still have the same problem.

FWIW, I use Onkyo AVR.

Any advise? I prefer not to reformat my sd.


Write the new LE image to any external media and verify that IT works.


Created new profile(no change to settings). When turn off the tv, turn back on would restart libreelec. during restart, libreelec hang. i can see freaktab logo. stays like that forever. restarting through console or hardware would allow it to boot properly.

Bite the bullet and reformat sd. when turn off then turn on tv, libreelec reboot and stuck at freaktab logo. Format and install with LibreELEC-S905.arm-18.0_20180601.img.gz

Now gonna try LibreELEC-S905.arm-18.0_20180522.img.gz