Krescue - take full control of your VIM device!

Hello! From video, I realized that you can make an EMMC VIM image from a network from a remote terminal, and burn it to a NAS. Is this a possible scenario? Thanks for the cool work !!!

1 Like

yes its very easy !!!

simple example how to

curl http://krescue.lan.ip/cgi-bin/disk/rd/mmc > vim_raw_mmc_image.bin

or gzip on the fly

curl http://krescue.lan.ip/cgi-bin/disk/rd/mmc | gzip -c >

Great, tomorrow I will try it !!!


I tried the VIM3 version. While it boots when I use the serial method(kvim3# run update) and also boots if I use the keys method for standard update(hold power, short press reset, release power after 5 seconds), I could not get it to boot using TST.

It works great! I made an image of the eMMC. Used Krescue to clean(Erase) the eMMC. Then used Krescue to write the image back to the eMMC.
Krescue conveniently boots automatically if eMMC is empty.
After writing the image to eMMC, everything is as it was, all apps, etc were running as before the eMMC wipe.

Great job @hyphop


TST ??? Plz clarify ? What is TST :wink:
If USB cable connected to host machine power key booting not work for krescue but have some tricks just pull USB cable slowly only until power pins after booting u can plug for full length (USB connector pins have diff length for power and data) if uboot detect USB data pins he goto amlogic USB burn mode


I speak of Terry’s Smart Tweezers. This is mentioned in step 4 above.:slightly_smiling_face:

I was not using host PC. VIM3 powered from Khadas 24w PD power supply and USB-C to USB-C cable.

1 Like

OK )) TsT for VIM1 VIM2 not same as for VIM3

1 Like

VIM3 has TST function. But since VIM3 uses a different method, maybe @tsangyoujun can modify the above instructions to indicate that TST not used for VIM3 for Krescue.:slightly_smiling_face:


Привет hyphop! The SD card is formatted on 2 logical drives, the VIM 3 image about 32 GB EMMS took 11 GB on the memory card. The full image was recorded for 30 minutes, recovery - 15 minutes.

But I can’t log in to the LAN on the krescue, the password is 12345678 - but the SSN connection is not established.

Вообщем с сетью у меня пока не получается вход, ни через lan, ни через веб морду, по UART не пробовал. Под виндой после записи имиджа SD карта не читается, только через diskpart восстанавливается, пока ограничился записью имиджа на NAS, с него на карту,с карты бэкап.
Спасибо за отличную работу!!! Thanks for the excellent work !!!
П.С. после бэкапа на CD карту она открывается только на устройстве с которого сделан бэкап? Не могу получить к ней доступ с других систем. Это защита?:sunglasses:


My use case is in its current state: I use a 64 GB class 10 SD card, write Krescue and good system images (Android, Ubuntu, etc.) to it and store it as an emergency disk in the cabinet. It reminded me of Noron Ghost of Windows 98 and the good old DOS from my youth! Thank!!!


Yea I really like what @hyphop made! Norton Ghost, exactly what I was thinking. :smile:

1 Like

It is kool and needs a kooler name was thinking, :sunglasses:

KresQ less to type

What say you @hypohop :upside_down_face::upside_down_face:


tnx for alternative name :wink: if somebody have any cool idea about Krescue name - wellcome ! maybe we can change it later :wink:

1 Like

Krescue looks great! Thanks for the pointer, @tsangyoujun.
Q: Does it work with EDGE-V? ex: Could it be used to back up a currently running Ubuntu OS & configurations onto a local SSD, then erase another OS and restore the original from SSD back onto eMMC?
Also, can Krescue be controlled via keyboard, instead of Remote Control?
That’s exactly what I need.:sunglasses:

1 Like

No intended association with Qanon, right? Been seeing lots of Q’s online lately.
Just sayin.:face_with_raised_eyebrow:

Now Krescue only for VIMs board
I can add edge soon !


@TheHermit yes a USB keyboard works just fine :smile:

1 Like

Thanks for the great tool Hyphop.

I was able to clone the image of the emmc in my VIM2 that was stuck in a reboot loop. I have the rescued image file now.

So how do I mount this compressed image so that I can get the files I need out of it? I have tried a couple of methods using cloop and squash but couldn’t get them to work.

Thank you

1 Like

dump image its just raw data compressed by gzip
u can decompress it gzip -dc you.image.gz > image.raw

we have many tools for repairing ! but u need some skills for mount and extract data or change it!!!

best way its a make backup from workable system :wink: and restore this backup

PS: i can make some recomendation for u ! plz say which broken system u have - android or linux ?

1 Like

I had CoreELEC installed in the emmc and neither android (as far as i know) nor linux. At some point CoreELEC attempted to auto update to a new version and after that my VIM2 would just continually reboot.

I want to just open the image to get at all my custom settings and merge them with a new updated CoreELEC version I have installed on USB (which runs perfectly) and them move that all to emmc again.

Hmmm… I see what you mean. having decompressed and mounted that image it really IS a raw disk image.

Sadly though, I do not have a backup of this system. I got it going recently and have been to busy to back it up. Lesson learned in that regard. I might just have to take the time and redo everything manually.

Still I am interested in learning how to rescue this system from the situation I find myself in for future reference. I’d like to hear your recommendations.