Krescue downloading old CE

Hi,

I have updated on my VIM3L from CE 9.2.0 to 9.2.2 and have heavy issues with the live-tv. So I want to downgrade to 9.2.0. Unfortunately the downgrading doesn’t work. I got stuck with the Khadas Logo and than the SBC turns off. That’s why I want to make a fresh install to the eMMC with the Krescue tool but I can not find the old CE Version, just the 9.2.2.

Can anyone help me?

@damianar1984 Hello ,there maybe not a old version . But I think you can ask for help with CE forum.

I already asked but there are no solutions. Besides I need to install it to the eMMC Storage. CE gives only instructions how to install it to SD/USB-Stick.

There must be a way to install it via krescue. Otherwise how did you guys install it to the eMMC?

@damianar1984 You can try with this

Here are the old builds:

https://github.com/CoreELEC/CoreELEC/releases/download/9.2.0/CoreELEC-Amlogic-ng.arm-9.2.0-Generic.img.gz

https://github.com/CoreELEC/CoreELEC/releases/download/9.2.0/CoreELEC-Amlogic.arm-9.2.0-Generic.img.gz

Unfortunately I can not open that file. What do I need to do with it? Sorry I am a Beginner. Do I need to put it to the Update folder?

Thank you. I already tried it with the .tar File but same result.

try so, settings, restore the backup, and specify this file, and turn off the main update!

Ok, I will try it within the next 30 minutes

just in case, turn off the Internet and turn off the update,otherwise 9.2.2 will fly again :slightly_smiling_face:
https://github.com/CoreELEC/CoreELEC/releases/download/9.2.0/CoreELEC-Amlogic-ng.arm-9.2.0.tar
https://github.com/CoreELEC/CoreELEC/releases/download/9.2.0/CoreELEC-Amlogic.arm-9.2.0.tar

@damianar1984 You should burn it with USB-burn-tools

1 Like

I have tried it but It boots to 9.2.2. When I move it to the update, it boots, installs the 9.2.0 then boots and get stucked with the Khadas-Logo

Thank you very much. Your Image saved my life :slight_smile:
Maybe you should think about adding an archive in the krescue tool for older builds so anyone can go back to these builds.

Again Thank You!!!

@damianar1984 We’ll consider your suggestion, thank you .

modification features, but also not bad :wink:

Coreelec can be transfered from a SD/USB card to emmc very easily using the ceemmc tool.
SSH into the box and simply enter the command ceemmc and it will do everything automatically. It is well tested on the VIM’s and has never failed to work for me.

The VIM’s are one of the main test platforms for the Coreelec project so its very unlikely that your issues are related specifically to the release 9.2.2 as no version is released without first passing testing on the VIM’s.

Get a bootable SD and test all is working OK and then issue the ceemmc command from SSH when you have assured yourself its OK.

In my experience when you encounter a problem with playback after a major upgrade (jumping from 9.2 to 9.2.2 is a major upgrade which has skipped a full version) its usually a problem of retained settings messing up the operation of the new version. In this case a fresh install from scratch usually resolves all issues. Start with no addons and reload them one by one testing that all is OK after each one. Addons are the major source of system problems and only the official Kodi or CE ones are guaranteed not to cause instability.

Shoog

2 Likes

try this one