Khandas VIM Pro doesn't turn on

I just received my Khandas VIM Pro and when I connected to energy it light on a LED on red and the screen in monitor switch from ‘no signal’ to black and remain so no matter what I did (pressing Power button for 2-5 seconds or reconnecting the source power through USB-c). My adapter for source power through USB-c is of 5V 2A (used for IPHONE). If I press reset the monitor goes to ‘no signal’ for a few seconds and turn again to black screen.

Is that hardware defective or I’m doing something wrong?

Hello, Please check to see if your iPhone supply is just a power supply or an intelligent charger. Either way, I would check using a different power supply, just to rule it out as the cause.
May also want to check using a different HDMI cable.
Also, first boot may take a couple of minutes, so give it a little time after turn on.
Good luck.



Thanks for the answer. I Thought the same and I tested with over 4 different power sources. My first mistrust was that maybe the source would not provide enough current. That’s why after testing some sources with 1 A I also look for 2 others with 2A of maximum capacity.

Is there any other way to power this VIM besides through USB-c?
In the negative answer, what do you suggest to solve this?
Thank you again.

The VIMs can be fed power thru either of the rear USB2.0 ports, one is limited to 500mA, the other is good to 900mA. See image below for fuse assignments. Check for for more information, see section, Extra Power Input for Khadas VIMs.


Now I could power it with different power sources and It start to be in a loop, first with the screen win VIM and then the screen with the 4 (four) small colored animated points, then black screen and ‘VIM’ again, and so remains indefinably. :tired_face:

Note that the LED always remaining in RED never going to blue as expected…

The other scren during the loop.

Hello, I have no idea if it is hardware problem or software problem. I am curious about the display shown in your pictures. Have you tried a different display to rule it out? Not suggesting the display is bad, but if the resolution is non-standard, maybe it could cause the hang. I have no experience with the hangs on either of the VIMs(VIM1&VIM2) I own, so my thought on the display is just a guess.

Make sure no uSD card(TF card) is in the VIM’s card slot when attempting to boot.

If you try a different display and cable, or have tried them already, and it still hangs, maybe attempting to flash your VIM’s firmware will resolve it.

Because your device is new and has yet to boot, before flashing, it might be better to wait for one of the Khadas team, @Terry, @numbqq, @Gouwa or others, to advise you from here.

In the meantime, if you would like to learn about the methods to flash firmware to the VIM, see here. Firmwares to flash can also be found there.

Hope you get it going. :slight_smile:

hi, keglevich:
Did you update the Surper SU application? You can try to flash the ROM
Have a try. Thanks!

1 Like

Hi all,

Thanks for the tips!

Yes I already tried different displays, included an SmarTV 40" wide 4K and yet the still on loop. I also inserted a 64 Mb SD card but I couldn’t format it because I could format it directly with the VIM. Since it says that it came already with Android I didn’t concern about flashing the ROM.

Thanks for this tip, I’ll will try in a couple of days and let you know the result.

The display in the foto is a 7-Inch-1024x600 Display Kit that I use for some debuging. More details at

Thank you all. Problem solved VIM running with android.

How was the problem resolved ?


hi connecting extra power in the VIN interface then I searched for better USB source power 2A that isn’t prepared for iPhone (those for iPhone seems not working properly with Khadas VIM).

Yes, some chargers are “intelligent”, and may misinterpret the load of the VIM.
Very glad to learn you got the VIM going. :slight_smile: