Khadas VIM3 - keyboard and mouse are not working

Hello world,

I have a Khadas Vim3, and I want to install Ubuntu on it.

I tried these two images and none of them worked, I cant even log in without keyboard or mouse!

  • vim3-ubuntu-20.04-gnome-linux-5.17-fenix-1.0.11-220429.img.xz
  • VIM3_Ubuntu-gnome-focal_Linux-5.16-rc2_arm64_SD-USB_V1.0.10-220108.img.xz

I also tried this image,

  • vim3-ubuntu-20.04-gnome-linux-4.9-fenix-1.0.11-220429.img.xz

but it gave me another error related to screen timing,

any help is appreciated :frowning: ,

Hey @Mohammad_Nour_Alawad
sorry to hear about the issue you are facing currently, could you elaborate about the setup with the vim3 you have ? monitor, keyboard, mouse power supply etc.

we can try to figure out, what is causing the issue for USB to hang :slightly_smiling_face:

thank you @Electr1

I am using a Dell screen with resolution of 1280-720, a wired mouse (microstar brand), and none of the images is working,

I have been told that my screen resolution should be 1920-1080 in order for this image to work,

  • vim3-ubuntu-20.04-gnome-linux-4.9-fenix-1.0.11-220429.img.xz

but it is very expensive to replace the screen so I replaced the ubuntu image, and it still dose not work,

I read some previous solutions about erasing the eMMC,
how can I do that if I can not connect my keyboard?

If you have a wireless USB adapter remove it and use wired USB keyboard directly on the USB2 port (near the 3 buttons). That must be plugged in before powering up the board.

Its best to go simple and basic until you find the problem.

Did you try reverting back to android installation, does it work there ? it will help check if it is hardware mismatch, usb damage, or some other bug.

hey @foxsquirrel ,
I actually tried an older image, and everything worked just fine,

  • VIM3_Ubuntu-gnome-focal_Linux-4.9_arm64_SD-USB_V0.9-20200530

so, I guess I can say that nothing wrong in the hardware,

I just don’t understand why the newer versions have this such problems!

hello @Electr1 ,
some images actually works very fine, like this one:

  • VIM3_Ubuntu-gnome-focal_Linux-4.9_arm64_SD-USB_V0.9-20200530

I think it is a problem related to the newer versions, is that possible!