Khadas VIM2 MAX dual OS dead after booting into UBUNTU


i have some serious problems with my VIM2. I just got it today and i installed the latest dual os image with success (VIM2_DualOS_Nougat_Ubuntu-16.04_V171028). After sucessfully booting 2 times in android i tried the option to restart into UBUNTU. When i tried this option after restart i only got a black screen!
The device is totally unresponsive to nothing. The led is burning white. I tried to reflash but windows 7 pro does not recognise the device any more. It shows as nothing is connected to USB.

Please help me with this issue.

Have you correctly booted into recovery mode. here are the instructions:

Hello, Using the supplied USB-C to USB cable…

Press and hold the power button, while holding the power button, Connect USB cable to PC, quick press the reset button, hold the power button for at least 3 counted seconds.

Note: After pressing the reset, it is easy to count to 3 seconds too fast, count out loud to 3 like, 1001, 1002, 1003. You can’t hold it too long, VIMs will enter upgrade mode even if you keep holding the power button. I find whenever I do a deliberate count, VIMs enter upgrade mode reliably.
Hope it helps.

1 Like

Hi klemen,

My VIM2 has the exactly same problem. The android works fine, but ubuntu no way. I was able to flash again using MRegister mode, but same result.

The Firmware DualOS V170818 works fine, but I really need the V171028 because of boot memory.


What’s the ubuntu problem with DualOS V171018? Can you describe it more detail? Thanks

Hi Terry, after flash it boots to Android, so I hold the power button and select the option to boot to Ubuntu. Then the screen turns black, not even the KHADAS logo appears. The LED turns on and off slowly. After that the khadas is unusable, I cannot boot to Android anymore, to solve I have to put KHADAS into MRegister mode and flash again.

Model: VIM2 Max 64Gb


It doesn’t support for it. And You need to boot into android system and long press power button. Then you can reboot to ubuntu.

Hi Terry, sorry for the poor english, but that was what I meant. Long press on power button and then Reboot to Ubuntu. After that my screen becomes black no matter what. The only way I could get out of this is by flashing again using MRegister method.

What’s the resolution of your monitor? 4K? Can you try to connect HDMI with 1080p monitor?
BTW, Maybe you need to provide the printing log for me ? Thanks.
Here is about how to get printing log.

1 Like

Thanks Terry, the problem was my 4K Receiver. My monitor supports only 1080p, but my receiver is 4K and the Khadas was plugged through the receiver, when I plugged direct to my TV the problem was solved.

I bought the Khadas recently, so I was not aware how the front LED works, the normal behavior is blinking.

Thanks again