Inception_v3.nb is not a core dump: File format not recognized

Will inception_v3.nb converted from Tensorflow 2.1 be usable by aml-npu on VIM3 ?

  • Tensorflow on Host
➜  ~ python
Python 3.6.9 (default, Apr 18 2020, 01:56:04) 
[GCC 8.4.0] on linux
Type "help", "copyright", "credits" or "license" for more information.
>>> import tensorflow as tf
2020-04-27 15:17:40.112242: I tensorflow/stream_executor/platform/default/] Successfully opened dynamic library
>>> tf.__version__
>>> tf.__file__
>>> exit()
  • I did specify Fenix while building EXECUTABLE inceptionv3

  • Segmentation fault on VIM3

When I tried to debug on VIM3, I got the following ERROR message:

./inception_v3.nb" is not a core dump: File format not recognized
  • Then, I tried aml_npu_sdk/linux_sdk/linux_sdk_6.3.3.4 on VIM3 without re-compile at all, but failed with Segmentation fault as well.

Clearly, this has something to do with either inceptionv3 or inception_v3.nb.

I just wonder if the source of aml_npu_sdk can be provided for us to build by ourselves?



Just a data file, not an executable

Hi, Frank, I just had aml-npu upgraded this morning, from to .
However, my aml-apu-sdk is still of version

Is it possible that this is caused by the driver and sdk are of different versions?

@jiapei100 No impact

Hi, Frank… Finally, I figured out how to build the demo inceptionv3 onboard directly, with aml-npu, but still failed to run it with Segment Fault

  • I failed to run the demo coming with the SDK
  • I successfully built the demo with aml-npu from repo, but failed to run it…

Any further suggestions?

The model (the *.nb file) I converted can be found

Any further suggestions?


Great… Finally, it’s running… What a long journey…

Thank you very much Frank…

Now, start coding with npu… Thank you