Hung on android logo

We were able to build the android from source using the instructions here: In this custom version, we were able to include our apps. As part of this customization, one of the core requires couple of xml files placed under /data/system/ folder.

So we updated the /system/core/rootdir/init.rc file to:
chmod 0600 /data/system/file.xml
chown system system /data/system/file.xml

For some reason it doesn’t like “chown …” and the module get stuck at the android logo. If I remove the “chown…” command it boots fine but app fails as it doesn’t have admin permissions of the file.xml

Any pointers?

Any pointers?

does chmod 777 work ?
did you give the execution permission ?

Maybe it doesn’t like to have just the first group to be able to read, write, and execute it, :man_shrugging:

Yes, I tried chmod 777 instead of chmod 0600 as well and it get stuck at chmod 777 step

have you consulted Terry ?

he opened the topic for this


Yes, maybe @experi_me_ntos try posting there itself…

he has already published, where else should he publish?

I think Terry will understand the problem after advertising it in so many places :grin:

thanks to you, I hope he will notice

I think I found the issue. Looks like it is related to app changing the default launcher and nothing to do with the chmod/chown itself.


Hmm, ok, well it is good to hear your problem is solved :slightly_smiling_face:

it’s very good that your problem is solved