How to use linux kernel I compiled?

I think you lose the config file env.txt

I re-compile the kernel with arm64 default config, it runs successfully!
@balbes150 @Frank @numbqq Thank you for your help! :relaxed:

@numbqq @balbes150 @Frank
Another problem!!
I can’t access domain name,

this is my boot.ini

setenv kernel_loadaddr "0x11000000"
setenv dtb_loadaddr "0x1000000"
setenv initrd_loadaddr "0x13000000"

booti ${kernel_loadaddr} ${initrd_loadaddr} ${dtb_loadaddr}

Well, emmm, it just a / permission problem.

Anyway else? I don’t want install android, and I found that it wouldn’t run my kernel ,but can boot with my rootfs.

I did it! I saw four penguins in my screen ( :grin: like a hen just laid an egg )


Which kernel did you compile?

@Spikerguy Kernel 5.2.0, ROOTFS:ArchLinuxARM, (no wifi and gpu drivers)

1 Like

I don’t know how to create this uInitrd, it seems to contain a gz file(may be initramfs) and 0x40 Bytes head,
I can only create initramfs-linux.img.
Can you help me?

Solved, I use mkimage to convert initramfs-linux.img!
(but still no wifi and gpu)

wifi driver is ready, maybe I can make a server image now!

1 Like

yes, go on ! :::::::::

@ravelo @Frank @balbes150 @Spikerguy @numbqq
My ArchLinuxArm Image is ready.


    For wired connection:
  • dhcpcd service is disabled by default, you can enable it manually.
  • For wireless connection:
  • you can use 'wifi-menu' to connect to WiFi
  • If you want to test with another kernel,I've created a script(/root/update-uInitrd) to update uInitrd
  • usage: sh update-uInitrd [kernel version] [initramfs generate path+name]
  • How to use XDM
  • write your desktop session to ~/.xsession
    echo xfce4-session > .xsession
    echo startlxde > .xsession
  • make sure your .xsession is executable, `chmod +x .xsession`
  • you can enable (xdm.service || xdm-archlinux.service) or you can run xdm directly. Another question about XDM

Wifi works. but I have some problem about rootfs permission, normal user can’t even access file, so I can only login as root, I’ll post new image,modules and kernel, if you don’t want to use this only root image, just update modules and kernel to this new version. Or you can execute chmod 755 / to solve that problem.

After burning
you have to resize the rootfs partition manually.

Working on:
temperature-controlled gpio
usb wifi(rtl81xx,mediatek76xx)
HDMI Audio




@_no_proxy,OK,give me a link with you firmware.I will test it this two days.Thanks.

1 Like

Thank you for your test. :smile:

@_no_proxy,OK,we will test it.

1 Like

how did you fix the mess in the emmc ? did you finally flashed an android firmware there as a prerequisite ?

@ravelo No,just copy boot.ini from official image and have a little change.

What’s the kernel version ?

Kernel version is 5.2.1 .

1 Like