How to use bluetooth keyboard (and mouse) on ubuntu (server and mate)?

Hi all,
for some reasons, like usb not working yet w/ mainline kernels,
I would like to be able to use a bluetooth keyboard to - at least - enter login/passwd on the linux session on the hdmi display.

I assume I use the kvim onboard BT controller, that serial console already works ok, and that I use 4.12.7 (or more) kernel and ubuntu base (16.04.3 or more).

Any advice on making BT kbd work on older kernels or older ubuntu are of course very welcome if they can help me achieve my goal;

Please feel free to share your valuable knowledge you may have on the subject, thanks in advance and let’s make the kvim (pro) greater !

google was again my friend,

I stumbled upon this good web page:

and I begun with these commands :

sudo bluetoothctl
[bluetooth]# scan on
Discovery started
[CHG] Controller 44:2C:05:B6:BD:FF Discovering: yes
[NEW] Device 00:18:00:09:B8:3C BTKB-B83C
[NEW] Device 7C:C5:37:6A:A6:F8 Raxy-iOs-61
[bluetooth]# pair 00:18:00:09:B8:3C
Attempting to pair with 00:18:00:09:B8:3C
[CHG] Device 00:18:00:09:B8:3C Connected: yes
[agent] PIN code: 233649
[CHG] Device 00:18:00:09:B8:3C Modalias: usb:v0DC6p3752d1001
[CHG] Device 00:18:00:09:B8:3C UUIDs: 00001124-0000-1000-8000-00805f9b34fb
[CHG] Device 00:18:00:09:B8:3C UUIDs: 00001200-0000-1000-8000-00805f9b34fb
[CHG] Device 00:18:00:09:B8:3C Paired: yes
Pairing successful
[CHG] Device 00:18:00:09:B8:3C Connected: no
[bluetooth]# connect 00:18:00:09:B8:3C
Attempting to connect to 00:18:00:09:B8:3C
[CHG] Device 00:18:00:09:B8:3C Connected: yes
Connection successful
[CHG] Device 7C:C5:37:6A:A6:F8 RSSI: -71
[CHG] Device 7C:C5:37:6A:A6:F8 RSSI: -60
[BTKB-B83C]# trust 00:18:00:09:B8:3C
[CHG] Device 00:18:00:09:B8:3C Trusted: yes
Changing 00:18:00:09:B8:3C trust succeeded

And voilà !
I was able to type (on the hdmi tty session) my login and password from my very old KeySonic 340-BT Bluetooth Keyboard!

Does it survive the kvim reboots ? YES indeed, it does !
The only remaining problem is the layout, but I thing it’s time to do some reconfiguration to fix it…

And I also need to check if the trackpad will be able to work under the X11 GUI, once I manage to have one running on the kvim


and as a happy :yum: bonus,
I now also managed to make the kvim take into account my non-us-qwerty layout keyboard to enter my credentials on the hdmi linux session after boot !

I tried these and it worked initially, the keyboard had since disconnected and I’ve been unable to pair since.

why !? which distro have problem with USB ?

my message was dated …2017, so it is a very old issue, not sure today it is still valid with mainline linux 5.5