How to run my own model with NPU

@liudongbo If you are using the Android system, you can refer to the following documentation to see if it is helpful to you.

Hi all,
I have fellowed the document above . when i installed app on vim3 , and click the button YOLOV3 MODEL , it flashbacked , and return as bellow on android studio :

Hi all,
anybody help me please ?


@liudongbo What version of firmware are you using?

Hi goenjoy,
The firmware is the old one which is exist before , i don’t know which version.
I have tried to download the latest but failed , because i didn’t find it or there is not on the website any more . could you send me one please ?
What’s more , i just installed USB_Burning_Tool on my PC , but it could not find the device ,please look at this :


View the version information in the about of the settings

vim32 bit firmware:

vim64-bit firmware:

How to enter the upgrade mode The following documents have detailed instructions

Hi all,
This is version info :slight_smile:

Then you can try to update the system firmware, either 32-bit or 64-bit

Hi goenjoy ,
I fellowed this document ,when i compile yolov3 ,it returns as bellow:

Could you tell me what’s wrong with it please ?


Hi all,

anyone here please ?

Download khadas_ android_ npu_ The library uses the following command

git clone -b khadas_ ai

You’re in khadas_android_npu_library Check the git log in the library to see if the latest commit is f0505038c156da9058501b21e82cfb8c33732a60
Branch is khadas_ ai

If you have any changes, you can roll back first to ensure successful compilation


That true the latest commit is f0505038c156da9058501b21e82cfb8c33732a60.
You mean that i roll back to f55df43a79586ce6fdcd809444b5b88b8aefad28 ?

Did you modify anything? I just tried my local compilation and it was fine.

Hi all,

I have roll back to the first . but it returns the same error as before.
Our company wish that i can survey the device faster . could you help me please ?

Hi ,
I just fellow this :slight_smile:

Quantify yolov3.weights which is downloaded from website , and copy those files ,vnn_pre_process.h,vnn_post_process.h,vnn_yolov3.h,vnn_yolov3.c to khadas_android_npu_library

Hi all ,
I have roll back to the first commit , and compile successfully. then copy and into khadas_android_npu_app , launch to vim3 .but i can not detect anything .
What can i do next ?

What’s more , if i want to run yolov5 / resnet50 or any other models on NPU . what can i do ?

You can use this firmware to authenticate your own NPU


I have already installed vim3-android-9-32bit-v221228.img.xz and updated to VIM3_Pie_V211220.7z , it still has the same problem . Yolov3 model detected nothing , however , YOLOV2 ,YOLOFACE and INCEPTIONV3 are work well.


who can help me please ?