HOW-TO install Fedora Linux for any Khadas SBC

@hyphop I didn’t find that kernel module and couldn’t add it when building manually, also the server script seems to have some issues:

root@Krescue:/# curl -jkL
install/ | sh -s -
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100  3923  100  3923    0     0   8795      0 --:--:-- --:--:-- --:--:--  9165
ArchLinux installation for Khadas VIM3 ... > /dev/mmcblk1
check network connection...
PING ( 56(84) bytes of data.
64 bytes from icmp_req=1 ttl=59 time=6.32 ms

--- ping statistics ---
1 packets transmitted, 1 received, 0% packet loss, time 0ms
rtt min/avg/max/mdev = 6.324/6.324/6.324/0.000 ms
[i] fast opkg install
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100   629  100   629    0     0   1419      0 --:--:-- --:--:-- --:--:--  1459
100 1116k  100 1116k    0     0   813k      0  0:00:01  0:00:01 --:--:-- 2061k
Installing kernel-modules-fs (0.0.0) to root...
Configuring kernel-modules-fs.
download and extract
pixz: image Fedora-Server-34-1.2.aarch64.raw.xz > /dev/mmcblk1
can not seek in input: Invalid seek
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
  0     0    0     0    0     0      0      0 --:--:-- --:--:-- --:--:--     0
100  788M  100  788M    0     0   772k      0  0:17:24  0:17:24 --:--:--  570k
label: dos
label-id: 0xd17792e4
device: /dev/mmcblk1
unit: sectors

/dev/mmcblk1p1 : start=        2048, size=     1228800, type=6, bootable
/dev/mmcblk1p2 : start=     1230848, size=     2097152, type=83
/dev/mmcblk1p3 : start=     3328000, size=    11352064, type=8e
partition: none, disk: /dev/mmcblk1, lower: 0, upper: 0
/dev/mmcblk1: partition table type 'dos' detected
/dev/mmcblk1: partition #1 added
/dev/mmcblk1: partition #2 resized
/dev/mmcblk1: partition #3 added
/dev/mmcblk1p1: UUID="8171-1D60" TYPE="vfat" PARTUUID="d17792e4-01"
/dev/mmcblk1p2: UUID="8994f34c-2c8d-4ab6-a61a-aa1ef8338d07" TYPE="xfs" PARTUUID="d17792e4-02"
/dev/mmcblk1p3: UUID="G27dL3-f2Cn-Wup4-Au99-x2fS-MYYV-HFvhnt" TYPE="LVM2_member" PARTUUID="d17792e4-03"
/dev/sda1: SEC_TYPE="msdos" LABEL_FATBOOT="rescue" LABEL="rescue" UUID="DEAD-BEEF" TYPE="vfat" PARTUUID="20bfde93-01"
/dev/sda2: LABEL="dumps" UUID="6F5A-7D16" TYPE="exfat" PTTYPE="dos" PARTUUID="20bfde93-02"
cp: can't create directory '3/root/lib/firmware': No such file or directory

tnx ! i will improve this script later

Any plans to fix to allow 4K displays?

its was allowed but i think 4K still not much usable (slow frame rate)


  1. update krescue to last version
  2. curl -jkL install/ | sh -s -


  • splash logo added
  • wifi fw blobs added
Fedora 34 (Server Edition)
Kernel 5.11.12-300.fc34.aarch64 on an aarch64 (ttyAML0)

Web console: https://fedora:9090/ or

fedora login: root
[root@fedora ~]# 


install fedora via online scripts - more easy now

Krescue - online scripts - (beta testing)

Krescue - online scripts - Fedora 35 available


Fedora Improve bugs and other problems

Anyone who have problems with fedora plz submit all issues to bug-report its very easy to improve your favorite distro by yourself


1 Like

FEDORA-2021-fdef34e26f has been pushed to the Fedora 35 testing repository.

Soon you’ll be able to install the update with the following command:
sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2021-fdef34e26f
You can provide feedback for this update here:

FEDORA-2021-7de33b7016 has been pushed to the Fedora 34 testing repository.

Soon you’ll be able to install the update with the following command:
sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2021-7de33b7016
You can provide feedback for this update here:

Last metadata expiration check: 0:07:01 ago on Thu 11 Nov 2021 12:00:42 AM EST.
Dependencies resolved.
 Package            Arch        Version               Repository           Size
 kernel             aarch64     5.14.17-301.fc35      updates-testing      66 k
Installing dependencies:
 kernel-core        aarch64     5.14.17-301.fc35      updates-testing      39 M
 kernel-modules     aarch64     5.14.17-301.fc35      updates-testing      27 M

Transaction Summary
Install  3 Packages

Total download size: 66 M
Installed size: 137 M
Is this ok [y/N]: y
Downloading Packages:
(1/3): kernel-5.14.17-301.fc35.aarch64.rpm       29 kB/s |  66 kB     00:02    
(2/3): kernel-modules-5.14.17-301.fc35.aarch64. 1.7 MB/s |  27 MB     00:15    
(3/3): kernel-core-5.14.17-301.fc35.aarch64.rpm 2.0 MB/s |  39 MB     00:19    
Total                                           3.1 MB/s |  66 MB     00:21     
Running transaction check
Transaction check succeeded.
Running transaction test
Transaction test succeeded.
Running transaction
  Preparing        :                                                        1/1 
  Installing       : kernel-core-5.14.17-301.fc35.aarch64                   1/3 
  Running scriptlet: kernel-core-5.14.17-301.fc35.aarch64                   1/3 
  Installing       : kernel-modules-5.14.17-301.fc35.aarch64                2/3 
  Running scriptlet: kernel-modules-5.14.17-301.fc35.aarch64                2/3 
  Installing       : kernel-5.14.17-301.fc35.aarch64                        3/3 
  Running scriptlet: kernel-core-5.14.17-301.fc35.aarch64                   3/3 

  Running scriptlet: kernel-5.14.17-301.fc35.aarch64                        3/3 
  Verifying        : kernel-5.14.17-301.fc35.aarch64                        1/3 
  Verifying        : kernel-core-5.14.17-301.fc35.aarch64                   2/3 
  Verifying        : kernel-modules-5.14.17-301.fc35.aarch64                3/3 

  kernel-5.14.17-301.fc35.aarch64          kernel-core-5.14.17-301.fc35.aarch64 



check new situation

[hyphop@fedora ~]$ cat /proc/asound/cards 
 0 [hdmisound      ]: simple-card - hdmi-sound

HDMI sound already works - OK


That’s great news, thanks @hyphop

1 Like

@hyphop can we get these scripts to make images with legacy kernel ?

if u talking about vendor kernel from amlogic which used same in fenix ! maybe but not at this time …

1 Like

If i install Fedora using online script, and perform sudo dnf update, HDMI audio will work normally or do i still need to enable testing repos and upgrade the FEDORA-2021-7de33b7016/ FEDORA-2021-fdef34e26f

u can check but i think must be on next release

1 Like

wellcome to Fedora 36-1.5

Fedora Linux 36 (Server Edition)
Kernel 5.17.5-300.fc36.aarch64 on an aarch64 (ttyAML0)

Web console: https://fedora:9090/

fedora login: root

how to use it ? : absolutely easy just start online scripts inside krescue and install fedora by 2 minutes

Fist impressions

everything works well out of box all prev problems fixed :wink:

[hyphop@fedora ~]$ cat /proc/asound/cards
 0 [G12BKHADASVIM3L]: axg-sound-card - G12B-KHADAS-VIM3L

but vim3l WiFi not very stable now :wink: common problem for latest mainline kernel -

[hyphop@fedora ~]$ dmesg | grep fm
[   21.834419] brcmfmac: brcmf_fw_alloc_request: using brcm/brcmfmac4359-sdio for chip BCM4359/9
[   21.837913] brcmfmac mmc2:0001:1: Direct firmware load for brcm/brcmfmac4359-sdio.khadas,vim3l.bin failed with error -2
[   21.840485] usbcore: registered new interface driver brcmfmac
[   21.845533] brcmfmac mmc2:0001:1: Direct firmware load for brcm/brcmfmac4359-sdio.khadas,vim3l.txt failed with error -2
[   24.148503] brcmfmac: brcmf_fw_alloc_request: using brcm/brcmfmac4359-sdio for chip BCM4359/9
[   24.149210] brcmfmac: brcmf_c_process_clm_blob: no clm_blob available (err=-2), device may have limited channels available
[   24.157922] brcmfmac: brcmf_c_preinit_dcmds: Firmware: BCM4359/9 wl0: Jan 19 2018 12:14:30 version (a85e25e@shgit) (r) FWID 01-cb5aa0a5
[   24.177710] brcmfmac: brcmf_sdio_readframes: RXHEADER FAILED: -84
[   24.177733] brcmfmac: brcmf_sdio_rxfail: abort command, terminate frame, send NAK
[   26.717520] brcmfmac: brcmf_sdio_bus_rxctl: resumed on timeout
[   26.771016] brcmfmac: brcmf_sdio_firmware_callback: brcmf_attach failed

prepareing this issue to bug-report

PS: wellcome to testing


@hyphop any plans to make VIM4 script ? :slightly_smiling_face:

yes we have this idea but for vim4 need replace original fedora kernel and gpu packages what no so easy and need time

PS: at this moment u can play your self and replace it by hands a test how its works

1 Like

Cool, i tried to install manually by talking a look at the normal script made for vim3.

I took into account that oowow was in the spi flash and didn’t overwrite it but forgot to check GPU packages.

I will test it some more later and post back here.


1 Like

Any plan to include latest fedora editions to script?

yes will be checked soon

Hi @hyphop

Any update? I want to use latest rolling Fedora on vim3 pro