How to flash vim3 with android 11

i am trying to flash vim3 with android 11
but i get this error :grinning:
fastboot flash boot boot.img
fastboot: error: boot partition is smaller than boot image

Hi, as I understand it, the issue has not been resolved yet :thinking::slightly_smiling_face:

1 Like

hi thanks for replay
well from the source coide of aosp yukawa is build for vim3l but i used this command
it build successfully but i got the error while flash image

1 Like

Upate well i found the correct boot.img under /bootable/recovery/tests/testdata/boot.img

after that i tried to flash this

fastboot flash system /home/boudour/Android11/out/target/product/yukawa/system.img
Sending sparse ‘system’ 1/9 (129732 KB) OKAY [ 7.659s]
Writing ‘system’ OKAY [ 4.987s]
Sending sparse ‘system’ 2/9 (129044 KB) OKAY [ 7.557s]
Writing ‘system’ OKAY [ 4.968s]
Sending sparse ‘system’ 3/9 (129060 KB) OKAY [ 7.649s]
Writing ‘system’ OKAY [ 4.945s]
Sending sparse ‘system’ 4/9 (129044 KB) OKAY [ 7.672s]
Writing ‘system’ OKAY [ 4.969s]
Sending sparse ‘system’ 5/9 (129060 KB) OKAY [ 7.480s]
Writing ‘system’ OKAY [ 4.951s]
Sending sparse ‘system’ 6/9 (129044 KB) OKAY [ 7.443s]
Writing ‘system’ OKAY [ 4.969s]
Sending sparse ‘system’ 7/9 (129060 KB) OKAY [ 7.434s]
Writing ‘system’ OKAY [ 4.942s]
Sending sparse ‘system’ 8/9 (129044 KB) OKAY [ 7.549s]
Writing ‘system’ OKAY [ 4.964s]
Sending sparse ‘system’ 9/9 (32972 KB) OKAY [ 1.919s]
Writing ‘system’ FAILED (remote: ‘Request would exceed partition size!’)
fastboot: error: Command failed

can you please help me

@Boudour the khadas team is on spring vacation, they will look into the issue only after they return 2 weeks from now…

1 Like

ah okay thanks alot guys i will wait so <3 enjoy your holidays

1 Like

Hi @Boudour ,

I meet the same problem when I try to flash Android 11 image. :smiley:

And I found another way to flash image from, which is also shown in Khadas_VIM3 · Wiki · BayLibre / amlogic / Android TV / aosp / device / amlogic / yukawa · GitLab.

I think you can try this.
However, another question is that, if you want to burn only system.img or vendor.img , you need to use “fastboot flash super super.img” , which is very strange. :grinning:

Best Regards


Hi @lthxxn thank you alot for your replay i will test it

@lthxxn have you an idea about this boot.img under this path /bootable/recovery/tests/testdata/boot.img

I didn’t even know this file existed. :joy:

1 Like

hhhhh it exist just try to search and wait awhile you will find alot of intresting for example i have found another thing like u-boot is under the external folder

@jasonl Please follow up this.

1 Like

@Boudour when you build aosp android11 code for vim3 &&vim3l ,these is no system.img ,only super.img ,super include vendor and system partition ,you can refer Khadas_VIM3 · Wiki · BayLibre / amlogic / Android TV / aosp / device / amlogic / yukawa · GitLab to build android11 code


thank you @jasonl for the replay but after flashing the android 11 my vim3 is dead so i had to buy another one

@Boudour If you follow the documentation step by step, vim3 can successfully run Android 11. I don’t know what’s the difference between you and me

@jasonl well the difference is that i did it by my own following aosp official documentation after downloading this by :

repo init -u -b android-11.0.0_r31

and i have got this error the boot cant flash the boot img

after this i had found those command so i changed the u-boot.bin file for android 11 so i can flash the boot.img then fastboot the img the black screen after 2 day i tried to reback to the android PIE so i reflash the uboot.bin of android 9 then the led stops working
for allimentation i used the usb type C linked to my laptop i didnt ry any electronique stuff i thing still a problem of the android 11 software it self i dont know what iis the problem exactly but the thing that i am sure about is that i did everything correctly.

this is my code download path

@jasonl yes you followed this link:

It’s hard bricked? Is that possible? I think we can save the device using krescue in all situations…