How to enable UART serial on Vim3

Hello, I’m use Vim3 board and installed
Ubuntu 22.04 server .

I have enabled
overlays=pwm_ao_a pwm_f uart3
in /boot/env.txt but after reboot no ttyS* files in /dev/ directory (no such files).

How to enable UART support in VIM3?

Also I have installed Armbian Bookworm.
/dev/ttyS0-7 files are exist, but no success communication in minicom
(i.e minicom -D /dev/ttyS*), console not recives symbols.

Has anyone successfully connected the serial uart port to devices (via Rx,Tx pinns)?

Which image you used ?

Are you sure you use the correct device node and the connection is correct?

I have installed Debian on SD card from the file:
and apt upgrade from Ubuntu 22.04.1 to:

lsb_release -a

Description: Ubuntu 22.04.03 LTS
Release: 22.04
Codename: Jammy

I’m sure about connections (I have checked connections to my LCD uart with my USB-uart on /dev/ttyUSB0)

For the 6.x version, the overlays may have some issues, have you tried the 4.9 kernek image ?


thank you for advice! Kernel 4.9.241 (Ubuntu 20.04.6) works fine with uart on ttyS3.
How do you think is it possible to fix dt overlays in 6.x kernel?

And one more question: I have tried uart support in Armbian 23.8 Bookworm
without success.
No answer from my device on pins 15,16.
Python sripts pyserial output: “i/o error”. May be you have ideas how to fix the problem or how to troubleshooting this issue? Thank you in advance!