[How to] Debian Stretch + Linux 4.9 from scratch (w/download, EMMC only)

hi all,
i have created the update.img file. I have created an bootable emmc and flased it in hardware. But i didnt see any gui. I am getting command line interface. Please give me your opinion. i have tried to install gnome .But i couldn’t. Please help me why it is so?

Please provide the printing log .

Do you have a TTY-USB tool? Can you provide the serial log and not the burn tools log for me?

Hi terry,
I couldn’t take the printing log. Please help me to take it. Am attaching the image of desk top.

About how to install ubuntu mate desktop, you can refer to the post

Hi Terry,
I need to create an .img file which has Gui. I believe u have seen the image. Is that the same image file which you have made this guide for.

You can look the reply from Gouwa

Hi, here’s the log: https://pastebin.com/5KVcHXbV

After this point, log freezes and the device starts Android from eMMC

Thank you for your work.
Did as described…

Here is the feedback, really nothing big… compiled successfully and flashed it…
Trying to get kodi running now:

regarding bootstrap commands:
The website marked marked this parameter as additional comment.
sudo chroot /mnt/kvimrootfs /debootstrap/debootstrap –second-stage
So I tried to left them out…(sure its an website issue)

regarding last step:
Now you can transfer this image over to a Windows PC and flash it using Amlogic’s USB Burning Tool6.
I was little bit irritated of the the other img files…
It would be better to mention the update.img as file to be flashed…

That’s all… having khadas vim with the latest debian version and the 4.9 LTS kernel…

Thank you :smile:

@test1234, i am astonished you did boot a working linux without doing the --second-stage step in the tuto, do you confim that?

:slight_smile: I did the second step…
tried it without --second-stage and got a parameter missing error…
and then I executed the whole line…

I would not proceed with further steps incl. burning to emmc and
trying to get kodi working if I had any issues here…
I meant only that the webpage is greying the --xxx parameter as comments…
Which causes my misunderstanding, that this parameter can be left out…


ok, understood! tks.

hi, you did use ubuntu 17.04 or 17.10 ?
and did you manage to open a shell session over an usb serial cable as well ?
the latter i never managed to do…

Hi, I had a running Ubuntu 16.04 Server x86_64…
as described…

No, I did not access the VIM debian via USB-Serial …
I was going with ssh to access VIM debian…

kind regards

tks, and was your vim connected over wifi or rj45 ?

I am not expecting much from an initial build…like WIFI drivers or easy config to join WIFI network or GUI…
-> RJ45

I have to correct me, I did make the prep on a Ubuntu 16.04 LTS not debian… but Ubuntu is very common to debian…

ok, good,
you’re right regarding ethernet; i’m currently experimenting w/ sid (instead of zesty or stretch), let’s see what we get

I gave up on 4.9 khadas+ sid, I now focus on 4.12 mainline + xenial

Sorry to polish this post, but I have the problem that Ajithbalakrishnan had, and he managed to solve without giving the solution.

Here is the problem :
"marc @ Khadas: ~ / project / linux $ sudo chroot / mnt / kvimrootfs mkinitramfs -o /boot/initrd.img $ (cat ~ / project / linux / include / config / kernel.release)
open / dev / fb0: No such file or directory
/etc/initramfs-tools/scripts/local-top/khadas_init.sh: 4: /etc/initramfs-tools/scripts/local-top/khadas_init.sh: can not create / sys / class / display / mode: Directory nonexistent
… "

Thank you for your answers.

Sincerely Marc.

PS : See [resolved] Pb with mkinitramfs .... open /dev/fb0: No such file or directory

Is there a way to flash this rom on Linux? For example with fastboot tool.
I did read this page:
But the relevant part is not written yet.

I do not know if you’re looking, but I’ve seen this page
[Burning Tools for Linux PC](http://Burning tools for linux PC)
I have never tested since I can not solve my problem.

Sincerely Marc.