Help needed - bricked VIM2

Hi there - my new VIM2 only had Android on it and I want Ubuntu so I prepared an SDcard and tried to boot into upgrade mode as per the instructions here.

About when I pushed the reset button the screen went black. When I released the power button the screen stayed black - no upgrade/progress nothing. White LED stayed on. After a while tried removing power and plug in again - still only ever black screen & white LED.

I have tried the M-register mode as per this thread with the same outcome - screen stays black, white LED stays solid. (I presume the instructions are short M pins, press & release reset button, then remove short from M pins?)

Any/all suggestions welcome as cant get my VIM2 to do anything now :frowning:

Hello, I have not attempted to flash with a card. Have you tried using the Amlogic USB Burning Tool(Windows) and the USB-C to-male USB cable? When manipulating the buttons(keys) as stated in the following, make sure to hold the power button for at least 3 counted seconds after pressing/releasing the reset button.
“Keys Mode(U-Boot is running)
Power on Vim.
Long press Power key without release
Short press ‘Reset’ key and release
Count 2-3 seconds and release the ‘Power’ key to enter into upgrade mode”

I assume you have read these sections in Khadas Docs/bootcamp,…

Hope you get it going. :slight_smile:


Thanks, sorted with Windows USB burning tool; think (my) confusion as (my) VIM2 has black/blank screen while updating. SDcard may well have been working but I didn’t give it long enough. Windows USB took over 10 mins but at least I had progress bar in Windows.

Hi, dukla2000:
Have you resolved your issue?

As RDFTKV suggested above, you can take a try with the USB-C tools on Windows.

Any update is welcome :slight_smile:


@Gouwa - yes, all resolved :slight_smile: thanks. Based on @RDFTKV suggestion I dug out the only Windoze PC in the house and got the update done. Ubuntu now installed fine.

As I said above it seems my VIM2 does a black/blank screen when updating which is what confused me in the first place. But all is well now.

I realize this has been resolved, but I mistakenly listed USB male-to-USB male cable. Of course, I meant supplied USB-C to USB male cable. I have corrected my post
Glad you saw thru my error and that you were successful. :slight_smile:

1 Like

Hi people,
By accident, I erased the Android system from my device Khadas Vim, when I was trying update it. The device seems “dead”. I’ve tried the metods of “Create LibreELEC Booting Card”. When I used the metod via Windows PC, Win32DiskImager has frozen. When I used the metod via command line, the operation was fine. But, after insert the card and power on the device, the screen turned green. And nothing works.
What I can do? (Sorry for my bad english)

The SD card contains:

drwxr-x—+ 3 root root 60 Set 16 19:15 …
-rw-r–r-- 1 armando users 4631 Out 3 2016 boot.ini
-rw-r–r-- 1 armando users 19073080 Out 3 2016 KERNEL
-rw-r–r-- 1 armando users 48 Out 3 2016 KERNEL.md5
-rw-r–r-- 1 armando users 34738 Out 3 2016 kvim.dtb
-rw-r–r-- 1 armando users 124416000 Out 3 2016 SYSTEM
-rw-r–r-- 1 armando users 48 Out 3 2016 SYSTEM.md5

My problem was with a VIM2: not sure with a VIM but anyone else reading this with a VIM2 do the Amlogic USB Burning Tool (from a Windows PC) with the USB-C to-male USB cable as per 2nd post in the thread.