HDMI Resolutions testing


Maybe your monitor don’t support for 480p. It don’t work if you force to change the resolution to 480P.
Also you have a try following below steps.

1. Download the new TvSettings application

2. Replace TvSettings application with WI-FI adb command.

# adb connect IP_ADDR
# adb root
# adb remount
# adb push TvSettings/TvSettings.apk  /system/priv-app/TvSettings/
# adb push TvSettings/oat/arm64/TvSettings.odex  /system/priv-app/TvSettings/oat/arm64
# adb shell sync
# adb shell reboot

After do that, you can see the 480P resolution on TvSettings application list.


Hi, Terry!

How’s it going with the solution to the UI problem on VIM2?


Thank you!
Early I used this monitor with adndroid tablet on which i select 480p-60Hz, and ewerything was fine. I download TvSettings aplication and do that comands, but after reboot I see “Settings has stoped” :frowning:
I made this not via WIFI, but via USB cable.


Hi, davemf:
The drivers working fine more, but still need to match for different UIs, Terry haven’t forgot that work, give him more time :wink:

Thanks for understanding.

FAN never stops in sleep mode (on VIM2)

What’s the version of your system? Do you can build your ROM with android source code?


Vim Nougat V171028. Can not. Sorry but I am a newbie


You can try again with above steps. Maybe the file data was missed when you push the file to your VIM device.
Also you can provide the android printing log for me. Thanks

# adb shell logcat > logcat.log


hello, i tryed 2 or 3 times, the same, please watch my logcat


Did you push the file TvSettings.odex to your VIM device?
You can check the shasum for that file.

# adb shell
# shasum /system/priv-app/TvSettings/TvSettings.apk
aee058a4d8539936d07760dae69f8f02c606001a  /system/priv-app/TvSettings/TvSettings.apk
# shasum /system/priv-app/TvSettings/oat/arm64/TvSettings.odex
8ad7fbe157fa3425443a244650db3465c69d3aac system/priv-app/TvSettings/oat/arm64/TvSettings.odex


Hello. I checked . Checksum the same. But shasum command work only like “sha1sum /system/…”


Hi Terry.
Do you have another version TvSettings.apk ? Thats not work. :frowning_face:


Or maybe you can make new ROM with working settings?


Hello Terry!
If you connect any monitor to Khadas via HDMI-VGA converter( I try 2 models, UGREEN and noname) in list of resolutions have only 1080p-60hz and 720p-60hz. How to solve this problem? How to can select others resolutions?

Car Installation

Hi, Gouwa.
How long to wait?


Hi Terry, what news?


if you have another HDMI in your tv try it, I change to another one, and it is feet the screen.


It has been more than 3 months, but the top product of khadas remains without full functionality. This is a big disappointment for users who changed the VIM1 to VIM2.


I am not satisfied with vim support for now, there are still bugs in Android, Linux is missing proper driver support, but things have improved, they are now much better than before.

If i have known all of this when i bought it, i wouldn’t have bought this board, but i am really hoping for proper Linux support with all the drivers needed, but i am afraid that we will need to wait a long time for it to come, if it ever comes.

I know it’s not only their fault, a lot of job is needed from Amlogic and Arm too, problem is that these two companies only support Android, there is no Linux support from them.

I am now using Android Nougat latest image, Nougat images before had a serious bug with systemui stopping, for the first time i can use this board to watch movies and other stuff, it was impossible to use it with previous images.


The VIM2 Vesa resolution patch is the same with VIM. In addition, you need to modify the kernel driver

--- a/drivers/amlogic/display/osd/osd_fb.c
+++ b/drivers/amlogic/display/osd/osd_fb.c
@@ -2581,12 +2581,10 @@ static int osd_probe(struct platform_device *pdev)
                        if (ret)
                                osd_log_info("not found display_size_default\n");
                        else {
-                               fb_def_var[index].xres = var_screeninfo[0];
-                               fb_def_var[index].yres = var_screeninfo[1];
-                               fb_def_var[index].xres_virtual =
-                                       var_screeninfo[2];
-                               fb_def_var[index].yres_virtual =
-                                       var_screeninfo[3];
+                               fb_def_var[index].xres = vinfo->width;
+                               fb_def_var[index].yres = vinfo->height;
+                               fb_def_var[index].xres_virtual = vinfo->width;
+                               fb_def_var[index].yres_virtual = vinfo->height*3;
                                fb_def_var[index].bits_per_pixel =
                                osd_log_info("init fbdev bpp is:%d\n",

Have a try. Thanks.


Yes, I applied аll VESA patches. But if you do not disable the UI interface scaling, the image begins to twitch strongly.

— a/services/systemcontrol/DisplayMode.cpp
+++ b/services/systemcontrol/DisplayMode.cpp
@@ -1176,9 +1176,6 @@ void DisplayMode::setAutoSwitchFrameRate(int state) {

void DisplayMode::updateDefaultUI() {
— char outputmode[MODE_LEN] = {0};
— getBootEnv(UBOOTENV_OUTPUTMODE, outputmode);
— strcpy(mDefaultUI, outputmode);
if (!strncmp(mDefaultUI, “720”, 3)) {
mDisplayWidth= FULL_WIDTH_720;

Thank you, today I will try to apply new fix.