Having trouble in using Teams app in VIM3

hi @xiong.zhang, yes we have installed Microsoft outlook and teams from playstore

Hello, have you tried our official vim3 firmware? The following is a screenshot of our official website firmware after downloading and installing Teams and Outlook. It shows that there is no problem and can be used. Also, do you have any information prompts during the download process using Google Play? Or is it just that what you said happened when you downloaded and installed it?

Hi, while downloading Microsoft teams and office outlook these problems are not coming but when we are opening them with our company account email this scenario is happening.

Company portal app (which is required for teams and outlook to open business accounts) which will get overlay automatically when opening this apps is showing above images, but they are working fine for personal mails. one thing it is showing is device is not healthy and when we press continue it is saying this app cannot be used as you are using a rooted device, but I did user build and made changes as you mentioned before to remove root permissions still it is coming.

sorry for giving this long answer but I want you to know what procedure followed by us, which will help you to find if you did any mistake in it. We followed below procedure to build for our vim3 board withs aosp9 and gapps.

  1. we did repo syn from this link GitHub - khadas/android_manifest: AOSP for Khadas VIMs & Edge

  2. we added GAPPS patch to the source code from this link GitHub - terry2droid/google

  3. we then builded vim3 for lunch options like kvim3 user debug and kvim3 user both for two separate vim3 boards

Note: In our build image for first five minutes when we login to playstore, google play will make google playstore to crash often that but after 5 minutes it will automatically adjust itself after updating something by itself and works fine later

Hello, I would like to share a few questions with you. First, are you using 32-bit or 64-bit code? Second, you can post the git log in your ./repo/manifests directory to me. , Third, you said that you use the company account to appear, and your own account will not. Is it a problem with Outlook or Teams software? Are they applicable to Android, because there should be no problem with downloading through Play


  1. 64 bit
  2. git log i have sent message for you
  3. Its downloading from playstore, no issue with that but when signing in teams and Microsoft outlook apps with company official outlook mail id it is not allowing by stating device is unhealthy and rooted device, but it is allowing for personal mail outlook mail id, but our requirement is able to attend teams meeting through it so company mail id should be used (not only ours but standard office outlook mail id’s should work, where IT admins will not allow rooted devices to the network).

Hello, because my company does not have the company account you mentioned, there is no way to reproduce the problem you encountered here, but you can try my suggestion to you, and you have other Android systems that can be used Boards, such as our company’s vim1s or vim4, edge2, or other Android-based devices or mobile phones are fine. Is it the same for Outlook on these devices? you can verify
And you have been using the firmware compiled by yourself, have you tried the firmware on our official website?
I still think that if there is no problem with this personal account, the problem still lies with the company account if you cannot use your company account.

The following is also the account number with the company name applied by my company

ok i will try to flash your firmware and check same problem is recreating there also… can you share the link where I can download ready to install images of android 9 with playstore inbuilt for vim3pro

1 Like

Hi @xiong.zhang ,I have downloaded and flashed V230719 ROM release image of Android 9-64 bit on my Vim3 device. However, when I use the adb command and fond that ‘su’ is working, it indicates that the device is rooted(correct me If I am wrong). I wish to have an unrooted device, can you please provide available ROM images for having an unrooted device with playstore support.

Hello, then if you use this firmware with root, will the same problem still occur?

hi, yes this firmware V230719 ROM with root permissions then same problem, I am getting. will there be any unrooted ROM firmware versions available, if there I will check with them

Then you try this 220719, this is the firmware without root function


ok I will try and let you know the results

Hi, flashed this build but this is also having root access(su command is working), I came to know from terminal

Precision-5540:~/Downloads$ lsusb | grep Amlogic
Bus 001 Device 015: ID 1b8e:c003 Amlogic, Inc.

Precision-5540:~/Downloads$ burn-tool -v aml -b VIM3 -i vim3_android9_64bit_v220719.img
Try to burn Amlogic image…
Burning image ‘vim3_android9_64bit_v220719.img’ for ‘VIM3/VIM3L’ to eMMC…
Unpacking image [OK]
Initializing ddr …[OK]
Running u-boot …[OK]
Create partitions [OK]
Writing device tree [OK]
Writing bootloader [OK]
Wiping data partition [OK]
Wiping cache partition [OK]
Writing boot partition [OK]
Writing dtbo partition [OK]
Writing logo partition [OK]
Writing odm partition [OK]
Writing product partition [OK]
Writing recovery partition [OK]
Writing system partition [OK]
Writing vbmeta partition [OK]
Writing vendor partition [OK]
Do you want to reset the board? y/n [n]? y
Resetting board [OK]
Time elapsed: 5 minute(s).
Tue Aug 29 14:43:25 IST 2023
Precision-5540:~/Downloads$ adb connect xx.xxx.xx.xx
connected to xx.xxx.xx.xx:5555

Precision-5540:~/Downloads$ adb shell
kvim3:/ $ su
kvim3:/ #

however I checked installing app, same issue is coming

anything can we try further to solve this ?

Hi @xiong.zhang,
I found one official documentation of microsoft saying this

“Use the Intune Company Portal app to remotely check the status of an enrolled device, and confirm or resolve access issues caused by noncompliant settings. During a status check, Company Portal checks your device to make sure it meets your organization’s requirements. If your device doesn’t meet requirements, your organization may limit or restrict the device from accessing work resources until you make changes.”

and in xda forums I found about unrooting this procedure

"The problem is that fully un-rooting via the SuperSU app does nothing to remove Busybox from your system, which is causing the custom status after the startup scan. This is the only cause for the “custom” status that can be deduced from the problem and the results after going through the steps that follow.

1.Navigate to a folder called “/system/xbin”
2. Delete ONLY files in that folder with the word “busybox” within its filename or symlink path. "

After flashing my custom aosp user build (after remitting git changes you previously suggested) now my build does not have “su” access but still company portal thinking it as a rooted device, as mentioned above I am thinking due to the traces of busybox it is thinking like that.

I found one busybox file under vendor/xbin/busybox on vim3 file manager, but I am not able to delete or rename it manually or via adb command.

I found xbin in our aosp source code under this path vendor/amlogic/common/external/busybox here it is a directory, just by making build_with_gapps_config=false to not include gapps in the build is there any code change we can do to exclude this busybox.

@Terry ,@Electr1, @superceleron do you guys have any suggestions on this issue.

what should I do? or should I give up on this topic ?

In the following code related to busybox, you can remove it and try to compile the firmware. You can find software on the Internet that can detect whether the device is rooted.

/device/khadas/common/products/tv/product_tv.mk:62:    busybox \
/device/khadas/kvim3/device.mk:70:    device/khadas/common/recovery/busybox:recovery/root/sbin/busybox \
1 Like

Hi @xiong.zhang ,

Thanks for your previous reply, unfortunately after doing these code change, doing clean build, but still in out folder under vendor/xbin/ I saw busybox file.

You can try this for Teams

1 Like

Thanks for your reply, this solution is suggesting magisk app(I downloaded it but not understanding how to do further process) , also we want to remove root status from build itself, when we gone for user build there is no root signature and in the link you shared it suggests an app called YASNAC - Yet Another SafetyNet Attestation Checker, to check whether it passes safety net, my user build is passing both.

Only thing I am not able to check is to remove busybox from the source build then check whether intune company portal this time detecting device as unrooted or rooted. Thanks for your response, if you have any other suggestions it will be helpful

For my user build of aosp9 for kvim3, su binaries are not there. when I ran a root check application, I found that testkeys is the one exposing the build as custom or modified firmware to intune company portal app.


any one have any idea how to overcome this, chatgpt is giving these suggestions If your AOSP build is using “test-keys” and you want to create a custom firmware that doesn’t trigger the detection of custom firmware by security apps like the Intune Company Portal and doesn’t get flagged as rooted, you should consider the following steps:

1. Change Keys: The “test-keys” are typically associated with development and testing builds. To create a custom firmware that doesn’t use test keys, you should generate your own set of keys for signing the firmware. This involves creating new keys and modifying your build configuration to use them instead of the default test keys.a. Generate new keys using a tool like genkey or openssl. You can find detailed instructions in the Android documentation on how to generate signing keys.b. Update the build configuration (typically found in the build/target/product/security/ directory) to use your new keys for signing the firmware instead of the test keys. Replace the test key references with your new key references.c. Rebuild your AOSP firmware with the updated keys.
2. Set Release Build Type: Ensure that your AOSP build is set to a “release” build type. Release builds typically disable debugging features and may have optimizations for performance and security. This can help prevent the firmware from being detected as a development or test build.In your build configuration (e.g., BoardConfig.mk), set TARGET_USER_BUILD_TYPE to “release” instead of “userdebug” or “eng.”

what I should do ?