GPU and hardware video support

If I use without LIMA then no HWdecoding and graphic drivers so Desktop environment is useless without it.

I will try to use without LIMA and install the kernel over it. And also try different user space drivers to see if any matches.

Thanks anyways. If you get any lead on how to make the graphics work on it then please do guide me on that as without graphic drivers DE are not usable as they lag alot when any browser or video is opened.

I was able to boot with the kernel where I have added Lima. I have Mesa 19, but when I do glxinfo | greo OpenGL there is no mention of LIMA.
As per the upstream report, LIMA was onlt accepted in Linux Kernel 5.2 and in Mesa 19.1.

So maybe we need to wait? or is there any way to add it to 5.0.2 ?

Any support or guidance from Khadas team ?

You’re wrong. HW is only needed for full screen video playback. This is not required for a normal desktop system. Everything works at the right speed. If this is not the case in your manjaro image with LXQT, you need to understand the settings and packages in ArchLinux (why they are poorly optimized for ARM). There is no such problem on Armbian. Without HW desktop VIM1 works with normal speed.

1 Like

Interesting article

I tried it too. There is no HW Support, DE works fine until someone loads a youtube video or a Movie, The video is playable not watchable as CPU is used at 90% and above. I tried loading Libre Word and it takes 50% above CPU for using the Libre as the htop clearly mentioned the CPU load is for libre video rendering, similar case for Firefox with youtube on. When the videos are played in full screen then I can see the frame changing, that means the framebuffer is also a concern.

If you say that armbian works fine then I will do some more digging with armbian and get back to you with more details.

The reason I mentioned this is the for DE to work smoothly we need GPU HW support, As DE is used for mostly GUI based applications which utilizes quite good amount of GPU.

I will do some more thorough test for you and take screenshot with the CPU load and its details.

Another confusion is the manjaro team who tested manjaro LXQT on oc2 said the youtube works fine on firefox with minimum cpu load as the graphic is processed by the GPU but heavy load on RAM, I wonder how did they make the GPU work on oc2?

This was my reference to know that Lima will be added upstream in linux 5.2 and mesa 19.1

Tried to install kodi and run it but it crashed due to display issue.
Crash Log Here

Finally I was able to Install lima drivers in Manjaro KDE using the libgl7-aml but it have bad fb rate.

my results for dmesg | grep lima shows me the lima drivers. Screenshot below.

Also When I am running glxgears I get 200fps on 2D.

Somehow able to install kodi but error on loading it.
Error on loading Kodi

  kodi.bin error while loading shared libraries cannot open shared object 
  files: no such file or directory 

Any suggestion ?

1 Like

compile the missing dependency?

I didnt try it. Will try it tonight, but can. You advice which one i have to compile.?

These are for Kernel 5.0 But not sure whether it is device specific or not.

@chewitt Any advice on this ?

it was wrong permission on rules.d conf I changed it to 755 and now it is showing
Unable to Create GUI. Exiting.

Will go through the Log and update it here.

Kodi Crash Log: Link
Here the concern is not kodi but graphic driver for me. I just need to try and get the graphic work smoothly if not 4k.

Finally found something which I installed wrongly while testing. Had installed fbturbo for sunxi instead of amlogic. So I installed the amlogic one and now video is much smooth but still the frame change can be figured out while watching a video. Lima seems to work for this built, chromium is much lighter than Firefox for watching online videos.
Tested it for long time with multiple display screens.

Next I will make new built with fbturbo of c2 thats the only one available for amlogic s905x, incase if anyone knows them kindly advice with fbturbo to use.

Getting 205+ fps on glxgears with fbturbo-c2.

Kodi issue is still there, will look into this some other time until someone else who have faced such problem can advice.

This looks like you previously built Kodi with libmali so the wrong EGL libs are being used:

1. Thread 5 (Thread 0xffff81ffae50 (LWP 10545)):
2. #0  0x0000ffff97b347f0 in pthread_cond_wait@@GLIBC_2.17 () from /usr/lib/
3. #1  0x0000ffff96b47c98 in _mali_osu_lock_wait () from /usr/lib/mali-egl/
4. #2  0x0000ffff96b44ca0 in ?? () from /usr/lib/mali-egl/
5. #3  0x0000ffffe7d39190 in ?? ()
6. Backtrace stopped: previous frame identical to this frame (corrupt stack?)

I’d also recommend you build mesa master to pick up the latest lima changes.

So you mean, I have to update kodi as well as mesa?

I checked Mesa was built 4 days ago with 19.0.3-1 and kodi 5 days ago with 17.6-6

If you built Kodi against libmali before switching to lima you probably have a polluted toolchain and Kodi is being linked against mali EGL libs not the equivalent ones from mesa, and (surprise) Kodi is not able to open the mesa EGL context correctly.

Well the libmali was enabled in my kernel built and it was from the beginning.

The kodi i used was built by archlinuxarm team that’s the one I used and I assume it is for odroid c2.

Now what do you suggest me to do in this case?
Do I have to build kodi with with lima enabled?

Please guide me how to get kodi to link with lima? And how to get it working. This is just for test and developement purpose only. I m not going to use kodi for myself. I am just trying to figure out ways to make stable manjaro built’s for khadas vim.

I tried compiling kodi from the same pkgbuild by archlinuxarm kodi-c2 on my device with lima enabled and still I am getting the same error. :frowning:

As recommended, I tried the latest builds and still the same issue.
I am trying to figure out this… I had the exact same issue even after I used Linux 5.2.1 with latest Lima and mesa. Still getting the exact same error.

Any recommendation on how I can get a working kodi for Kvim1 with Manjaro Arch ?

Any advice on how to get a smooth framebuffer?
Framebuffer driver Link
Kodi Link

My situation is I built a manjaro for khadas vim1 using manjaro-arm-installer and using balbes modified kernel source code with lima enabled.

But I think the framebuffer is little slow as compared to the librelec built.

I am going to dig into the balbes libreelec built and try to find out which framebuffer driver was used.

I would need your advice on how I can get a stable framebuffer for arch…

2 posts were split to a new topic: Linux support for both NPU and GPU

I can try to install lima driver but dont work :frowning:

Hello And welcome to the forum.

How did you install lima?
It is part of mesa package. You will need 01-lima.conf in /etc/X11/xorg.d/ directory
This should be the content of the file.

1 Like