Final release of OpenWrt 19.07.8 for Khadas SBC VIM1 VIM2 VIM3 VIM3L Edge

ok, thanks !now how to make this owenwrt connect to my wifi access point and access the internet ?

ethernet dhcp works by default!!!

wifi dhcp client mode !!! need user configuration;)

i have test AP mode only!!!
client mode not tested !!!

ok, so I should no try wifi client mode for now, but connect an ethernet wire to get internet access; I’ll do that tomorrow, time to go to bed now, thanks for your support!

TNX ! for Krescue testing !

autodetection board name - FIXED!

Ubuntu 18.04.3 LTS Khadas ttyS0

Khadas login: khadas
Password: 
Last login: Tue Sep 17 13:40:36 CST 2019 on ttyS0

Welcome to Fenix 0.7 Ubuntu 18.04.3 LTS Linux 4.9.190  
 _  ___               _            __     _____ __  __ _ 
| |/ / |__   __ _  __| | __ _ ___  \ \   / /_ _|  \/  / |
| ' /| '_ \ / _` |/ _` |/ _` / __|  \ \ / / | || |\/| | |
| . \| | | | (_| | (_| | (_| \__ \   \ V /  | || |  | | |
|_|\_\_| |_|\__,_|\__,_|\__,_|___/    \_/  |___|_|  |_|_|
                                                         

 * Website:        https://www.khadas.com
 * Documentation:  https://docs.khadas.com
 * Forum:          https://forum.khadas.com

To run a command as administrator (user "root"), use "sudo <command>".
See "man sudo_root" for details.

khadas@Khadas:~$ curl -sfL dl.khadas.com/.mega | sh -s - -i
[i] DEVICE INFO
[i] BOARD NAME: VIM1
[i] eMMC      : /dev/mmcblk0


1 Like

hi there !
i connected the vim1 booting openWRT from emmc over ethernet to my network;
I’ve put some password for root account, now it refuses my ssh request from my laptop,
what to check in order to fix that ?

don’t move, I’ve found one solution from https://gist.github.com/lynus/3446706#file-wan_ssh-L13

just add the following lines in /etc/config/firewall :

config rule
        option src              wan
        option dest_port        22
        option target           ACCEPT
        option proto            tcp 

and reboot, voilà !
now i can ssh into my VIM1 from my laptop, next step woull be to setup VIM1 as wifi client…

@hyphop
can you please tell if you’ve included usb audio support in your kernel ?
i’ve installed a few alsa related pakage, but I still cannot get my many usb sound cards recognized as sound device (only as HID which is meaningless)
tks

opkg update
opkg install alsa-utils opus-tools
1 Like

ok, alsa-utils and opus-tools (?) installed,
but same soundcard detected by ubuntu 18 (X86) in dmesg as…
[ 9116.535393] usb 3-2: new full-speed USB device number 8 using ohci-pci
[ 9116.783761] usb 3-2: New USB device found, idVendor=21b4, idProduct=0083, bcdDevice= 1.07
[ 9116.783768] usb 3-2: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[ 9116.783773] usb 3-2: Product: AudioQuest DragonFly Black v1.5
[ 9116.783777] usb 3-2: Manufacturer: AudioQuest
[ 9116.783782] usb 3-2: SerialNumber: AQDFBL0100103705
[ 9121.950711] hid-generic 0003:21B4:0083.0002: hiddev0,hidraw0: USB HID v1.11 Device [AudioQuest AudioQuest DragonFly Black v1.5] on usb-0000:00:04.0-2/input2
[ 9122.838807] usbcore: registered new interface driver snd-usb-audio

is not detected on openwrt probably because the kernel do not have the module snd_usb_audio (which is on my X86 ubuntu 18),
please check if you compiled your kernel with this option or not

is not detected on openwrt probably because the kernel do not have the module snd_usb_audio

all modules in openwrt loaded by manually ( not like ubuntu )!!!

modprobe snd-usb-audio

add permament module load

echo snd-usb-audio > /etc/modules.d/66_audio_usb
opkg update
opkg install alsa-utils opus-tools
curl -sL ai-radio.org/opus.128 | opusdec - - | aplay -fdat
1 Like

PS: > AudioQuest DragonFly !!! very nice sound card ! i have same its must works fine !!!

i dont have any problem with audio ! :wink:

i followed you rinstructions,

and now I’m hearing good sound in my meze99C headphones connected to the dragonFly DAC under openWrt1907 :love_you_gesture::star_struck:

1 Like

looks like somebody like a good sound :wink:

yeah, tks !!
mpg123 -@ http://ai-radio.org/44.flac
works well here on the VIM1 :robot:

Once i install openWRT using Krescue all from the emmc,
i get …
root@openwrt-vim:~# df -h
Filesystem Size Used Available Use% Mounted on
/dev/root 27.0M 27.0M 0 100% /rom
devtmpfs 795.2M 0 795.2M 0% /rom/dev
tmpfs 923.4M 1.1M 922.3M 0% /tmp
/dev/loop0 871.4M 148.7M 722.7M 17% /overlay
overlayfs:/overlay 871.4M 148.7M 722.7M 17% /
tmpfs 512.0K 0 512.0K 0% /dev
/dev/mmcblk1p1 99.8M 10.5M 89.3M 11% /boot

where are all the 16MB mmc space gone ?
i’d like to use the remaining available space on the emmc for my storage needs

by default we dont use whole emmc space ! we can make another partition and mount it for free usage !

BUT if u need use all free emmc space for root overlay

sfdisk /dev/mmcblk1 --delete 2
echo "573440, " | sfdisk -f  /dev/mmcblk1 -a
dd if=/dev/zero bs=1M of=/dev/loop0 count=1
reboot 

NOTE: all overlay data reset to default !

my example !!!

root@openwrt-vim:/# df -h
Filesystem                Size      Used Available Use% Mounted on
/dev/root                27.0M     27.0M         0 100% /rom
devtmpfs                  1.3G         0      1.3G   0% /rom/dev
tmpfs                     1.4G    244.0K      1.4G   0% /tmp
/dev/loop0               57.9G      1.3G     56.6G   2% /overlay
overlayfs:/overlay       57.9G      1.3G     56.6G   2% /
tmpfs                   512.0K         0    512.0K   0% /dev
/dev/mmcblk1p1           99.8M     10.5M     89.3M  11% /boot
3 Likes

ok,
in your example, i understand that you use sfdisk to resize /dev/mmcblk1 to 57G;
or maybe you make the partition start from location 573440 up to the end of the emmc ?

:wink:

our openwrt default partitions

root@openwrt-vim:/# sfdisk --dump /dev/mmcblk1
label: dos
label-id: 0x42fc31d5
device: /dev/mmcblk1
unit: sectors

/dev/mmcblk1p1 : start=      368640, size=      204800, type=e
/dev/mmcblk1p2 : start=      573440, size=     1843200, type=83

your command totaly wrong :wink:

  1. this option -@ for play list
  2. mpg123 play mpeg streams

correct commands

mpg123 http://ai-radio.org/mp3 - play mp3 stream
ogg123 http://ai-radio.org/320.ogg - play ogg 320kbit stream
mpc clear && mpc add http://ai-radio.org/flac && mpc play - play lossless flac stream

1 Like

as i do not need to use the vim1 as a router but as a headless server for hosting my experimental (audio) services instead of using ubuntu, i do not need the wifi access point function but need the vim1 to bevin wifi client mide and connect to my existing access point.
can someone please help me to make wifi client work ?
tks