Fail upgrading via USB-C cable

Hello to all,

after using my Khadas Vim 1.2 Pro with preinstalled Android 6 OS I wanted to change the OS to Ubuntu.
So I downloaded the USB Upgrade Tool plus the latest Ubuntu Mate Image File from the following links:

Then I tried to perform the steps written in Your tutorial on a Windows 7 PC.
However, instead of burning the image the Burning Tool always issued some kind of “parse image fail / error”.

So I tried with the following (older) image file:

Still got the same kind of “parse image fail / error”.

After that, I decided to try upgrading via USB-C cable on a Linux PC (Ubuntu 16.04), once again following the instructions given in Your tutorial step by step.
Again everything seemed to do well at the beginning, but when the process reached the point of image extraction it stopped issuing some kind of “extract image [KO]” error message in red letters.
As I had done on the Windows PC I tried with both the most recent Ubuntu Mate Image and later the February version of Ubuntu Mate Image.
In both cases I got the same “extract image [KO]” error message.


Thought EMMC would stand for External Multi Media Card and I would have to use image files tagged “USB”, but instead EMMC stands for Embedded Multi Media Controller and I have to use one of the image files tagged “EMMC”
for installing Linux on my VIM 1.2 Pro via USB cable.

Quite confusing for beginners…


Hi dormilon,

Glad to see you solve the problem yourself.:wink:

Thanks for your feedback. We will add some documentation for new beginners to get started.