Ethernet and Wifi simulaneously


I am in a situation where I need to access some pages on ethernet (192.168.1.x) and the internet over wifi.

Now android deactivates wifi once ethernet is connected.
I tried to fix this as described in, but the relevant .dex file is not contained.

Can you please help me to be able to activate both ethernet and wifi simultaneously?

Thanks in advance.

I really need your help here…
I have looked through the android source but I cannot find the relevant file…

Hello @terry @goenjoy @jasonl

Please help on this.

Why did you add support for it? The official Android didn’t support this, and we haven’t the plan to do it.


I think it is a good idea to support it, in order not to miss out on certain usecases the vim3 is perfect for!
E.g. Enabling simultaneous wifi and ethernet, people can use their vim3 on portable things, like a car as in my project.

Also I think it should be easy for people so experienced and with advanced knowledge just as you are.

Thanks in advance for your consideration.

This is also something I could really use. I have a system on a motorcycle where I have a network video recorder that I would like to access on the ETH and I still need the wifi on for a variety of AP’s I will access as the system moves around.

WiFi Hotspot works, but I guess that won’t do in these use cases.

I have been busy downloading the android source and have found the file
which I made my changes (see at the bottom) in.

Now I tried building according to the instructions in docs.

I’ll report when finished…

My changes in the file (untested as of now)
2420 comment
2421 comment
2422 comment
5307 comment
5308 comment
5330 comment
5404 comment
5485 comment
5482 comment

1 Like

Ok, the good news is, I finally could compile it.
The bad news, it only works as intended for a few seconds…

Can someone of the experts from khadas please look which lines have to be changed, so that the wifi can coexist simultaneously to the ethernet?

Thanks a lot in advance.

1 Like

Yes please! I could really use multihoming networking with android for my project!

Hello @Terry @goenjoy

Please help to resolve this issue.


I have tried again and it seems to me there must be another place outside ConnetivityService to look for.
I changed everyging that seems relevant but still shuts down my wifi once ethernet got a connection


please support me on this. I have been hours through ConnectivityService and other related files and tried a lot but just can’t make it work…

1 Like


I think I know why my tries failed…
Although I have copied the services.jar to /system/framework they seem not to be loaded, because the debugging messages I changed are still the ones before my change.

Do I need to reload the jars somehow?

I am still monitoring this thread as I really hope you work this out!!