Errors running NPU demos on latest ubuntu 20 VIM3 image?

I have hard time running NPU demos on VIM3.
Which Ubuntu version to use?

I followed official docs and checked “NPU Demo and source code” post.

Many of the links point to 2019 firmware (I started with it but had problems)

Emmc flashed VIM3_Ubuntu-gnome-focal_Linux-4.9_arm64_EMMC_V0.9-20200530.img from the official repo.
First I tried to use prebuilt binaries with demos - or to build myself.
Using latest 6.4.3 for SDK
2 Problems with inceptionv3

  1. I am getting error about missing There is /lib/ - I tried to copy as so.1.2. Getting “segmentation error”.
    I see lsmod galcore (not sure what it is?) - but that means I have NPU…
  2. I got similar errors with demo_detect_picture v3
  3. I built from source some of the demos - also run time errors.

apt upgrade was as disaster - I had to reflash the image.

Please, confirm if you have recent success with newer builds.
Should I go back to 2019? or build ubuntu with fenix?

uname -amr
Linux Khadas 4.9.224 #29 SMP PREEMPT Sat May 30 14:20:51 CST 2020 aarch64 aarch64 aarch64 GNU/Linux

Serial : 290b1000010d06000009353847475250
Hardware : Khadas VIM3

I like the VIM3 board - but NPU seems very rough…

@ivostoy After you burned the VIM3_Ubuntu-gnome-focal_Linux-4.9_arm64_EMMC_V0.9-20200530.img, you need to upgrade the lastest firmwware .

$ sudo apt update
$ sudo apt upgrade 
$ sudo do-fenix-upgrade

Then, reboot you system, check the NPU version

$ sudo dmesg | grep "Gal"

It should be 6.4.3


Yes, demos work now.
I think I did the update sequence - maybe havemissed something.
Thank you, Frank