Encountering a few Issues with Ubuntu

#1

I’m Encountering a few Issues with Ubuntu
Mostly Bluetooth Related
I’m sharing the video of this experience here:


It never did detect the Bluetooth Keyboard.
What you can’t see in the video is that the audio on the Bluetooth earbuds cuts in and out and isn’t consistent, I can only hear 2 or 3 seconds of a song at a time.
1 Like

#2

Hi Ryan:
@numbqq and @Frank are processing this issue now, should can resolve it quite soon.

Thanks for feedback!

2 Likes

#3

Hello @CyberManifest

Can you please check with the bluetooth?

VIM2_Ubuntu-xfce-bionic_Linux-4.9_arm64_EMMC_V20190411

Thanks.

1 Like

#4

@numbqq
That seemed to do the trick, had to still wrestle with it a bit, and there’s still issue with the settings window not opening until a reboot, but all devices (including keyboard) were able to connect, and audio on bluetooth earbuds is smooth now. Thank You :slight_smile:
Can You please implement these fixes in the One-Stop Script https://github.com/khadas/fenix
Thank You again.

0 Likes

#5

I will push the modifications to GitHub today.

1 Like

#6

Encountering a few more issues. @numbqq
inxi is giving me errors…
I downloaded latest updates with: sudo apt update && sudo apt upgrade && sudo apt full-upgrade && sudo apt dist-upgrade
I install inxi: sudo apt install inxi
because of errors with weather
I modify inxi configuration file: sudo nano /etc/inxi.conf
I change “false” to “true”
then I update to latest inxi with: sudo inxi -U
I try issuing: inxi -Fxxxpwrz
I get errors:

Error 45: Error opening file: /home/rkm/.local/share/inxi/location-main.txt
Error: Permission denied
print() on closed filehandle $fh at /usr/bin/inxi line 3591.
Error 45: Error opening file: /home/rkm/.local/share/inxi/weather-35.1663-101.8868-100.txt
Error: Permission denied
print() on closed filehandle $fh at /usr/bin/inxi line 3591.

I go to check permissions but the folder is empty:
Folder is empty ?
╭─rkm@Khadas ~/.local/share/inxi
╰─➤ ls -la
total 8
drwxr-xr-x 2 root root 4096 Apr 11 23:29 .
drwxr-xr-x 6 rkm rkm 4096 Apr 12 02:17 …
╭─rkm@Khadas ~/.local/share/inxi
╰─➤
Screenshot_2019-04-12_02-46-41

Please reference:

0 Likes

#7

Hi @CyberManifest, This is a Permission problem with you shell. I try to install inxi with bash shell in my VIM2,and no problems arose.You can install it with bash shell.

0 Likes

#8

Hi @Frank, nope, I’m encountering it in bash too… see screenshot…


Also, this would not address the empty folder at ~/.local/share/inxi that says there are 8 files but shows none.

Screenshot_2019-04-12_08-16-22

Update: Got a little help from ##linux over on freenode on IRC
[08:46:10] CyberManifest: try this “sudo rm -rf /home/rkm/.local/share/inxi” and rerun inxi
That returned the results: http://dpaste.com/27YGGV4
@Frank So See IT WAS NOT THE SHELL
While this seems to fix inxi… there are still problems with file count in directories…
Screenshot_2019-04-12_08-58-49

UPDATE: I’ve been made aware this is not file count, but instead, block size.
Also worth noting, I had forgotten to implement fix for sudo issue reported before. Hopefully this all comes out in the wash.

0 Likes

#9

@numbqq
I’m able to connect my bluetooth devices with the push, but I have no audio in my bluetooth earbuds, no matter what I do
I can get audio in earbuds in official Ubuntu images, but not in Debian built images.
So Bluetooth is able to connect my mouse, and keyboard, and can even connect the Pixel Buds, but I can’t get audio out of them like I can in Ubuntu.

What’s different about Debian than Ubuntu? Why can’t I get audio in either one?

0 Likes

#10

I haven’t checked on debian yet.

Hello @Frank,

Try to build debian image and check with this issue.

1 Like

#11

Hi @CyberManifest,I will check it with Debian today.

1 Like

#12

Hi @CyberManifest ,We have solved this problem.You can execute this command sudo rm -rf /etc/firmware and reboot,then you can use Bluetooth speakers.

1 Like

#13

Hi @Frank, Awesome! Thanks, I’ll give it a try tomorrow; it’s late here. But I’m glad it was sorted out. So it was a misconfigured firmware or the wrong one or something? Also, I hate to be a bother, but, I’ve also noticed my “Pictures”, “Music”, “Videos”, etc. Folders aren’t present in my home folder upon fresh install like they are in Ubuntu. Why would they be missing? Can you fix this as well?

0 Likes

#14

Hi @CyberManifest,about folders,only the desktop is preset. You can use mkdir to build which you need.This is not different from the preset one.

0 Likes

#15

Hi @Frank. Yeah, I’ve done that, but then the folders are missing their artwork under a file manager like Thunar; they’re missing the embrossed emblems to indicate what type of folder they are. Perhaps if I reinstalled the XFCE components this would be corrected? Cause AFAIK XFCE has always set them up automagicly in every other distro. I just thought perhaps there was a glitch in your setup script or build script, or perhaps it was intentional, and had been surpressed purposefully? At this point, I really can only guess why Debian on the Khadas acts and behaves differently, than Debian on virtually all other platforms I’ve ever ran Debian on. On the Raspberry Pi with Raspbian (A form of Debian), the folders and art are present. On the nanopi m4 with Armbian (another form of Debian), the folders and art are present. Even after starting blank, with a minimal skeletal core (Think Net Install), when I install XFCE manually and fresh, the folders are always present and in place, on these other platforms.

0 Likes

#16

Hi Guys:
To make the topics readable, would be better to create a new topic for different issue or questions.

Good day!

0 Likes

#17

Hi @Frank, I just tried this, and it did not resolve the issue. I’m still not getting audio in Pixel buds. Also after first attempt the audio mixer doesn’t even see the Pixel buds even though they are shown paired in Bluetooth Devices window. On the first attempt, I tried testing by launching Pithos, the play button was depressed but there was no audio and the play progression bar was frozen in place, similar to pause but without pause active. Eventually it fell back to the HDMI audio and resumed playing. Then the Pixel Buds disappeared from the mixer altogether, but still showing in Bluetooth devices. So I’m still having issues with Bluetooth and audio over Bluetooth.

0 Likes

#18

Hi @CyberManifest, These are my test steps, you can refer to them.

1.Execute this command sudo rm -rf /etc/firmware
2.Execute this command sudo reboot

Now,IStart Connecting Bluetooth.

3.Open the Bluebooth Manager.
4.Select the Bluetooth headset.

This is my choice.


note : if you If you have ever connected, I suggest you delete the device and search again.

5.Open the volue control

6.Modify audio output to your Bluetooth device.


note : Because I use online music,So it’s chromium.

7.Choosing the Output Mode of Bluetooth Device.(A2DP Sink)

Now,music is playing normally.

Please check Which step is different for us?Thanks.

1 Like

#19

Hello, @Frank
Still having problems, see last images and video at the end.
Notice the music wasn’t paused but stops and occasionally resumes, also, the Bluetooth device disappears from volume control but is still in Bluetooth Manager…

Video: https://youtu.be/SamZ3-tYBMA

0 Likes

#20

Hi @CyberManifest , I check it again just now.


Please check this.And I tried different Bluetooth headsets, which can be played.Then I used the system’s own music player and online music.It’s works well.Can you try to test with online music or another Bluebooth headsets?

0 Likes