[Edge-V] [HDMI] Issue : Failed to get EDID Information

Hello Khadas Team,

We are facing one issue related to HDMI display or EDID most probably.
After seeing the kernel logs, we have found following problematic logs:

[ 23.080674] dwhdmi-rockchip ff940000.hdmi: failed to get edid
[ 23.081516] rockchip-vop ff900000.vop: [drm:vop_crtc_enable] Update mode to 720x576p50, type: 11
[ 31.510264] rockchip-vop ff900000.vop: [drm:vop_crtc_enable] Update mode to 1024x768p60, type: 11

How to reproduced Issue:

  1. Boot the Box without HDMI cable plugged-in.
  2. Let the box boot up properly, wait for 1 minute.
  3. Plugged the HDMI Cable.
  4. See the Behavior, HDMI Display Device

Expected Behavior: Display should be observed on HDMI TV
Actual Behavior: No Display observed on HDMI TV.
Re-Producible Rate: 40-50%, not always observed.

When we start/restart the Kodi Application, Display available on HDMI TV. Following are the logs:
[ 203.084429] rockchip-vop ff900000.vop: [drm:vop_crtc_enable] Update mode to 1360x768p60, type: 11

We need your help/support for resolving this issue.


@amish Maybe you can tell me that which version firmware you used and you borad version ?

@Frank : what do you mean by firmware & board version ?
how we can check this ?

@amish You can see the board version in plank front ,such as Edge-V14 . And then , did you Reburned firmware ? tell me the which firmware you used If you have did it .

We Dont know about firmware version…

Can you plz let us know how we can solve this issue ?

Go to the Settings app or Settings menu, then to About and check the firmware version, build information there.

Version Info:
Build: Kodi 18.4 Git:20191101-nogitfound
Compiled: 2019-11-01

You must exit Kodi and check inside Android’s Settings.
Or are you using LibreELEC OS on a micro-sd card?

i do have terminal only…
let me know how can i find it on Terminal ?
may be using LibreELEC OS on a micro-sd card

Try a newer LibreELEC from a micro-sd card.
LibreELEC is known to still be in beta state for mainline 5.x support so it’s expected that on some tv’s, displays there will be problems.

Try this newer image, write with Etcher to a micro-sd card
Have you tried different HDMI cables and a different tv, display to connect to?

1 Like

Sorry for miscommunication, i am not sure about the “LibreELEC OS on a micro-sd card”.

I do have Image file which i got from Khadas team, i burned it and start working.
Do you know how we get the Version information ?

Regarding HDMI Issue,
We have used best certified HDMI cables, this issue is not 100% reproducible,
can you help me to resolve this issue.


@amish You firmware is ubuntu or android ?

Ohh… you asked for Operating System.
we are using Ubuntu

@amish OK,can you tell me which version ubuntu firmware you used , like this :

Frank, We dont know about what firmware we have installed on our box.
We got this firmware from Khadas team.
can we check on box itself, how we can check the firmware version .

i do have only console access…

@amish If you don’t install so more things in you board . I suggest you try to reburn the lastest version .

I will let you know which Firmware version, we have installed.
we are from Mannan…
I need to check with Nick (Khadas Team).

But i think , HDMI driver remain same …
have you encountered this issue before ?

plz provide your email id…
i will add you in loop also.


I we have installed latest EDGE-V firmware on board , and still face this issue.

  1. How can we enabled HDMI logs ?
  2. What next step according to you to solve this issue ?
  3. printk is also not priting anything.


What logs?

I don’t know what’s your mean.

What do you mean “What Logs” ??
Dont you know about Logs ?
HDMI logs means, Debugging HDMI logs.

Let me re-iterate my statement.

We have tried to burn latest Edge-V image, and found a Issue which is based on HDMI.

Issue 1 : Sometimes, No display observed on HDMI.
Issue 2: Sometimes, Wrong resolution display on HDMI display i.e. 1024x768p60, instead of 1360x768p60.

Now, we need your help to resolve this issue , and require your help.

Can you please help us to resolve this issue ?

Please clear your stand.