EDGE-V bug thread [ANDROID PIE]


Is PIE building successfully? Here it always fails with

        FAILED: TAs 
/bin/bash -c "(make -j4 -C /home/raimo/android-sources/khadas-edge-pie/external/rk_tee_user O=/home/raimo/android-sources/khadas-edge-pie/external/rk_tee_user TA_DEV_KIT_DIR=/home/raimo/android-sources/khadas-edge-pie/external/rk_tee_user/export-user_ta clean ) && (make -j4 -C /home/raimo/android-sources/khadas-edge-pie/external/rk_tee_user CROSS_COMPILE=\$(pwd)/prebuilts/gcc/linux-x86/arm/arm-eabi-4.8/bin/arm-eabi- 	CROSS_COMPILE_HOST=\$(pwd)/prebuilts/gcc/linux-x86/arm/arm-eabi-4.8/bin/arm-eabi- 	CROSS_COMPILE_TA=\$(pwd)/prebuilts/gcc/linux-x86/arm/arm-eabi-4.8/bin/arm-eabi- 	CROSS_COMPILE_user_ta=\$(pwd)/prebuilts/gcc/linux-x86/arm/arm-eabi-4.8/bin/arm-eabi- 	TA_DEV_KIT_DIR=/home/raimo/android-sources/khadas-edge-pie/external/rk_tee_user/export-user_ta 	O=/home/raimo/android-sources/khadas-edge-pie/external/rk_tee_user )"
make: Entering directory '/home/raimo/android-sources/khadas-edge-pie/external/rk_tee_user'
make[1]: Entering directory '/home/raimo/android-sources/khadas-edge-pie/external/rk_tee_user/ta'
make[2]: Entering directory '/home/raimo/android-sources/khadas-edge-pie/external/rk_tee_user/ta/testapp'
  CLEAN   .
make[2]: Leaving directory '/home/raimo/android-sources/khadas-edge-pie/external/rk_tee_user/ta/testapp'
make[2]: Entering directory '/home/raimo/android-sources/khadas-edge-pie/external/rk_tee_user/ta/testapp_storage'
  CLEAN   .
make[2]: Leaving directory '/home/raimo/android-sources/khadas-edge-pie/external/rk_tee_user/ta/testapp_storage'
make[1]: Leaving directory '/home/raimo/android-sources/khadas-edge-pie/external/rk_tee_user/ta'
make: Leaving directory '/home/raimo/android-sources/khadas-edge-pie/external/rk_tee_user'
make: Entering directory '/home/raimo/android-sources/khadas-edge-pie/external/rk_tee_user'
make[1]: Entering directory '/home/raimo/android-sources/khadas-edge-pie/external/rk_tee_user/ta'
make[2]: Entering directory '/home/raimo/android-sources/khadas-edge-pie/external/rk_tee_user/ta/testapp'
  CPP     /home/raimo/android-sources/khadas-edge-pie/external/rk_tee_user/ta/testapp/ta.lds
  /home/raimo/android-sources/khadas-edge-pie/prebuilts/gcc/linux-x86/arm/arm-eabi-4.8/bin/arm-eabi-gcc      /home/raimo/android-sources/khadas-edge-pie/external/rk_tee_user/ta/testapp/testapp_ta.o
  /home/raimo/android-sources/khadas-edge-pie/prebuilts/gcc/linux-x86/arm/arm-eabi-4.8/bin/arm-eabi-gcc      /home/raimo/android-sources/khadas-edge-pie/external/rk_tee_user/ta/testapp/user_ta_header.o
  LD      /home/raimo/android-sources/khadas-edge-pie/external/rk_tee_user/ta/testapp/8cccf200-2450-11e4-abe20002a5d5c52c.elf
  OBJDUMP /home/raimo/android-sources/khadas-edge-pie/external/rk_tee_user/ta/testapp/8cccf200-2450-11e4-abe20002a5d5c52c.dmp
  OBJCOPY /home/raimo/android-sources/khadas-edge-pie/external/rk_tee_user/ta/testapp/8cccf200-2450-11e4-abe20002a5d5c52c.stripped.elf
  SIGN    /home/raimo/android-sources/khadas-edge-pie/external/rk_tee_user/ta/testapp/8cccf200-2450-11e4-abe20002a5d5c52c.ta
  SIGN KEY /home/raimo/android-sources/khadas-edge-pie/external/rk_tee_user/export-user_ta/keys/oem_privkey.pem
Traceback (most recent call last):
  File "/home/raimo/android-sources/khadas-edge-pie/external/rk_tee_user/export-user_ta/scripts/sign.py", line 80, in <module>
  File "/home/raimo/android-sources/khadas-edge-pie/external/rk_tee_user/export-user_ta/scripts/sign.py", line 40, in main
    from Crypto.Signature import PKCS1_v1_5
ImportError: No module named Crypto.Signature
/home/raimo/android-sources/khadas-edge-pie/external/rk_tee_user/export-user_ta/mk/link.mk:65: recipe for target '/home/raimo/android-sources/khadas-edge-pie/external/rk_tee_user/ta/testapp/8cccf200-2450-11e4-abe20002a5d5c52c.ta' failed
make[2]: *** [/home/raimo/android-sources/khadas-edge-pie/external/rk_tee_user/ta/testapp/8cccf200-2450-11e4-abe20002a5d5c52c.ta] Error 1
make[2]: *** Waiting for unfinished jobs....
make[2]: Leaving directory '/home/raimo/android-sources/khadas-edge-pie/external/rk_tee_user/ta/testapp'
Makefile:37: recipe for target 'ta' failed
make[1]: *** [ta] Error 2
make[1]: Leaving directory '/home/raimo/android-sources/khadas-edge-pie/external/rk_tee_user/ta'
Makefile:27: recipe for target 'ta' failed
make: *** [ta] Error 2
make: Leaving directory '/home/raimo/android-sources/khadas-edge-pie/external/rk_tee_user'
[  9% 9834/100991] Build hyb out/targe...phenation-patterns/hu//hyph-hu.pat.txt
21515 unique nodes, 102669 total
ninja: build stopped: subcommand failed.
17:46:02 ninja failed with: exit status 1

#### failed to build some targets (12:11 (mm:ss)) ####

Any ideas what is going wrong here?

EDIT: Solved, my python installation was missing the module pycrypto.

I have tried with SD, it does not work.

I tried with usb-c I did not succeed too.

can this come from usb-c cables?


These are the instructions for Khadas Edge V to flash:

Get a USB C Male to USB A Male cable.
Then connect the USB cable to the top USB C port on Khadas Edge V and the other end to a USB port on your PC(avoid USB Hubs as they can cause problems).

Then press the middle button on the side(Function button) and hold it in, now press the button after it, first button towards you(Reset button), after 2 seconds release the first button.
(This is if the buttons are on the left side and the ports are facing towards you, if the buttons are on the right side and the ports are facing backwards then the 'Reset button is the last on on the right back side)

If you have AndroidTool open on a PC, it will say ‘Found Loader Mode’.
Now do ‘EraseFlash’, it is needed every time if you flash between different Android OS’s, but not the same OS.
Now click ‘Upgrade’.
After it finishes, wait 10 minutes or so before removing the USB cable and unplugging it.

It should now boot Android Pie.


My Edge-V is only showing the kernel logo but does not continue booting with both the Edge_Pie_V190626 firmware and Pie build from the sources. I did an EraseFlash before flashing Pie.

I installed the Edge_Pie_V190626 firmware before and it booted correctly.

Now Android Pie I built from the sources get stuck on the Rockchip kernel logo then the text appears below it and then it freezes on my Khadas Edge V.
I tried several times in MaskROM Mode, EraseFlash and Upgrade but it doesn’t help.
After removing power several times, it boots to Recovery and says system is corrupted, Do you want to erase and try again. I do then it gets stuck again on the kernel logo.

I just flashed the new firmware Edge_Pie_V190701 and same problem here (Edge V version 11). Getting stuck showing Khadas logo.

EDIT: Problem solved by updating driver and Android tool to the most recent versions. I hope it will also work from Ubuntu from now on.

must use a usb-a and usb-c 3.0
usb-c in the usb for edge v power supply, no need to add power.
when the tool is open, three click on the middle button.
the blue led will flash.as explained by khadas.

How is the procedure for Ubuntu? The instructions on https://docs.khadas.com/edge/UpgradeViaUSBCable.html do not work for flashing Pie via Ubuntu. Kernel boot logo problem again…

I wanted to test armbian, I did not succeed. yet I have a computer with ubuntu.
either by sd or better through ubuntu and sudo, I see that it

I want to test SSD (PCIE M.2) with build image of android PI but not able to detect. can any one help?

What board do you use (e.g. edge-v)? What is the model of the board (e.g. V11)? What is the name of SSD?

more than to know why kodi 17.6 or 18.3 does not open.


I am using edge-V
model number v13
SSD is NVME SSD 960 EVO M.2 from SAMSUNG 250 GB.

We only let the Edge-V V13 and Edge V14 for sales.

I will feed back the question you raised to the rockchip to solve, waiting for good news.

1 Like

Execute this command and see:

rk3399:/ # ls -l /dev/block/nvme*
brw------- 1 root root 259,   0 2019-07-03 03:49 /dev/block/nvme0n1
brw------- 1 root root 259,   1 2019-07-03 03:49 /dev/block/nvme0n1p1


kernel is creating nvme node but not able to see ssd storage on file explorer or storage section in android setting. I am able to mount it from console using block node.
do we need to make entry in fstab for auto mount?

rk3399:/ # blkid /dev/block/nvme0n1p1
/dev/block/nvme0n1p1: LABEL="NO_NAME" UUID="BE71-0B13" TYPE="vfat" 
rk3399:/ # mkdir /data/media/0/nvme
rk3399:/ # busybox mount /dev/block/nvme0n1p1 /data/media/0/nvme

1 2 3

Please check if there is a script that can be added or boot files modified on boot so it mounts automatically. I can then add it to my ROM.

If I use a USB 2.0 HUB(tried 3 different ones) on right USB port on Khadas Edge V then after a while a connected USB 3.0 Toshiba 1TB hard-drive seems to get stuck and not detected by file managers anymore, not sure if it’s a software or power issue.

I use the same hard-drive on Rockchip RK3229, RK3328 with USB HUBS and the hard-drive stays powered on and working correctly.

I can’t use the top left USB port as the hard-drive or USB keyboard dongle can’t fit in it if the case is on and the USB C power cable is connected in the bottom left USB C port.