EDGE Android Pie V191227 Rom Release

In addition, you can’t download it like that. Follow the README:

Gapps for khadas

About how to add Gapps support on khadas Edge SDK source code, You can follow the steps below

二、Edge board
1. Modify the file 'PROJECT/device/rockchip/rk3399/rk3399.mk'
<1> Change the property 'BUILD_WITH_GAPPS_CONFIG' from false to true
		 #Gapps Build Config

2. Download the google repertory into the path 'PROJECT/vendor/rockchip/'
<1> cd PROJECT/vendor/rockchip/
<2> git clone https://github.com/terry2droid/google google -b Pie

3. Build yourself ROM again
1 Like

Anyboby , The latest firmware has been released, see the beginning.

Anyboby , The latest firmware has been released, see the beginning.


Anyboby , The latest firmware has been released, see the beginning.

1 Like

Hi @goenjoy

You can perhaps upload these tools for Rockchip Android Pie maybe to mega or another host?
Users outside China have problems downloading from Baidu.

SDDiskTool_v1.57_SD for Windows
Link: https://pan.baidu.com/s/13XCiqUV_fp_MvpsNtNy3Uw
Extraction code: jmt1

SDDiskTool_v1.57_SD for Linux
Link: https://pan.baidu.com/s/1wLlexYUMQGUFkW2zSWT1YA
Extraction code: mg3a

The SDDiskTools v1.56 is not compatible with Android Pie, only Nougat, v1.57 is also compatible with Pie and also has a Linux tool, not just for Windows.


Please also check if there are newer updates for AndroidTool(v2.69) and FactoryTool(v1.66) too.
Above versions are from Rockchip-Linux Github but they are a bit old I think and not the latest.
The latest tools are always recommended to help fix flashing and boot issues.


There is no release at present.


Can you test if Android Pie firmware with SDDiskTool ‘Upgrade firmware’ box checked written to a micro-sd card can boot correctly on Khadas Edge-V, show the Recovery menu, upgrading in progress and finishes 100% to update firmware on emmc? When the updating finishes it doesn’t restart automatically and try to redo updating from the micro-sd card again and rather shows a message that the update completed successfully and allows you to remove the micro-sd card to reboot and load Android from emmc? If it has this bug, can it be fixed?

I just tested it. There’s BUG. Next firmware fix it. Thank you for your feedback.

1 Like


If you can test the SDDiskTool update/restore firmware from micro-sd to emmc and come up with a fix for the bug, please let me know.

1 Like

ROM Infos:

Version(Latest): Edge_Pie_V191205.7z Update List:
Anyboby , The latest firmware has been released, see the beginning.
Sorry, the update is slow. The next version will merge the latest rockchip patch


ROM Infos:

Version(Latest): Edge_Pie_V191227.7z Update List:
Anyboby , The latest firmware has been released, see the beginning.



the wifi does not turn on automatically when I turn on the edge V.
I have to go into parameter and force the wifi to connect.

1 Like

How to root Android Pie on Edge-V?

I have Magisk Manager, but when it downloads ZIP, it says “Unsupported/unknown image format” :neutral_face:


- Device platform: arm64-v8a
- Copying image to cache
2034+0 records in
2034+0 records out
2082816 bytes transferred in 0.030 secs (69427200 bytes/sec)
1410+1 records in
1410+1 records out
1443916 bytes transferred in 0.014 secs (103136857 bytes/sec)
- Unpacking boot image
Parsing boot image: [/data/user_de/0/com.topjohnwu.magisk/install/boot.img]
! Unsupported/Unknown image format
! Installation failed
1 Like

Flash Magisk zip via TWRP
 Build TWRP:https://github.com/rockchip-software/TWRP
 Build boot.img with ramdisk(refer to BOOTIMG_SUPPORT_MAGISK := true)
 Download Magisk.zip:https://github.com/topjohnwu/Magisk/releases
Installation step
 Flash TWRP(recovery.img) and boot.img by AndroidTool
 Push Magisk.zip to device
adb push /path/to/Magisk.zip /sdcard/
 Reboot to recovery
adb reboot recovery
 Install Magisk.zip via TWRP
 Reboot device
 Install MagiskManager
adb install /path/to/MagiskManager.apk



Managed to build boot.img and recovery.img, flashed them using AndroidTool.

ADB finds my device:

gytis@desktop:~$ adb devices
List of devices attached
P5CLE90HKP	device

But when I boot to recovery, there is no output in HDMI :neutral_face:

gytis@desktop:~$ adb reboot recovery

gytis@desktop:~$ adb devices
List of devices attached
rockchipplatform	recovery

So either TWRP doesn’t work or doesn’t output anything to screen…

Edit: I was using sources from Rockchip to build TWRP. Now I tried TWRP sources by Khadas team - with latter build succeeds and TWRP works :blush:

Since Kodi is not bundled into Android Pie build, any idea how to build Kodi for RK3399?

I tried running Kodi from Google Play store - it stutters on 4K :neutral_face:

Have you tried the custom firmware I made?

Kodi is working smoothly if you setup the resolution whitelist in Kodi Display Settings and enable ‘On start/stop’ in Video Playback Settings.

But I would suggest to use the latest version from here since they fixed H265 seeking and it includes the latest improvements.


Hello! I don’t have Edge, but I’m wondering, when playing a video, does the frequency and resolution automatically change?

Yes, if using my firmware.

1 Like

this is good ,since on vim3 these nuances can’t be done on Android,for this reason I watch videos exclusively on coreelec, where it all works perfectly :slightly_smiling_face: